Virtualmin 7 installer beta released

Howdy all,

I believe we’re ready to call the new installer beta. It works for us for GPL and Pro installs in testing on Rocky/Alma 8, Debian 11, and Ubuntu 22.04. It is still changing rapidly, but in minor ways at this point. A system installed with this will probably be pretty close to what you’ll get once we call it stable, assuming it works for you.

Please do not treat this like a stable release. If you’re using it on a system that will be put into production, you must test thoroughly first. There will be quirks. Our testing has been limited to confirming it installs fully and runs through all configuration steps correctly. It has had almost no functionality testing beyond that, and these new distro versions (Debian 11 and Ubuntu 22.04) are completely untested beyond installation.

If you are deploying to a distro supported by Virtualmin 6 installer, you should keep using that one for now. If you use this new installer, you are a beta tester, you are not a user. We will try to help with problems, but sometimes our answer will be to “start over” after we reproduce and fix whatever problems you report. Our focus now is on a few more days of a rapid text/fix cycle until we’re happy with it, and helping people use this on a production system is not amenable to going fast, so don’t ask us to do that.

Here’s the link for Virtualmin 7 beta install script.

It’ll probably change regularly during the final few days of development and testing, so be sure to grab the latest before an install.

Once again: If you are not looking to be a beta tester, you should not be using this installer. Install using the Virtualmin 6 installer on a Grade A supported OS.

One other heads up: We’ve found during our testing that Vultr instances in many regions permanently lose network connectivity when Firewalld starts, even a reboot does not restore it. We have no clue why this is so. It simply doesn’t make sense. But, it’s a thing you should be aware of. If you’re using Vultr, you may lose network connectivity during install at the firewalld step. We don’t have a solution or a workaround for this, but we’ve reported it to the Vultr folks. It isn’t us; the firewalld package installation all by itself breaks connectivity at least on Ubuntu and Debian but maybe only in some Vultr instance locations. So, until that’s understood or fixed upstream, we don’t have any ideas. Don’t waste your time or ours with this problem (unless you figure it out and want to tell us about it). It is known, but again, we don’t have solutions and I’m not inclined to workaround a bizarre behavior like this. Use a different provider (we’ve tested at Linode and on local VMs without issue) or try a different location (I have, in the past, been able to make it work on Vultr in some locations, but not others…Dallas consistently fails, Miami worked for me today, I have no clue wtf is going on). If you see this behavior at providers other than Vultr, we do want to know about it, though. It will look like the install freezes during either the “Installing dependencies and system packages” step (on deb-based distros) or the
“Configuring Firewalld” step (on RHEL-based distros).

No changelog or release notes yet. If you’re curious all of the installer and related packages are on our github, so you can see the commit history. Big ones are:

GitHub - virtualmin/virtualmin-install: Shell script to perform a Virtualmin GPL or Professional installation - The install script
GitHub - virtualmin/Virtualmin-Config: A modern rewrite of the Virtualmin postinstall configuration script - The configuration system (called by the install script for Phase 3 of the installation)



Well… perfect timing, I shall test it out tomorrow :slight_smile:

Just tried RC8 on an Alma Linux Vultr VPS in Australia (8.6). The Webalizer errors from RC7 have been fixed but it still shows out-of-date versions in red for Webmin and Virtualmin.
Looking to the future, RC8 installs without error on Alma 9.0 but you can’t log in from a browser. (RC7 crashed during install on Alma 9.0.)
Thanks to the team for all the effort going into this release.

@ilia, why are we still complaining about versions being out of date when newer versions are not available in the repos? I thought this had been fixed (several times?).

1 Like

On RC8 I still getting MariaDB getting configured incorrectly

You didn’t run into that issue?


I am not seeing the MariaDB issue (looking at an Alma 8.6 system on Vultr right now).

Note this is not an issue in the install script, so the RC number does not matter here. The MariaDB config issue is a Webmin issue. But, a Webmin issue I don’t think we’ve been able to reproduce.

Webmin doesn’t correctly identify what OS it is running on (or it thinks it is a much older version of some Red Hat), and so it copies the wrong files into place. i.e. it finds something that matches the OS description it finds in /etc/redhat-release before it finds the Alma versions.

The “RC7” had it working.


That’s a coincidence. I don’t know why it worked for you before (and why it worked for me today, and every other time I’ve installed on Alma). It’s definitely not the install script, though.

Webmin has its own OS detection wholly independent of the detection that happens in the Virtualmin installer. They don’t even share any code at this point (Webmin detector is in Perl, Virtualmin install OS detection is in POSIX shell).

I just installed 1/2 hour ago on vultr so weird. I’ll destroy and try again.


P.S. Should I do a webmin install and see what happens?
P.S.S. I’m using wget to download the script, is that your method?

That would isolate the problem. Mostly to convince you that it’s Webmin and not the install script. I already know it’s Webmin. :wink:

Yeah, that’s fine, and it’s how I get it most of the time. It doesn’t matter, though. Anything that downloads an exact copy (which would be, I think, any web client you could run on the command line on Linux). As long as you don’t download it in Windows, open it in a text editor that screws up the line endings, and then upload it to the Linux server…but, then you’d just get a bunch of syntax errors, you wouldn’t get a mostly working script that behaved differently.

Almost beer time, still fails, took some screenshot, ran in verbose mode.
Also I can workaround the issue but adjust the stop stop command and all works.

Excellent! I’ll try it out on my test server in a bit and report back.


Installing now. I love the line:

If your OS/version/arch is not listed, installation will fail.

Probably should have had that on every version since day one.

Installed perfectly. No errors.

Check the repos are set up.


Everything works perfectly. Everything is already “set up”. The installer does all of that for you. I’ve even got a Wordpress install set up. I’m going to convert one of my existing sites over to mariadb on the test server in just a bit.

Screenshot this please:

Been patiently waiting for this. Absolutely amazing! Thank you :smiley:

1 Like

Amazing what happens when you follow the simple three step directions.

That’s what I thought, thanks. No VM repos.