Upgrading to latest webmin version 1.990

SYSTEM INFORMATION
OS type and version Almalinux
Webmin version 1.984

Please will running this comman below upgrade my existing webmin installation without wiping my active installation of websites?

wget http://prdownloads.sourceforge.net/webadmin/webmin-1.990-1.noarch.rpm

yum -y install perl perl-Net-SSLeay openssl perl-IO-Tty perl-Encode-Detect

rpm -U webmin-1.990-1.noarch.rpm

I have tried using sudo dnf upgrade webmin but its not working rather it shows already install but what I see is version 1.984

Do you use Virtualmin also on that box?

yeah its both webmin and virtualmin on my dashboard

I already runned the first two command wget http://prdownloads.sourceforge.net/webadmin/webmin-1.990-1.noarch.rpm

yum -y install perl perl-Net-SSLeay openssl perl-IO-Tty perl-Encode-Detect
But want to be show am not deleting any current installation when I run the last command rpm -U webmin-1.990-1.noarch.rpm

Look in GUI Dashboard then
Software Package Updates
then:
[Package Repositories]

What see you there? about virtualmin package ( you should have no webmin package there !!! )

Refreshing Packages

" [usermin]( version 1.834-1** Virtualmin-universal
[webmin]( version 1.990-1** Virtualmin-universal

virtualmin (RHEL/CentOS) Yes http://software.virtualmin.com/vm/6/gpl/centos/$releasever/$basearch/
virtualmin-universal (Virtualmin Distribution Neutral Packages) Yes Index of /vm/6/gpl/universal

"

I do not see anything webmin package

That is ok you should not see a webmin package, but the virtualmin package there are the webmin and usermin udpates from, so you should see i think what i posted and see in my dashboard alma8x

refresh packages and so on

And not do it manual by downloading webmin package while is total wrong way!

I dont see those options you stated

Then something is probably wrong, or looking at wrong place but can’t help, i am not from support

Put in versions you have in starttopic also from virtualmin and the os / alma , maybe someone else coould help

It looks for me you didn’t follow the installation instructions at initial installation

Location for virtualmin package is not in sourceforge for example but
Index of /vm/6/gpl/universal (virtualmin.com)

and :sweat_drops: Index of /vm/6/gpl/centos (virtualmin.com)

See screenshot but not showing any packages

And in TAB: there
[Package Repositories]
This page allows you to configure which respositories will be used for new or updated packages.

i solved this by downloading and uploading it manually. Thanks

That’s hardly a solution. You should figure out what’s wrong with your yum repo configuration.

Thank you mentor. But I dont know how to do that as I have run this for two years now with no issue. Currently I have resolved every other issue remaining cpu fluctuation from 10 to 50 to 70 back to 10 and seconds after will move to 100%

Please open new topics for new problems.

1 Like

Ok. Thank you.