Webmin stuck at 1.991, Virtualmin 7.0 and Usermin 1.840

SYSTEM INFORMATION
OS type and version CentOS Linux 7.9.2009
Webmin version 1.991
Virtualmin version 7.0
Usermin version 1.840

on one of my servers, Webmin, virtualmin and Usermin have all turned red and stopped updating. i’m having to handle this by default, but as i am not really a sysadmin type, please use small words. :slight_smile: .

anyway, the closest (partial) answer i’ve found is: Upgrading to latest webmin version 1.990 - #4 by jotst
but the original poster manually upgraded his webmin before jotst could finish walking him thru how to fix this problem. hopefully it can be picked up here.

answering jotst quaestion regarding the [Package Repositories], i have the following
virtualmin (RHEL/CentOS/Scientific) Yes “http://GPL:GPL@software.virtualmin.com/gpl/rhel/$releasever/$basearch/
virtualmin-universal (Virtualmin Distribution Neutral Packages) Yes “Index of /gpl/universal

any help is greatly appreciated

Download the latest installer from https://raw.githubusercontent.com/virtualmin/virtualmin-install/master/virtualmin-install.sh
the run sh ./virtualmin-install.sh --setup
the setup option updates to the latest software repositories.
Refresh the the software packages and you should get the updates.

thanks. i’ll try this this weekend.

do i need to worry about backing up any settings? or will the install script migrate these for me?

As long as you only use the --setup option, the install script is not doing any installation or service configuration (which would be dangerous) and so backing up config files is not necessary or useful (though I’m assuming you keep regular backups). It is only changing your software repo configuration.

The install script never backs up configuration. Using it in --setup mode is reasonably safe on a production server to update the Virtualmin repos on the system (after making any changes to software repos, you should always pay close attention to updates afterward to make sure dependencies haven’t changed in ways that would affect you, that is true of any repo change, not just this one). Using it in any other mode should never be done on a production server.

Going from the very old install repos to the new ones is reasonably non-disruptive, as the way dependencies were handled in our packages is different, so there’s no conflict. virtualmin-base no longer exists in our new repos, which is how your dependencies were installed, so there is no risk of an update breaking anything.

1 Like

thanx! i’ll give it a try this weekend. i appreciate the help

i ran:
/usr/bin/wget https://raw.githubusercontent.com/virtualmin/virtualmin-install/master/virtualmin-install.sh
then
sh ./virtualmin-install.sh --setup

i ended with the message in the attached image. and i still cannot find anywhere to update anything

Webmin-System-Software Package Updates.
Click Refresh Available Packages.

image

i’m wondering if it’s related to the install script installing “Virtualmin 6 GPL” while my server is already on version 7.0

but there is still nowhere in the Webmin GUI to update

No that fine. I get that when I run it.
image

Not sure why then.

No. Has nothing to do with it.

The Virtualmin 6 repos have the virtual-server (Virtualmin) 7.x module package.

1 Like