SSL issue only with website landing page

I migrated from cPanel to Virtualmin and the SSL certificate issued by cPanel is still valid and seems to be working on my current Virtualmin setup.

My website is run using WordPress on the same virtual server.

Only issue my website is facing is that the home landing page always gets marked as “Not secure” on all the browsers, but if it is a sub-section of the website it shows as fully secure.

For example: (shows as not secure) (shows as secure)

Any advice on how to fix this? Thanks!


If you have your main page loaded using https, then the most common reason why it might happen, is that because requests made from that page (main page in your case), to some non-secure (http) web-sites.

You can get more info by opening browser’s console.

Hi, I checked the page source code in the browser directly by doing ‘View page source’, seems no http:// requests, everything is https.

Before migration from cPanel this issue did not happen, so the same page was working in cPanel securely

I personally have always had problems with migrated cpanel accounts. They have never worked properly for me in virtualmin.

There seemed to be some critical issue with WordPress itself after migration from cPanel, I was getting a number of errors in WordPress (some plugins not working etc.)…

So I went ahead and re-installed WordPress now, did a fresh Install Script of WordPress from Virtualmin and restored all my content and files. Now Wordpress seems to be working perfectly and I never get those critical errors anymore.

I also made sure redirection is properly set on my site using the below instructions I found online:

  1. Went to “Webmin > Webmin Configuration > SSL Encryption”
  2. Changed “Redirect non-SSL requests to SSL mode?” to “Yes”
  3. Went to “Virtualmin > System Settings > Virtualmin Configuration”
  4. In the “SSL settings” column, selected “Yes” for “Redirect HTTP to HTTPS by default?”
  5. Located “Configure Websites” under “Services”
  6. Clicked “Edit Directives” and looked for “RewriteEngine On”
  7. Then under “RewriteEngine On” pasted the following rule:
    RewriteRule ^/(.*) https://%{HTTP_HOST}/$1 [R]
  8. Restarted the server.

For any other page, my site works perfectly now, but for the home page even though it loads as https it still says “not secure”, here is my actual domain so can see what i mean (shows as not secure) (shows as secure)

In addition to doing all the above, I went ahead and applied for a new certificate via Let’sEncrypt using Certbot, the new certificate is working throughout the site, however my original problem is still the same ( shows as not secure).

Out of ideas now…

Your front page is trying to load:, which takes forever and finally fails. It’s also why this page takes so long to finish loading.

@webwzrd, thank you! It turned out to be a problem in the actual WordPress page, I fixed it directly in WordPress.

All working fine now, cheers.