Post-Install Let's Encrypt Disconnect Error

Ubuntu Linux 20.04.1
Webmin version 1.962
Usermin version 1.812
Virtualmin version 6.14
Authentic theme version 19.62
Softaculous Virtualizer VPS

My Ubuntu Install, OS Upgrade, Virtualmin installs installed without issue.

When going through post-install config, I hesitated to run the Let’s Encrypt because I did not know if I had all my domain records setup correctly ( Yes, I am a Noob, but not getting into hosting, but love Webmin for the great interface to use as a server tool for setup and administration. But, in a friendly way it is my last apology for learning something new and being green to this. :slight_smile: )

But, I refreshed the page and I was still logged in and it accepted my other settings, MySQL Password, etc… and I think it just failed the SSL Let’s Encrypt portion.
I’m confused what to check. I have some sort of Https- see screenshot.
At my main domain web hosting I have my domain and the app.wayneburlingame sub-domain with Let’s Encrypt installed without errors, but I am not sure what I am missing to fully get https without the red text https error at url?

This is a non-production issue as stated earlier, and I am learning your product… Which ROCKS by the way. :slight_smile:

I did also find this [post](How to get SSL cert applied to port 10000 (Webmin + Virtualmin) and 20000 (Usermin) - General Discussion - Virtualmin Community ) and followed Calports guide:

Have you restarted Apache?



Happy New Year!

…and I am learning your product… Which ROCKS by the way.

Thank you for your kind words!

but I am not sure what I am missing to fully get https without the red text https error at url?

Unfortunately this is a known “issue”, which as far as I am aware cannot be solved in a straight-forward way at the moment. This problem arises when you try to enable SSL on default server (domain), which is currently being used with Virtualmin to connect. In other words, when your URL has and you’re trying to setup a self-signed certificate for at that post-install step, a SSL certificate is getting changed, and you technically get a new certificate warning, which needs to be confirmed, however connection is made in a background and it’s not happening.

The simplest solution would be is to just hit reload button and refresh the page, confirming new certificate and re-starting post-install wizard. A better work-around would be is to open another tab on the same browser, enter the URL from the current tab to a new, open the link and confirm newly re-generated self-certificate to be safe to use. Later go back to the old tab with post-install page, close the red warning modal window and click next for post-install wizard to continue.

This problem must not be happening with Let’s Encrypt option, in case a certificate is successfully issued but only with self-signed certificates.

I will look into the ways of improving it and adding a better warning message with explanations for this wizard step in particular, on what could be done to overcome this issue, as of now it is very confusing.

Thanks for the heads up!

This topic was automatically closed 4 days after the last reply. New replies are no longer allowed.

Considering that there is no straight forward solution for this problem, as until a self-signed certificate is accepted by the user, the browser locks down all requests made in the background.

The example of how it will work for the wizard page and for the other pages on which SSL certificate for the currently used domain may be changed. It’s not perfect but considering the situation, I would say it’s – good.

It will show an extra check message with a clickable link, assuming that if it happens on one of those pages, where SSL certificate may potentially change for currently used domain, with a stylish, convenient ans straight-forward to use pop-up.


1 Like