How to get SSL cert applied to port 10000 (Webmin + Virtualmin) and 20000 (Usermin)


I have a VPS Server which is accessible as http://vm39483. abchost .net/10000

Although, I have bought SSL for the domains hosted on virtualmin server and have applied to webmin and virtualmin.

Despite that access to https://vm39483. abchost .net/10000 shows as insecure (says NET::ERR_CERT_COMMON_NAME_INVALID)

I need to know whether existing domain SSL gets applied to the virtualmin login access point i.e https://vm39483. abchost .net:10000 OR I need to get a new SSL and apply to the login url domain i.e vm39483. abchost .net

I would be most glad to get some reply to my problem.


No, you do not need to get a new certificate for port 10000. After you had applied the certificate, did you use the following screen to configure Virtualmin to use the certificate on port 10000 (Webmin + Virtualmin) and 20000 (Usermin)?

Use above method or you can simply request new SSL for server from Webmin Configuration.

Webmin > Webmin Configuration > SSL Encryption > Let’s Encrypt > Request Certificate

Please be aware @bs981 that if you request a SSL cert (from Let’s Encrypt) then you will not be using the SSL cert’s that you have bought.


Yes, I have applied in the same manner as shown in the pic. However, my domain helios7. com shows up in the virtualmin drop down. I cannot see my vps address i.e in the domain selection drop down [as it is showing in the image you sent]. In my case, I only see my domain i.e helios7 .com and one more domain.

I have applied certificates from Helios7 .com

Please let me know if there is something I need to do to get my show up in the drop down there?


If the mentioned domain is the host system itself, then you won’t see it there. You can access the configuration in the webinterface itself for it. There is no specific VS entry for it.


Can you please guide me how to apply SSL on the main virtualmin login url i.e

vmi411011. contaboserver. net: 10000 [pls remove spaces]



I havent yet found solution to my problem. I would request to keep this post active.


I used the “Copy to Webmin” and Usermin and all that and it still doesn’t work. It works on all my servers, but not on port 10000 or 20000. Even when I go to Webmin itself and look at the SSL settings for Webmin, it shows that it’s using my VPS certificate.

It still doesn’t work though and never has, so I left it alone and have been just living with it ever since.

Webmin -> webmin configuration -> ssl encryption (or similar).

How are y’all making this so complicated!?!? :wink:

Just contact Webmin and Usermin on a domain name that has a working cert. Don’t fiddle with it. Just use it the way it was intended to work…i.e. if you’re hosting example.tld on your server, and it has a working TLS certificate, then browse to https://example.tld:10000. It will use the cert for that domain.

1 Like

Of course it can be done like that and that is the easiest way. :slight_smile:
But please don’t get me wrong, it’s just not what he asked for. That’s at least why I posted what I thought might help. :sweat_smile:

1 Like

I was trying to get SSL implemented on virtualmin, but it is showing “ERR_CONNECTION_REFUSED” now

Surely the SSL has not been installed correctly. Also I added I.P addresses of my internet provider in order to secure virtualmin login url under “IP Access Control”

It was surely a bad move to make two changes at the same time, but I do have a back up of virtualmin configuration file. I copied old miniserv.conf file and few other files in /etc/conf/ folder and /etc/conf.d/ folder

Contabo Support wants me to re-install virtualmin, but I know lot of settings go into virtualmin. So trying my best to restore it somehow

Any suggestions on how to get out of this new problem ? I would greatly appreciate your suggestions.


If you want proper help, then you should provide more details.

Please let me know what details I need to provide. I am willing to share all information required.

How about starting at the beginning? You said you did this and that and restored here and there.
Start from the beginning.
Which OS? Which versions from virtualmin /etc? Where do you get the error message? How did you restore?

Undo the IP Access Control change you made and see if you can connect again.


I have done following:-

a) Restored virtualmin using putty commands from the backup.

This has helped to resolve the IP access issue, but I am seeing strange view in the virtualmin.

I am attaching the view of virtualmin after logging into the virtualmin.

When I click on any link it gives 404 error. Please see below

I need to know following

  1. Is it error related to the virtual min authentic (default) theme or something else.
    2)Is there any way to Re-install Webmin/Virtualmin without losing existing settings?
  2. Can theme be upgraded with a new one using Putty commands?

Please let me know


Nevermind. Answered my own question.

I am able to log into the server now but theme seems corrupted. The display is strange in the virtualmin