PHP FPM - Do not work

Hi there,

We have been using FPM method for PHP execution. What we are struggling is with the settings to stick per domain. for ex: setting the execution time… we have to do this in the .ini file inside of /etc/php/ folder… per domain config file gives error and crashes the FPM

We went through this… : Changed max_input_vars but no effect - Virtualmin - Virtualmin Community

Here are some of the screenshots for your analyses.


SYSTEM INFORMATION
OS type and version Debian 11
Webmin version latest
Virtualmin version latest
Related packages SUGGESTED

@staff

@Ilia - Can you look at this issue of mine… i am mostly certain this is some config issue on the server.

@masterg0g0 For the Maximum execution time (i.e. max_execution_time) to work as expected, you should set Maximum input parsing time (i.e. max_input_time) option to -1 in Services ⇾ PHP-FPM Configuration: Resource Limits page.

@Jamie, for PHP execution time to work properly, we should set max_input_time to -1. I think you considered it back in time, and this is still what the default should be according to the PHP documentation, but it appears that it’s not, and the default is set to 60.

I suggest that every time we change max_execution_time using PHP Options we set max_input_time to -1 as well.

But the problem is per domain values… while using FPM mode… they dont work… and it crashed the FPM server… if i try to add any PHP config values. The execution time was not in question more of the _vars variable,

Can you show your domain PHP-FPM pool file?

The commented line fails if i activate it…

Try using UI to change settings in Services ⇾ PHP-FPM Configuration page:

It should be written as:

php_admin_value[max_input_vars] = 6000

would have great if this “php_admin_value[max_input_vars] = 6000” could be given inside of GUI

Thnx

Sure, nice suggestion. We will add it.