Ghost Blog Script Install Failed. Partially Installed

OS type and version Ubuntu Linux 22.04.2
Webmin version 2.013
Virtualmin version 7.5 Pro
Related packages Ghost version 5.26.3

I installed and worked with Ghost blog on a dev svr successfully. The production svr has been installed with Ubuntu and Virtualmin last week. I have repeatedly attempted to install Ghost from the script and manually. It seems to fail after running for about 1 minute 38 seconds each time because, it seems, it cannot reach a remote server. I will include some of my documentation of the failed process below.

Install failed 1 minute 39.47 seconds after clicking on Install Now:

Install Script
In domain
Downloading (32.32 MiB) …
Received 1 KiB (0 %)
Received 3.23 MiB (10 %)
Received 6.46 MiB (20 %)
Received 9.69 MiB (30 %)
Received 12.93 MiB (40 %)
Received 16.16 MiB (50 %)
Received 19.39 MiB (60 %)
Received 22.62 MiB (70 %)
Received 25.86 MiB (80 %)
Received 29.09 MiB (90 %)
Received 32.32 MiB (100 %)
… download complete.
Found in cache …

Now installing Ghost version 5.26.3 …
Ghost installation failed:

More information on using this script can be found at
Installation can be continued manually at

… installation was only partially complete.

Manage Script
In domain
This page can be used to un-install a script, or upgrade it to the latest version. If you un-install, any data files and databases associated with it will be lost.

Details of installed script
Script to install Ghost
Version to install 5.26.3
Original website
Partial installation error Ghost installation failed:

Installed URL
Installed on 03/26/2023 11:29:56 PM
Installation directory /home/saverino/public_html
Server assigned ports 3000
Server status Running

Below is a screenshot of the installation directory:

Below is part of a log file from the Internet Server: /home/saverino/.npm/_logs/2023-03-27T02_07_10_067Z-debug-0.log

41 verbose cwd /home/saverino/public_html
42 verbose Linux 5.15.0-67-generic
43 verbose node v16.19.0
44 verbose npm v8.19.3
45 error code EHOSTUNREACH
46 error syscall connect
47 error errno EHOSTUNREACH
48 error request to failed, reason: connect EHOSTUNREACH
49 verbose exit 1
50 timing npm Completed in 79603ms
51 verbose unfinished npm timer reify 1679882830290
52 verbose unfinished npm timer reify:loadTrees 1679882830296
53 verbose unfinished npm timer idealTree:userRequests 1679882830316
54 verbose code 1
55 error A complete log of this run can be found in:
55 error /home/saverino/.npm/_logs/2023-03-27T02_07_10_067Z-debug-0

Tried installing from command line. Got the same kind of cannot connect error:

One difference between the dev svr and live svr is how PHP is installedd:
dev svr
PHP 8.1 Configuration

Production svr  
	PHP-FPM Configuration

PHP setup per - PHP FPM - Do not work - #6 by masterg0g0

Any ideas about how to overcome the install failure will be greatly appreciated.

OS type and version Ubuntu Linux 22.04.2
Webmin version 2.013
Virtualmin version 7.5 Pro
Related packages Ghost version 5.40.2

Many thanks to Ilia who updated Ghost install script to Ghost v5.40.2. Ghost has installed successfully.

I deleted a couple of follow up entries in this post that had no relevancy to the issue.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.