Mailman virtualmin modul

OS type and version centos7
Webmin version 1.990
Virtualmin version 6.17 pro
Related packages Mailman 2.1.34

i have made a mailman list and a test list on commandline, both are not shown in the mailman virtualmin module. i can reach the webconfig for mailman but not via the virtualmin module.

You need the Webmin module. On top of my head I cant remember the link. Try to search. I used CentOS 8 and webmin module worked for that. I am not sure about CentOS 7. Perhaps others may know and will reply. I currently use Mailman v2 on a CentOS 8.5 that was converted to AlmaLinux. Mailman still works fine albeit old version.

What error do you get, if any?

Oh, but also, the Virtualmin module only cares about lists it creates. If you did something on the command line, it’s not Virtualmin’s concern.

ye si try both in virtualmin also

when i create a new list it shows no error it goes to the same page again with no errorcode. but i can found the new list in the commandline

3 Passende Mailinglisten gefunden:
Mailman - [keine Beschreibung verfĂĽgbar]
Mylist - [keine Beschreibung verfĂĽgbar]
Testlist - [keine Beschreibung verfĂĽgbar]

the mylist is createt with virtualmin

also the mailman list are not shown but in the commandline.
and when i will access the url from the email, like this:
i have a - You are not allowed to manage this list

How did you install the Virtualmin module, via yum search wbm-virtualmin or elsewhere? Is mailing list link showing in Virtualmin at all?

If you created the list via command line, a user/password should be set, same as via Virtualmin panel.

via the webmin module admin

yes i have set the user amd pass

now i have removed the modul via the webmin moduladmin and have reinstalled the modul via yum install wbm-virtualmin-mailman. I have createt a new mailman list, and this is not shown in the mailman wbm module, i recieve a mail with a link,
You can configure your mailing list at the following web page:


The web page for users of your mailing list is:


both links says i have no permission to admin this list. but this is the mailman list ???

the forward is https://domain:10000/virtualmin-mailman/unauthenticated/admin.cgi/mailman

i have also try to change the user in the module config from apache to nobody, same result

Similar thread Mailman plugin download (version) maybe it’s the version

i have installed the 6.10 version but when i go and check the version under webmin modules its still the 6.9 and the issue is not gone.
Bildschirmfoto 2022-03-07 um 23.33.31

the module config

Just double checked mine and version I use is 6.9 but on CentOS 8, I don’t know if CentOS 7 is using a different version. By any chance, if you switch theme language to English - does that make any difference at all? in terms of what is being displayed/ options / features that can be seen.

/usr/local/mailman seems wrong? Did you really install mailman from a tarball instead of from a package?

this is the right config, so now i can see the lists and i can change paswords and add new lists, i will try all funtions tomorrow.