Annoying update message but can't find the package. New install on Rocky 9

OS type and version rocky 9
Webmin version 2.013
Virtualmin version 7.5
Related packages can’t find

Seems to be a “falsepositive” anyone else run into this issue??


Log out and then back in again.

Yeah done plenty of that as I’m doing shutdowns and snapshots so i can go back in case I see wanna fix something.
Fresh keeps keeps saying
Re-fetching available packages …
… found 1 possible updates but shows no package. Yum clean all doesn’t help either.


What about dnf update in an SSH session?

yep, update and upgrade. nothing to be done.

sound familiar - It was identified as a caching issue. However it was a reboot that fixed it - pretty drastic I know! :person_shrugging:t2:

I tried that. I might try rocky 8.

This has nothing to do with the OS, it happens to all because it is a cache issue.

In your dashboard upper right corner icon “Force to refresh system information” should do the trick.

1 Like

Ive done all that.

Ok, this maybe a bug, I just did a fresh install on Rocky8. This package update notification happen due install. And Refresh show 1 “possible” updates. But then back to updates says "No packages available to be updated were found. " no refresh or clearing cache can get rid of this message. It would be good if someone to fire up a new Rocky 8 or 9 or even just a new Install on any OS and see if they get this issue cause I’m thinking its a bug. screenshot.

still there, and I will refresh top right, refresh page reboot yum update , still there

Well, they’re not new installations, but I did get a sudo update on all my Rocky 8.7 servers today. Maybe it was revoked?

It’s kind of puzzling because my understanding was that that screen is basically a GUI for dnf.

Do you have any unusual repos enabled?


Reverted to a clean install of RHEL9, ran dnf update, installed Vmin - no updates show anywhere.

Its a clean VPS install on vultr. I said it was a new install. Standard install no playing with anything.
As soon as the server is ready I run install script, first screenshot shows the the beginning of the VM install.

I don’t have access to RHEL9 on vultr, I’d don’t think I would use it anyway.

You would use the Upload Custom ISO option, but I haven’t tested it.

I tried it on BinaryLane but the system is broken and they can’t be bothered fixing it, or even answering support emails.

RHEL is a bit of a pain with their Registration system though, so Rocky/Alma would be a bit less hassle. On the other hand, it’s the original which the others copy.

Yeah, I don’t like the ISO install method, to much setup to do just get to the VM install, here now I just login and all updates and network is ready to go. And isn’t RHEL just free for developer and individuals?

Solved, its was a Vultr repo, Once I disable it and refresh packages there is no more “possible” updates. Now I got to work out if it is needed or not.


I have the same issue with fresh install on Centos 9 Stream. I just ignore it at this point.

Its was a repo Vultr my VPS supplier added, maybe its the same. Just disable the repo and refresh the packages.

I was able to reproduce this (also on vultr), but I don’t think we can fix it. It is something weird about the vultr repo, maybe?

Here’s what I see when I do a check-update:

# dnf check-update
Last metadata expiration check: 0:05:22 ago on Fri 03 Feb 2023 11:36:14 PM UTC.
Obsoleting Packages
cloud-init.x86_64                                       97225:22.4_62_gcb128dc_cb128-97225                                   apprepo      
    cloud-init.x86_64                                   99191:22.4_83_g7d57fcf_7d57-99191                                    @@commandline
cloud-init.x86_64                                       99191:22.4_83_g7d57fcf_7d57-99191                                    @@commandline
    cloud-init.x86_64                                   99191:22.4_83_g7d57fcf_7d57-99191                                    @@commandline
cloud-init.x86_64                                       99191:22.4_83_g7d57fcf_7d57-99191                                    apprepo      
    cloud-init.x86_64                                   99191:22.4_83_g7d57fcf_7d57-99191                                    @@commandline

But, then a dnf update:

# dnf update
Last metadata expiration check: 0:06:00 ago on Fri 03 Feb 2023 11:36:14 PM UTC.
Dependencies resolved.
Nothing to do.

It may be that we’re interpreting that Obsoleting packages thing wrong. I don’t know what it means. But, I can’t update/upgrade cloud-init, so it seems like something it should not be considered a viable update.

1 Like