After upgrade webmin 2.013 and virtualmin 7.5 not show filemanaber in virtualmin section

I just checked and it does disappear!

For virtual servers that have web services disabled (in Virtualmin → Edit Virtual Server) the file manager option becomes invisible.

You are right, @Joe, it could be useful to have the file manager around since there could be other files in a user’s directory that he might want to access even if web services are disabled for that virtual server. #feature-request

If @milonroy is unable to see the file manager menu option in Virtualmin, he should check if this is due to web services being disabled.

1 Like

That’s a bizarre behavior. I’ll ask @Ilia why that happens. I can’t think of any reason to tie File Manager to web service.

I also cannot tell for sure without knowing more.

Possible solutions:

  1. Clearing cache in the right side slider (cog icon under Dashboard tab)
  2. Force reloading browser’s cache by hitting Ctrl+Shift+R
  3. Force reloading Webmin using /etc/webmin/restart-by-force-kill

But honestly I cannot think how it could be all related.

I have a new build and seeing this as well.

Could you please provide the screenshot displaying the problem?



If I tick it again the file manager returns.

I also see it. @Jamie it seem like a bug in a new chained feature mode.

Not sure if this is related, but I can’t turn SSL back on, this is a test machine so no biggy for me. I get this error
certificate and key do not match : Certificate data is not valid : Modulus=No modulus for this public key type
I tried requesting new certs and that went through fine but ssl server still wont start, producing the same error.
P.S. I will load again from the snapshot and see if it is.

@stefan1959 yes exactly same issue for me, need the solution please

I don’t see the connection between whether a website or SSL is enabled, and the file manager feature. The file manager should be visible all the time, and that’s what the current code does…

I know but its happening, the error only happens when the Apache website enabled is unticked and then ticked. I tested twice on a new install.

Oh, I see the bug here. We will fix it on the next Virtualmin release.

Thanks for the heads up!


@Ilia what was the fix?

@Jamie, here is the fix.

Any idea of when that will be?

Sorry, we cannot provide any ETA.

This worked, thanks!

Good to know, thank you!

I was going to try and patch but I see totally different coding for line 11913.

same with me