File manager has gone

The status of your system is being checked to ensure that all enabled features are available and properly configured …

Your system has 7.51 GiB of memory, which is at or above the Virtualmin recommended minimum of 1 GiB

MariaDB 5.5.68 is installed and running

Using network interface enp3s0 for virtual IPs

Default IPv4 address for virtual servers is

External IP address for DNS records is set to, but the detected external address is actually This may cause DNS records for Virtualmin domains to point to the wrong system

Disk quotas have been disabled in the module configuration

Shell for FTP users is not included in /etc/shells, which may prevent FTP access

All commands needed to create and restore backups are installed

The selected package management and update systems are installed

Chroot jails are available

The feature Administration user cannot be disabled, as it is used by the following virtual servers : lvh.test beds.test quicksarchery.coduk next-axis.test villebeds.test lucky.test quicks2020.test pds.test quicks.test wp.test oc15.test vetus.test front.test fiabwoo3.test vetus-shop.test fiab.test portz.test oc2302.test wvb.test wvb2.test testy.test rar.test mtx.test new.test joomla365.test os2ce.test stc.test storefront.test joomla394.test pash.test wppac.test sch.test

… your system is not ready for use by Virtualmin

Sorry I haven’t done this very well, my Centos 7 system is just used as a local server. It’s been good for ages but now I am having trouble File Manager has disappeared from Virtualmin and I can’t get past the above text after a re-check. Please help - thank you.


*** welcome back to the community ***

Is this a new system, or older one? Also which version of Virtualmin, Webmin, and Usermin are you running presently?

That’s pretty old. I think it was end of life 3 or 4 years ago. The current version is 10.6.12.

That’s not too good either. I think that will be end of life next year.

If that server is that old across the board, it’s no wonder you’re having issues. You should try to get everything updated as much as you can and see if that helps you out.

Thank you. CentOS 7.9.2009, Virtualmin 7.5. gpl & Webmin 2.013. It dates from January 2018. I’ve been using Virtualmin and either Ubuntu or Centos for my php/mysql work for much longer , I normally break it down and start again when faced with this kind of trouble but there are some useful relics on this machine. The Kernel has updated 5 times and I’d always thought that everything would get updated over time so this will be a useful lesson for me. What do I need to do?

Don’t tell people to upgrade away from the versions of packages provided by their distro. This is the CentOS 7 MariaDB version. It is fine, and maintained by Red Hat.

No one should be doing new installs on CentOS 7, but it is currently supported. No reason to panic…but, a plan for moving to a newer distro should be hatched within the next few months.

CentOS 7 is fine. You don’t need to panic to get off of CentOS 7; you obviously shouldn’t be doing new installs on CentOS 7, but it is currently supported both by us and the upstream CentOS folks. Don’t do anything rash to try to upgrade stuff like MariaDB.

And, of course, none of that has anything to do with File Manager. There’s a bug in Virtualmin 7.5, that effected a small number of people, but I don’t remember the details. I know it was discussed here, and a solution offered, though…maybe a search will turn it up.

1 Like

It’s pretty much exclusive to CentOS7 from what I’ve seen, hence my statement.

This thread has a fix on it. Actually, there’s two in it - one guy fixed his by just clicking and unclicking Apache Website Enabled. The other is code on Github.

1 Like

No, that was happening on a new install of Rocky9, its a bug in the code not the OS

this is the patch

1 Like

The actual original post of that thread was on CentOS 7 with the same exact issue.

Yep, at the time i was moving to rocky9 and I tested the issue on that, as I was using a snapshot.

The fix would is to apply the patch or temporarily enable website feature for the domain in Edit Virtual Server page.

I tried both fixes, still no File Manager sadly.

I’m wondering if the ‘… your system is not ready for use by Virtualmin’ message might provide a clue with this issue.

I’ve just noticed there are many options below Server Configuration missing such as Domain Key Options, Edit Proxy Website, Email Settings, PHP Options, Spam & Virus Delivery and Website Options.

Assuming that it’s the last message that triggered the failure, I am at a loss to know what to do about ‘The feature Administration user cannot be disabled, as it is used by…’

You don’t see File Manager in master administrator login or server owner? If latter, you need to also make sure that it’s enabled in System Settings ⇾ Server Templates: Edit Server Template / Administrator's Webmin modules.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.