After upgrade webmin 2.013 and virtualmin 7.5 not show filemanaber in virtualmin section

This worked, thanks!

Good to know, thank you!

I was going to try and patch but I see totally different coding for line 11913.

same with me

Line numbers don’t matter here, just search for the line in red from this commit:

1 Like

Ok, that one line patched fixed the Filemanager, but when I enable apache again I still get the error

“certificate and key do not match : Certificate data is not valid : Modulus=No modulus for this public key type”
In the edit virtual server I now see Apache SSL unticked

I tick it I get the error again.

P.S. The on way I can fix is backup the virtual server (the one effected), delete the server, restore server enable ssl and request new certificate.

If you go to Server Configuration ⇾ SSL Certificate page what is the path for SSL certificate file and SSL private key file options? Back those files up (and other ssl.* files in the directory mentioned on the path) and send it to me in a PM. Then delete all those files manually, and re-enable Apache SSL website feature immediately.

We will create a feature on Virtualmin side to automatically handle this problem.

Its a snapshot I have at vultr, I’ll restore tomorrow and send. Will I send it when its in the error state?

Yes, exactly. I’d like to have those certificates in “error state” please.

This issue will be fixed with the next Webmin release.

It it possible to make it work using this patch:

… and re-requesting Let’s Encrypt SSL certificate.

1 Like


when i click to Server templer-default-php-option theire was show only Default PHP exection mode = mode_php their was no change option to fpm please help me.

how to i change the option ?

This issue is unrelated. But I think you didn’t install Virtualmin using the recommended way with script.

@Ilia it only update from 7.2 to 7.5 after that it created this issue and also this is live server so how i resolve this issue without downtime with existing running all site ?

You need to install the following PHP packages:

dnf install php-{cli,fpm,pdo,gd,mbstring,mysqlnd,opcache,xml,zip}


apt-get install php-{cli,fpm,pdo,gd,mbstring,mysqlnd,opcache,xml,zip}

And then change all virtual servers to PHP-FPM and remove mod_php completely afterwards.

in this server already multi php installed 5.6,7.0,7.1,7.2,7.3,7.4,8.0 and 8.1 with php-fpm and some application run with php 5.6

@Ilia any solution?

Please show me the list of all installed packages that contain php word.

@Ilia i have already provide above all screenshot include all multi php installed list