When installing 'ondrej' PPA for multiple PHP versions, should install 'ondrej' Apache also?

Virtualmin recommends the ‘ondrej’ PPA to install multiple PHP versions on Ubuntu Virtualmin servers.

When do that that though, ‘ondrej’ says you really should install at his apache2 PPA to go with it, kind of implying PHP<->apache compatibility issues if you don’t.

"CAVEATS:

  1. If you are using php-gearman, you need to add ppa:ondrej/pkg-gearman
  2. If you are using apache2, you are advised to add ppa:ondrej/apache2
  3. If you are using nginx, you are advise to add ppa:ondrej/nginx-mainline
    or ppa:ondrej/nginx"

But possibly with some caveats that less well tested and missing some modules or maybe some Ubuntu tweaks.

“This branch follows latest Apache2 packages as maintained by the Debian Apache2 team with couple of compatibility patches on top. It also includes some widely used Apache 2 modules (if you need some other feel free to send me a request”

Do others also install the apache2 PPA? Are there problems if you don’t?

Aaron.

ref:
https://www.virtualmin.com/documentation/web/multiplephp
https://launchpad.net/~ondrej/+archive/ubuntu/php
https://launchpad.net/~ondrej/+archive/ubuntu/apache2

Hi,

You don’t have to really do it but you could, if there are obvious benefits that you miss with using default package.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.