Webmin 1.870 released

Howdy all,

Webmin 1.870 has been rolled into the Virtualmin repositories.

Changes since 1.860:

  • Major updates to the Authentic theme to speed up page loads and add real-time system statistics.
  • Greek, Bulgarian, Catalan and Russian translation updates and encoding fixes.
  • Several fixes for Let’s Encrypt SSL certificate requests.
  • UI cleanups in the Majordomo module.
  • UI unification in the IPv4 and IPv6 firewall modules.
  • Numerous fixes for minor Perl error and warnings.

This is a very large update of the Authentic theme, which likely introduces fun new bugs (we’ve fixed all the ones we’ve found over the past couple of months of beta testing, but Webmin is huge), so we need y’all to let us know when you run into UI problems. Specifically, there’s a common class of bug where buttons don’t work on Webmin pages that have oddly nested forms.

This also includes some fixes for Let’s Encrypt issues; in particular, LE has changed their user agreement, and Webmin’s LE client needed an update to point to the right place.

And, if you use the Webmin iptables firewall (module name Linux Firewall), there may be some minor changes, as the ipv4 and ipv6 modules have been merged into one (the same functionality is present, it’s just they share code directly rather than being copy-pasted into the ipv6 module with minor tweaks as it used to be).

As always, let us know about any problems you run into.

Edit: Let us know about problems by filing bugs in the issue tracker! Jamie and Ilia don’t monitor the forums religiously, and they’re mostly the folks who need to be notified of problems.



after update 1.870
IPv6 Firewall

Change IP protocol version: IPv4

External managed rules detected. Activate “Directly edit firewall rules” or your firewall rules may break.
Warning! It appears that FirewallD is being used to generate your system’s firewall. Maybe you should use the FirewallD module instead.

Change IP protocol version: IPv6

External managed rules detected. Activate “Directly edit firewall rules” or your firewall rules may break.
Warning! It appears that FirewallD is being used to generate your system’s firewall. Maybe you should use the FirewallD module instead.
WARNING! Your current IPtables configuration is invalid : iptables-restore v1.6.0: Couldn’t load match `icmp6’:No such file or directory Error occurred at line: 95

Thanks for the update. Authentic theme works very very well now. I want to report bug with UI

After 1.70 update, when I click on “?” button (for help) on any line (field) under “Virtualmin > System Settings > Virtualmin Configuration” section, it forwards to internal help page instead of popping up little bubble help window. Would be great if you could fix it

Also, I couldn’t find button to refresh System Information on Webmin default main page. That button was very handy, could you please let us know the new way to refresh sysinfo?

I get the following error after updating to Webmin 1.870 and attempting to renew a Let’s Encrypt certificate:

Hook command “/etc/webmin/webmin/letsencrypt-dns.pl” returned error code 1
Error output from letsencrypt-dns.pl:
Error: Script was not run with full path (failed to find /letsencrypt-dns.pl under /usr/libexec/webmin)

Is this just another bug or something wrong with my Webmin installation individually?

There are multiple things happening here…but, the firewalld detection isn’t new. Are you saying the old version didn’t warn you about firewalld being in use? Anyway, it’s not a bug, unless you don’t have firewalld enabled on the system.

The other bit looks like a configuration problem; that error is coming from iptables-restore and not from Webmin itself. In both cases I think this is not new behavior, and not related to the changes in the iptables module, AFAIK.

Good catch. Those links are generated differently, so I guess Ilia didn’t catch this one. It may have been introduced recently when he made the Virtualmin config page show up in sections again (it had been all one page for a while in Authentic).

I’ve opened a ticket in the Authentic issue tracker here: https://github.com/authentic-theme/authentic-theme/issues/923

What’s your distro and version? That looks like it could plausibly be a bug (paths are an area that required a lot of changes for the new single page app model, because the path of every request is now relative to / rather than /module-name/), but I can’t reproduce it. I’m able to renew LE certs on my test systems.

Can you make sure Webmin has been restarted? (service webmin restart will do that on most systems)

I restarted Webmin a few times via “systemctl restart Webmin” on my CentOS 7 system, I even killed all the Webmin processes and then restarted, but I still get the same error.

I think there is a bug in Webmin 1.870! Related to Cloudmin GPL specifically…

I updated my server earlier today and had this same issue… and then I killed my server and had to reinstall everything (was looking for an excuse to do so anyway)…

Just reinstalled everything and now this…

When I installed Cloudmin GPL, it comes up in the dashboard as"9.3.kvm Pro"
It also doesn’t give me ANY of the actual Cloudmin menu options on the left.
It only shows “System Information” and “System Statistics”

I think something is seriously wrong with the recently updated Webmin (version 1.870 is what I have installed, along with Cloudmin 9.3.kvm)

Followed the instructions here: http://webmin.com/cinstall-kvm.html

It appears as though it might just be an issue with the “Authentic Theme” that is causing Cloudmin GPL to fail.

When I switched Webmin theme to “Old Webmin Theme”, I am able to see all the Cloudmin Menu options… so something in the Authentic Theme code is messing with the GPL vs Pro license check… or something.

Hi! :slight_smile: Is there any update on the “script was not run with full path” error I posted earlier today? I am unable to renew my Let’s Encrypt certificates now because of this error, at least when DNS validation is run. When Web validation is run, the script also fails because it seems Virtualmin is not automatically removing the HTTPS redirect or whatever like it’s supposed to do (I read that somewhere) before the renewal is attempted, thus the renewal fails. If I remove all the Website redirects (Virtualmin > domain.com > Server Configuration > Website Redirects), including the default one Virtualmin adds that redirects /(?!.well-known) then the Web validation works.

I am running Webmin 1.870 on CentOS 7 with Virtualmin 6.02, and no package updates are reported.

after latest 1.870 update, usermin(1.720) only shows left menu column (menu being unresponsive), blank on the right. changing theme and everything works as expected. authentic theme version 19.04. will also file a bug there, just wanted to see if other people face the same issue.

edit] ticket : https://github.com/authentic-theme/authentic-theme/issues/936

I had the same issue with Cloudmin 9.3.kvm GPL

Switching theme to “Old Webmin” fixed it… then after rebooting the server, I was actually able to switch it to “Authentic Theme” (19.04) and everything appears to be working again as expected.

yes, also a simple webmin and usermin service restart will fix that as well:
service webmin restart && service usermin restart

Hmm…I haven’t installed it for any of our Cloudmin hosts yet, and I don’t think it’s been rolled into the Cloudmin repos for that reason that it’s seen a lot less testing. I’ll test today. Ilia has Cloudmin on his dev machines, so I’m surprised it’s completely borked for Cloudmin, but I’m not surprised it has some unnoticed bugs (since it hasn’t gotten as much testing as we’d like).

I’ve been unable to reproduce this problem on my systems. I’ll try to poke at it some more.

I don’t know if we’ve had other reports of this specific issue, so we may need to look at your system to figure this out.

I’ve noticed something is wrong with Webmin/Usermin restarts on systemd systems, though I don’t know what it is; restarting the Webmin/Usermin daemons doesn’t seem to work reliably. I’m looking into it.

C’on Joe, looks like someone stop testing stuff before they go live - here is new/old one:

Case 1: Authentic theme settings - Default pages:

Default tab after logging in to Webmin - Webmin
Default module for Webmin - empty
Default page for Virtualmin - empty
Default tab after logging in to Usermin - Usermin

After successful login i’m prompted with Usermin (def. tab Usermin).

Case 2: Authentic theme settings - Default pages:

Default tab after logging in to Webmin - Webmin
Default module for Webmin - empty
Default page for Virtualmin - empty
Default tab after logging in to Usermin - Mail

After successful login i’m prompted with:

Corrupted Content Error
The site at https://mydomain.com:XXXXX/ has experienced a network protocol violation that cannot be repaired.
The page you are trying to view cannot be shown because an error in the data transmission was detected.
Please contact the website owners to inform them of this problem.

This is what i have in Usermin logs:

readline() on closed filehandle $ADDRESS at /usr/libexec/usermin/mailbox/mailbox-lib.pl line 166.
Use of uninitialized value in split at /usr/libexec/usermin/mailbox/mailbox-lib.pl line 600.
Use of uninitialized value $file in substitution (s///) at /usr/libexec/usermin/mailbox/mailbox-lib.pl line 667.
Use of uninitialized value $file in substitution (s///) at /usr/libexec/usermin/mailbox/mailbox-lib.pl line 668.
Use of uninitialized value $file in substitution (s///) at /usr/libexec/usermin/mailbox/mailbox-lib.pl line 670.
Use of uninitialized value $mailbox::config{“server_name”} in string eq at /usr/libexec/usermin/mailbox/mailbox-lib.pl line 1323.
Use of uninitialized value $mailbox::config{“server_name”} in string eq at /usr/libexec/usermin/mailbox/mailbox-lib.pl line 1335.
Use of uninitialized value $mailbox::config{“server_name”} in string eq at /usr/libexec/usermin/mailbox/mailbox-lib.pl line 1335.

Reloading the page will remove this error and open Usermin but the default tab didnt change and Usermin tab will be first to show up.

If i move back Default tab after logging in to Usermin to Usermin the problem is gone. Tested with FF with clean cache and private window/browsing - nothing changed.

In this new deploy, the visual part, it looks good, but as far as I’m concerned this bug marks me, I’ve opened a thread in this direction, but you can help me. Thank you

Please feel free to look at my system if you believe that would more quickly allow you to remedy this issue. I am currently unable to renew Let’s Encrypt certificates without a lot of extra steps when Virtualmin has been amazing up until now about automating the process for me. Who should I e-mail SSH login details to?