Warning: connect to Milter service local:/var/run/milter-greylist/milter-greylist.sock: No such file or directory

Operating system:
Ubuntu
OS version:
20.04.2

Once Mail Rate Limiting is enabled; mail.log reads warning: connect to Milter service local:/var/run/milter-greylist/milter-greylist.sock: No such file or directory

Here is the output postconf -n;

alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
allow_percent_hack = no
append_dot_mydomain = no
biff = no
broken_sasl_auth_clients = yes
compatibility_level = 2
home_mailbox = Maildir/
inet_interfaces = all
inet_protocols = all
mailbox_command = /usr/bin/procmail-wrapper -o -a $DOMAIN -d $LOGNAME
mailbox_size_limit = 0
message_size_limit = 51200000
milter_default_action = accept
milter_protocol = 6
mydestination = $myhostname, localhost.$mydomain, , localhost
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
myorigin = /etc/mailname
**non_smtpd_milters = inet:localhost:8891,local:/var/run/milter-greylist/milter-greylist.sock**
readme_directory = no
recipient_delimiter = +
relayhost =
sender_bcc_maps = hash:/etc/postfix/bcc
sender_dependent_default_transport_maps = hash:/etc/postfix/dependent
smtp_dns_support_level = dnssec
smtp_host_lookup = dns
smtp_tls_CApath = /etc/ssl/certs
smtp_tls_security_level = dane
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
**smtpd_milters = inet:localhost:8891,local:/var/run/milter-greylist/milter-greylist.sock**
smtpd_recipient_restrictions = permit_mynetworks permit_sasl_authenticated reject_unauth_destination
smtpd_relay_restrictions = permit_mynetworks permit_sasl_authenticated defer_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
smtpd_tls_CAfile = /etc/postfix/postfix.ca.pem
smtpd_tls_cert_file = /etc/postfix/postfix.cert.pem
smtpd_tls_key_file = /etc/postfix/postfix.key.pem
smtpd_tls_mandatory_protocols = !SSLv2, !SSLv3, !TLSv1, !TLSv1.1
smtpd_tls_security_level = may
tls_server_sni_maps = hash:/etc/postfix/sni_map
virtual_alias_maps = hash:/etc/postfix/virtual

P.S. I have another VM with same specs/config and no issues… I also checked On every message, warning: connect to Milter service local:/var/run/milter-greylist/milter-greylist.sock: No such file or directory but it seems not a fix for the issue.

Could you remove everything after and including the comma, it should work then I think.

Oh, there should also be a:
non_smtpd_milters = inet:localhost:8891

Also update
/etc/opendkim.conf

,local:/var/run/milter-greylist/milter-greylist.sock comes with Mail Rate Limiting option in Virtualmin; which is same for non_smtpd_milters.

In /etc/opendkim.conf; related settings is;
Socket inet:8891@localhost