Virtualmin virtual-server module 7.1 released

Howdy all,

I’ve rolled out version 7.1 of the Virtualmin virtual-server module. This is a primarily a bugfix release, addressing a few problems found in the 7.0-4 (and subsequent testing releases) version. It should now correctly handle cleaning up the mess when disabling mod_php, among other minor bugfixes.

Changes since 7.0

  • Fix a bug upon disabling mod_php
  • Fix quota test when installing scripts
  • Fix not to apply self-signed certificate in post-install wizard
  • Fix to test that a domain name cannot be an IP
  • Fix to support detection of a new Debian/Ubuntu repo key format
  • Fix MariaDB error upon wizard setup on RHEL 8.5 and derivatives
  • Fix MariaDB bug upon virtual server restore
  • Fix not to call before/after functions when using a cloud DNS provider
  • Fix to improve detection of default IPv6 address
  • Fix not to email about scripts which cannot be upgraded
  • Update translations



Could you tell me where the download link is please?

If you installed with the install script, the update appears in your dashboard and is available via apt or yum. You shouldn’t need to download the package manually.

Thanks Joe. It didn’t appear in my dashboard until I had refreshed the page so have it now.

I have installed with the debian installation package and not from the script, how do I get the latest version?

Well, that was a bad idea. You have a very incomplete system. But, if you’re happy with it, I guess that’s all that matters. :wink:

You can get the package from the same place you got it originally. Or you can add our apt repos (running the install script with the --setup flag will do that without installing anything or changing your config, running to actually perform an install is not safe on a production system, but for just setting up the repos, it is fine).

Maybe it was a bad idea to use without the installation script, but the last time I used it, I followed the procedure to install the minimum, since I didn’t want unnecessary things and suddenly I had a lot of things installed without my authorization…

I have downloaded it from here Webmin, but it is still in version 7.0

I have let @Jamie know about outdated links.

Please do not install/update Virtualmin manually. It must only be done using the package manager from the pre-setup repos.

Hi, The new installer still says:


or do I have the wrong one?

Also, it won’t install RHEL 9, is that just a setting in the ?

The virtual-server module is not the installer. It’s a module in Webmin. The current stable release of the Virtualmin installer is 6.2.2.

No one has ever said the installer supports RHEL 9. Not even the beta one. The installer on the Download page supports RHEL 8. It’ll be at least another week or two before we’ve had a chance to make RHEL 9 work.

We have a beta that has been linked a few times in the forums that supports Alma 8 and Rocky 8 (kinda, though it’s quirky on Alma, and we haven’t figured out why yet).

1 Like


i am completly confused, the repo seems not working for me and the installer say it does not support debian11

# License and version

# Currently supported systems:
supported="    CentOS/RHEL Linux 7, and 8 on x86_64
    Debian 9, and 10 on i386 and amd64
    Ubuntu 16.04 LTS, 18.04 LTS, and 20.04 LTS on i386 and amd64"

E: The repository ‘Index of /vm/7/gpl/apt virtualmin-universal Release’ no longer has a Release file.
E: The repository ‘Index of /vm/7/gpl/apt virtualmin-buster Release’ no longer has a Release file.

could we have a clarification on how to upgrade to the latest virtualmin because it seems i am not the only one to be confused here.

best regards,

What is confusing? Debian 11 is not supported yet. I think our OS support page is clear, and I think the list of OSes in the install script is clear?

We’re wrapping up the Virtualmin 7 installer now, which will have support for Debian 11.

1 Like

Virtualmin OS Support – Virtualmin

But @gadnet you did use forum search? :wink:

While that link is so much in this forum.

And topics about deb11 to:
Virtualmin 7 and Debian 11 - General Discussion - Virtualmin Community

well this “virtulamin 7” != “virtualmin 7 module” is rather confusing to say the least to me, sorry for that.

Yes Jost2 i saw this thread earlier but there is a nomenclature that i didnt (and still dont) grasp in the versioning and the “version 7”+debian 11. I was pretty sure the v7 repo worked and that virtualmin 7 was out but seems neither are so i mistaken something for something else i guess :wink:

i will just wait for the new installer then. Have a nice day !

best regards,

Hihi for me to , i am no english and have kind of dyslexia so to understand that is … :wink:

Somewhere in forum @Joe tried to explain , but for the buzss in my head i didn’t try to read / understand all that time , that is only me i thought.


I have a Ubuntu 16.04 LTS production server with Virtualmin 6.17-3 installed. I do not see the option to update to 7.1, but Virtualmin is flagged as “out of date” on the dashboard. Any tips to discover the latest package?

Hi @Pixelpanther

Ubuntu 16.04LTS is already end of life since April 30 2021.
Virtualmin probably gives you this message to inform you about the EOL of your operating system

I’m not disagreeing that 16.04 is outdated, just seeking clarification on whether the Virtualmin update should be available.

It’s just a thought, but it might not be in the repos anymore… But I think we have to wait for an answer from the staff