Virtualmin install error on Ubuntu 20.04

Hi all,

After the news about the CentOS 8 EOL, after using CentOS for many years and fixing some problems with CentOS 8 and Virtualmin I decided to switch to Ubuntu. My hosting provider installed automatically on my VPS Ubuntu 20.04 with Webmin without LAMP. I have tried to install Virtualmin and this is what I get:
▣▣□ Phase 2 of 3: Installation
Installing Webmin [ :heavy_check_mark: ]
Installing Usermin [ :heavy_check_mark: ]
Installing fail2ban [ :heavy_check_mark: ]
Removing nginx (if installed) before LAMP installation. [ :heavy_check_mark: ]
Removing unneeded packages that could confict with LAMP stack. [ :heavy_check_mark: ]
Installing postfix [ :heavy_check_mark: ]
Installing virtualmin-lamp-stack [ :heavy_check_mark: ]
Installing Virtualmin and plugins [ERROR] Failed with error: 100
[ ✘ ]

[ERROR] Something went wrong. Exiting.
[ERROR] The last few log entries were:
Get:57 http://software.virtualmin.com/vm/6/gpl/apt virtualmin-universal/main amd64 webmin-virtualmin-git all 1.14 [142 kB]
Get:58 http://software.virtualmin.com/vm/6/gpl/apt virtualmin-universal/main amd64 webmin-virtualmin-htpasswd all 2.11 [78.4 kB]
Get:59 http://software.virtualmin.com/vm/6/gpl/apt virtualmin-universal/main amd64 webmin-virtualmin-init all 2.10 [90.8 kB]
Get:60 http://software.virtualmin.com/vm/6/gpl/apt virtualmin-universal/main amd64 webmin-virtualmin-registrar all 2.10 [354 kB]
Get:61 http://software.virtualmin.com/vm/6/gpl/apt virtualmin-universal/main amd64 webmin-virtualmin-slavedns all 1.13 [22.1 kB]
Get:62 http://software.virtualmin.com/vm/6/gpl/apt virtualmin-universal/main amd64 webmin-virtualmin-sqlite all 1.8 [33.2 kB]
Get:63 http://software.virtualmin.com/vm/6/gpl/apt virtualmin-universal/main amd64 libterm-spinner-color-perl all 0.05-1 [18.1 kB]
Get:64 http://software.virtualmin.com/vm/6/gpl/apt virtualmin-universal/main amd64 virtualmin-config all 6.0.31-1 [33.0 kB]
Get:65 http://software.virtualmin.com/vm/6/gpl/apt virtualmin-universal/main amd64 virtualmin-core all 6.0.1 [13.2 kB]
Fetched 6,629 kB in 0s (15.5 MB/s)
E: Failed to fetch http://asi-fs-d.contabo.net/ubuntu/pool/main/libs/libsub-quote-perl/libsub-quote-perl_2.006006-1_all.deb 403 Forbidden [IP: 213.136.72.159 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
Installing Virtualmin and plugins: [2020-12-09 12:27:33 CET] [ERROR] Failed with error: 100
[2020-12-09 12:27:33 CET] [ERROR] Something went wrong. Exiting.
[2020-12-09 12:27:33 CET] [ERROR] The last few log entries were:

Any help would be appreciated.
Thank you in advance.

Operating system: Ubuntu
OS version: 20.04

Minimal template?
I would guess you didn’t do a system update/upgrade before launching the installer. That would cause apt to throw an error like that.

Indeed, I did not do it, I will do it now.

Just tried it and still the same result. I’ve tried also the dev without success.

To be honest I’m not sure it would work without a reinstall, since the Virtualmin install is now broken.
However, if it fails on the same file it wouldn’t hurt to try a different mirror than your providers, f.ex. ubuntu’s own.

Every time I’ve made a fresh OS install with the same result. I really don’t know what to try anymore. :slight_smile:

Well that’s good. Did you try a different mirror also? :slight_smile:
Might be Contabo is out of sync…

I just tried to install it from: http://security.ubuntu.com/ubuntu/pool/main//libs/libsub-quote-perl/libsub-quote-perl_2.005000-1_all.deb and I get the following:

E: Unable to locate package http://security.ubuntu.com/ubuntu/pool/main//libs/libsub-quote-perl

E: Couldn’t find any package by glob ‘http://security.ubuntu.com/ubuntu/pool/main//libs/libsub-quote-perl
E: Couldn’t find any package by regex ‘http://security.ubuntu.com/ubuntu/pool/main//libs/libsub-quote-perl

Am I missing something here?!?

The package isn’t in the security repos, it’s in the regular Ubuntu archives.

Post your sources.list here, just so we can double check what needs to be changed.

For now it’s pointing towards Contabo mirrors which should be fine but apparently is not at the moment (which is just another reason you should find another provider IMO).

Hi there,

I’ve tried everything that I found. I think that the Contabo mirrors are down. I will contact them as well. After many attempts I could install it with the following commands, but it must be done before the Virtualmin installation. If not, the installation will break everything:

sudo apt-get update -y
sudo apt-get install -y libsub-quote-perl

This worked for me, maybe could help someone.

NEW UPDATE:
I tried that on another VPS Ubuntu 20.04.1 LTS and is still not working. I am really confused now.

That’s what I kept on suggesting you, to switch to the Ubuntu official mirrors!
Maybe the installer would have run normally, though I have no clue why it fails when running the install script but works when installing manually.

Also, just saw your edit…
Another VPS with same provider?
Then it must be something strange with Contabo’s template.

Yes, the same provider. I will contact them because I have never in my life reinstalled the OS on a server so many times.

OK, then change the mirror like I mentioned.
Also, consider changing provider. Contabo is well known for being crap…

They have a very good price for the servers, let’s see now how is the customer support. :slight_smile:

Their pricing isn’t bad, but their servers are. Their support is so-so…
But just change the mirrors and see how that works, please?

I’ll do it now

Ok, coming with an update. What I’ve changed:

I’ve changed the mirror in the /etc/apt/sources.list to:
deb http://de.archive.ubuntu.com/ubuntu focal main
Tried to install with:
sudo apt-get install -y libsub-quote-perl
What I get:
Reading package lists… Done
Building dependency tree
Reading state information… Done
Package libsub-quote-perl is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package ‘libsub-quote-perl’ has no installation candidate

What am I missing?

This is my sources.list:

cat /etc/apt/sources.list|grep -v “#”

deb http://de.archive.ubuntu.com/ubuntu/ focal main restricted
deb http://de.archive.ubuntu.com/ubuntu/ focal-updates main restricted
deb http://de.archive.ubuntu.com/ubuntu/ focal universe
deb http://de.archive.ubuntu.com/ubuntu/ focal-updates universe
deb http://de.archive.ubuntu.com/ubuntu/ focal multiverse
deb http://de.archive.ubuntu.com/ubuntu/ focal-updates multiverse
deb http://de.archive.ubuntu.com/ubuntu/ focal-backports main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu focal-security main restricted
deb http://security.ubuntu.com/ubuntu focal-security universe
deb http://security.ubuntu.com/ubuntu focal-security multiverse

Seems you’re missing restricted?
Also, you shouldn’t need to install the package manually before installing Virtualmin.

I’ve tried to installed it before virtualmin because of those huge amount of errors that the virtual in installation triggered because of that dead contabo mirror.

I get that, but seeing that the Contabo mirror seems broken, try changing to the Ubuntu repos, run apt update && apt upgrade, reboot and run the Virtualmin installation :slight_smile: