Usermin Mail displays "None (no subject) 12/31/1969" messages in Inbox

OS type and version CentOS Linux 7.9.2009
Webmin version 2.101
Usermin version 2.001
Virtualmin version 7.7
Theme version 21.04
Package updates All installed packages are up to date

Anyone know what these are and how to get rid of them. They don’t show up in my Thunderbird client.

If I select the message I get this

I’m pretty sure I saw something like this appear after playing with the scheduled emails but I was able to get rid of them that time and this time I can’t seem to find a way to delete them.

I have stopped and restarted Usermin in the server with no luck. Done the same with Webmin and tried a ctrl-F5 just in case. No luck.


I did find this if it means anything to anyone.
Usermin current login Sessions

I checked my mail queue and found this

Selected the message and got the Error message that it did not exist
Went back to the mail queue and flushed it
Went back to Usermin and checked again and the messages disappeared
Checked the mail queue and the message is gone.

I guess it was a mail queue issue??

This are system messages, you setup somewhere to be sent to your user inbox, in general those go directly nowhere.
Try to remember what you did, a good point to start is in VIrtualmin > Logs and reports > Virtual Server Action Log (it shows you what did you changed)
If you look at the date, that date is when the internet date started, so day 0.

That is the internal name for messages in Postfix.
“Flushed” means that you sent it.

This is all I found in the mail logs. Looks like some kind of spam possibly?

This looks like what Usermin was trying to display but as I pointed out it never displayed in my thunderbird client so for some reason Usermin was able to view it but it was not sent out using IMAP to the external client.
Can’t see how its a system message. If it was I don’t know why it would show as an error and then just disappear.
This is well beyond my pay grade.

They’re Back…

Okay now I can see how these could be system messages, but I still believe it must be some kind of internal error. I also believe that it is probably connected to the filters.

The two messages that are displayed just below the issues messages (that don’t exist) have filters to move them to different folders. The filters are obviously not working as they are showing up in the Inbox.

What I think might be happening is that the filter begins to run, has some kind of issue and fails. In the meanwhile the system sends out a message about the move which is probably, typically destroyed at the completion of the task but since the task fails the non existing message gets processed. Since I have no idea what is going on in the background, this is all speculation on my part.

I suppose to test this I will have to remove some or all of my current filters and let the mail arrive and see if these messages come back unless someone actually knows how this whole thing works and could provide a better method.

Started by removing some of my filters to see what impact it has.

Whoops, I should have checked the procmail file before I deleted a couple of the filters to see if I noticed anything out of the ordinary. Oh well, I didn’t.

I deleted the filters for the two messages that came through and did not filter as expected.
I then created another filter and checked it and it worked fine but I still couldn’t remove the 3 ‘none’ messages.
Then another email came into the inbox that was not filtered and the 3 ‘none’ messages disappeared.

Not sure what’s going on there but there must be some mechanism that flushes those out of the message list?

So right now it appears to be working correctly. I am going to leave it as is for now to see if it occurs again within the next few days. If not I’ll recreate the other two filters and see if it happens again.

Maybe you forgot > /dev/null at some of your cron jobs or something

That messages are system messages intended for system, not for your root/ admin user.

At least that is the only thing I can think of

Not with a date back in the 1960’s they look corrupt getting a time stamp in minus figures. I would have a look at the actual messages from the command line this may lead to more clues as to what is going on

Ok, lol,January%201%2C%201970%2C%20displayed.

vin., 25 aug. 2023, 5:08 p.m. jimr via Virtualmin Community <> a scris:

That date means the system has no date, so it puts default date, and that’s the date
Except if you think all IT world is corrupt

You have a script that doesn’t send it’s null result in /dev/null, but in your inbox.

That’s all

vin., 25 aug. 2023, 5:57 p.m. Bozesan Vlad <> a scris:

This is the only cron job that I can see would have caused any changes lately. The first time I noticed those messages appearing was after playing with the scheduled messages function. Usermin would have created this cron job when I did that.
I’m not positive but I’m pretty sure I noticed several of these messages appear in the mailbox right after I sent a scheduled test message but they disappeared right away so I thought I might have submitted something more than once because of the slowness of the interface (nothing appears to happen after clicking on some of the buttons -ie no refresh/display change etc.)
Note: I have not created any cron jobs manually. All cron jobs have been created by the system.
There are no messages in the scheduled jobs so not sure why something would be, being sent out.
If I see it again I’ll have to try and check in the Maildir and see if any file is actually there.
I could also try adding another scheduled test message and see if that is what is causing the issue or at least if it is connected to the scheduled messages function. With the fake data and little other info to go on its hard to know where to look for the cause especially for someone like me with limited understanding of how the whole thing works.
For now I will wait to see if these messages return. If I don’t see something over the next few days I may try and experiment with scheduled messages again to see if I can reproduce the problem.

I am currious as to why they:

  1. can’t be deleted using the Usermin Interface (or at least cleared since they don’t really appear to exist) and
  2. seem to clear themselves (maybe when new mail arrives into the maildir?) but not right away.

that’s totally wrong ! I exit loads of scripts with null in cron jobs and it does not produce this behavior.
you must except that the epoch date is January 1st, 1970 at 00:00:00 UTC and is programmatically stored as the number 0 if the number is less than zero a date before will be displayed for example the date July 20th, 1969 20:17:40 would be stored as -14182940 so as we can not see the full time stamp the returned date could be anywhere within the time period December 31st 1969 00:00:00 and December 31st 1969 23:59:59. All I said was there is a possible corrupt file on the OP’s file system and not

@jimr1 could be right that are “corrupt” messages (in the sense that they not longer exist because they were already moved), or you could be right that the filters you setup to move the emails cause the problem.
It is possible that the filters move the emails but the system has a delay and thinks the emails are still there (the empty None “emails”), and that are just ghosts of the emails sincronyse.

The delay could also be because your server IP from your VPS is on 9 blacklists…

I have only seen it on one, and that is for the whole IP range, not my specific IP.

What tool did you use to find those?

I have no idea if that cause the issue related with your mail system configuration, but could be a cause.
I have no idea.

I only use my server for personal dev so I don’t really care for email (even so I’m sad I couldn’t setup PTR yer for mails)

When I ran my IP I get 0 Results. Not sure what IP you were using.

Is this message in the proper thread?

Than is ok.
The IP was from images you posted, maybe I’ve seen it wrong.
I hope you’ll find an answer and put it in here, I’m curious what cause it.

Oh, that IP was from a SPAM email that I believe cleared the none existing messages when I Flushed the mail queue. I have a feeling that its an incoming message that clears out those, but I am not sure why they display in the first place.