Unable to disable Apache website from Features and Plugins

I am unable to disable Apache website from the Features and Plugins:

I use Nginx instead of Apache, and need to disable Apache from the Features and Plugins, and I get this error when I try to uncheck the Apache website checkbox and save:

This is a new Virtualmin installation and I was able to reproduce the bug again after another fresh install. It seems to be a new bug, since I’ve been using Virtualmin with Nginx without issues, and this is the first time I’ve seen this issue with disabling Apache.

Operating system: Debian
OS version:10

I wonder if @Bsara is having the same problem…

Protected web directories cannot work without Apache (it manages htaccess files, which nginx does not support). Disable it. I guess the error isn’t as clear as it needs to be.

Also, why not use the --bundle LEMP when installing Virtualmin instead of manually switching to nginx?

Can you tell me where to find it?

The reliable way to install Ngnix and its Webmin modules is to start out that way with the Virtualmin install script on a clean server. Read this or type ./install.sh --help in your terminal for all options.

I’m not sure re-running the script with --bundle LEMP will help with your problem unless it’s a fresh install on a clean server with no traces of Apache. Before trying the script a second time you might try removing Apache entirely making sure all its *.conf files, modules and .htaccess files are absent. On the other hand, if it’s a new server you have the luxury of starting over.

Thanks a lot for that.

Sorry about the detour, your post and the other post look alike.