How to know whats wrong in your system is not ready for use by Virtualmin

Hello,
I have the message
your system is not ready for use by Virtualmin.
with no error shows beside it so I don’t know what’s wrong, I will paste here the recheck
The status of your system is being checked to ensure that all enabled features are available, that the mail server is properly configured, and that quotas are active …

Your system has 1.9 GiB of memory, which is at or above the Virtualmin recommended minimum of 256 MiB.

BIND DNS server is installed, and the system is configured to use it.

Mail server Postfix is installed and configured.

Postfix is configured to support per-domain outgoing IP addresses.

The following PHP versions are available : 5.6.40 (/usr/bin/php5.6), 7.0.33 (/usr/bin/php-cgi7.0), 7.1.33 (/usr/bin/php7.1), 7.2.34 (/usr/bin/php7.2), 7.3.24 (/usr/bin/php-cgi7.3), 7.4.12 (/usr/bin/php-cgi7.4)

The following PHP execution modes are available : fcgid fpm

The following PHP-FPM versions are available on this system : 5.6.40 (php5.6-fpm) 7.0.4 (php7.0-fpm) 7.1.33 (php7.1-fpm) 7.2.34 (php7.2-fpm) 7.3.24 (php7.3-fpm) 7.4.12 (php7.4-fpm)

MySQL 10.0.38-MariaDB-0ubuntu0.16.04.1 is installed and running.

ProFTPD is installed.

Logrotate is installed.

SpamAssassin and Procmail are installed and configured for use.

ClamAV is installed and assumed to be running.

Plugin Nginx website is installed OK.

Plugin Nginx SSL website is installed OK.

The Apache website feature is not enabled
your system is not ready for use by Virtualmin.

Can you tell me what’s wrong?

It says just above the error message…

This seems peculiar for a LEMP installation. If Apache is installed it must be duking it out with Ngnix. If Apache is not installed Virtualmin may be mistaking it for Ngnix. If Nginx is installed it may not be running. If Nginix is not installed those two plugins need to be removed.

Nginx is okay and running and I am stopped Apache service

I can’t see its a problem because I stopped this service already.

There is a disagreement between Virtualmin and you on this issue.

In my experience, those who choose to disagree with Virtualmin always come out second best. I would urge you, @Bsara, to find a way to see those things as a problem which Virtualmin sees as a problem.

Hint: after you manually stopped the service, you should have gone to Features and Plugins and unchecked it from there too, no?

I can’t understand how this will be disagreement with Virtualmin, I need to work with Nginx, not Apache, What’s wrong with that can you explain it to me, please.
and yes, I did that I stopped the features and plugins of Apache and I’ve installed Nginx ones and enable it.
I feel a little bit confused if you would guide me I will be greatfull.
Thanks in advance.

You need to disable Apache in Features and Plugins.

sure I did that already.

Oh, you’ve probably got Protected web directories enabled. That only works with Apache because nginx does not support .htaccess files, or anything comparable. Disable that, too.

1 Like

but I already disabled it.

Try clearing cache…

Maybe post a screenshot of your Features and Plugins page? Something is wrong there, but I’m out of ideas for what.

@kindnation describes something similar…

Have you tried to remove the protected web directory feature first, and make sure there is nothing used Apache services.