Ubuntu OS ans WM/VM

Hi, I’ve installed a fresh copy of Ubuntu 20.4 and I can’t get it to resolve to all subservers and servers. Is there a way to get it done in Webmin?, or should I try another OS?.. Thanks.

|OS type and version:|Ubuntu 20.04|
|Webmin version:|1.973|
|Virtualmin version:|6.16|
|Related products version:|RECOMMENDED|

I don’t understand your question. But, I don’t think you should keep hopping from OS to OS without any understanding of the problem (whatever that problem may be).

Ubuntu 20.04 is well-supported by Virtualmin and Webmin.

I’ve never had server/domain issues with Centos 7. I spent the whole weekend trying to set Ubuntu LTS 20.04 onto a Digitalocean droplet and it looked like it was installed correctly but, when I created servers and subservers I could not get them to resolve to the ip. I was able to get the hostname to resolve to the ip and the main domain, such as http:test.com and http://ns1.test.com, however, if I set up testing.test.com it will not resolve to it. I followed all leads found about it and still couldn’t get it to reach sites. I also tried setting ssl to hostname and then it gave an error of: server not secured… What it should be a simple ordeal turned into a weekend nightmare. I asked an “Expert” and he told me that I would have to manually set up DNS to all subservers. That’s moronic. If you have a wiki I can follow I’ll appreciate it but, for me, Ubuntu is not practical. Thanks for your help.

Here’s the same issue with Centos 8. If you go to http://ns3.intrelligent.net/ you’ll get the Webmin page, but if you go to https://ns3.intrelligent.net/ it doesn’t resolve. This has been a nightmare, even to the “experts”…

You’re misunderstanding the problem. If DNS resolves for any service, it resolves for all. It’s literally impossible for DNS work for one service (i.e. http) and not another (https). DNS happens before the service is involved. This name currently resolves to (for any service, http, https, doesn’t matter, it literally doesn’t make sense to say one resolves and the other doesn’t).

Step one is to understand the problem. You can’t possibly solve a problem if you don’t even know what it is.

So, what’s the problem?

Are you not seeing what I’m seeing?? Please click links.

You’ve had the same problem for months. We went through all of this before. You have NEVER had your SSL working. At all. This is the third OS you’ve tried on if memory serves going back to March of this year.

Your first link is NOT SECURE and displays link ns3.intrelligent.net and shows page ns3.intrelligent.net. The reason for that is it’s regular HTTP protocol.

Your second link is NOT SECURE and displays link https://ns3.intrelligent.net but displays page fiestaazteca.co

The reason for that is your SSL is NOT WORKING so it will deny access and defer you to the default servers html page.

This is the second time this has been explained to you by me personally. Get your SSL working and it will work as it should. You can not use HTTPS addresses when you have no SSL certificates giving you secure connections. They literally do not work.

1 Like

SSL is working… https://fiestaazteca.co/. It works through Webmin and Terminal…

I give up.


You really need to let someone do this that knows what they’re doing.

So, you’re saying SSL doesn’t work?..

Not for the domain ns3.intrelligent.com, no. It doesn’t. That is why it’s failing to resolve and defaulting to the regular fiestaazteca.co page.

I’m sorry, but I do not see how ns3 is defaulting to fiestaazteca…

the image shows ssl installed on ns3… But, it doesn’t resolve…

Now it did. But, it’s been in and out like this. I had to go to Terminal and manually add SSL.

And surprise surprise when you fix your SSL and go back all your links work properly.

Go figure.

The main has SSL and it still doesn’t show. https://intrelligent.net/

Yes, it does. That is the install page for a Wordpress install.

Man, you are playing with fire by not doing things right. I could totally highjack your install right now.

Don’t do that again. Post a shot of what you see. Get rid of that link. Now.

I’m testing. Is not staying there, however, how did you see it, and I can’t, even after I cleared cache?..

Probably because you’re not clearing it totally. This is why you run multiple browsers, so that after a change you can switch browsers to tests results. I actually move to a totally different computer. You can also use a cell phone to test to make sure you’re seeing what’s actually there.

When you clear your cache makes sure you clear it ALL TIME not just the last hour or something. And also make sure you clear image and data, not just images if it gives you that option.