Sub-server - broke its back

OS type and version Ubuntu Linux 20.04.5
Virtualmin version 7.2-1

On a second box (not the one with the DKIM problem I can’t fix) Nice new Virtualmin install gets the 3 new assigned virtual domains up and running OK displaying landing pages globally (must finally becoming a real user!)

Perhaps not :unamused:
I added a sub-server to one of the domains ( and promptly got the following error.

No sender canonical map file for outgoing addresses was found in your Postfix configuration. You should either add the appropriate map to Postfix, or disable this feature in Virtualmin’s module config page.
your system is not ready for use by Virtualmin

Disable what feature?

I assume this message is much clearer to others than it is to me. From what I can tell all the folders were correctly built but nothing displayed yet thankfully still working as expected.

The message implies “Postfix” as the problem but why? there are no mail users?

I’m thinking about deleting the offending sub-server and starting over (as I see there is an option to convert a virtual server to a sub-server but would rather fix (and thereby learn) why it got this way.

System Settings > Virtualmin Configuration > Server Settings > "Also update outgoing addresses for mailboxes." The default should be No because that’s the Postfix default, so you probably enabled it at some point.

Either turn that off or properly enable it.


1 Like

Nail on my head :grinning:
Spot on and fixed Error gone away.

Good. I’m glad it worked.

By the way, on those rare occasions when I can answer a question about Postfix, it’s almost certainly because I made the same mistake myself somewhere along the line. I’m no maven.


Ah, but just spotted not is all well on the 'net

I mistakenly thought that the DNS A record would have been created during the create sub-server - nope, maybe the error stopped that.

Still cannot access the web page in a browser and no A record to it. I have just created an A record for this sub server (I guess I’ll have to wait a while to see if that has worked… nothing yet)

Sometime later…

Well Now visible BUT No SSL !!!
Don’t sub-domains get a nice shiny SSL from Let’s Encrypt during creation or even inherit the SSL of the parent domain?

This is a different issue and should be addressed in a new thread.

However, in Virtualmin > Server Configuration > SSL Certificate > Let's Encrypt for the parent virtual server, you should be able to re-request the cert to cover the sub.

If that doesn’t work, please start a new thread with a relevant title to attract attention to this issue.

1 Like

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.