SPF Aligned DKIM Unsigned DMARC missing

SYSTEM INFORMATION
OS type and version Ubuntu Linux 20.04.6
Webmin version 2.111
Usermin version 2.010
Virtualmin version 7.10.0
Theme version 21.10
Package updates All installed packages are up to date

SPF Aligned DKIM Unsigned DMARC missing
please I have problems with emails and sport on all with google it goes directly to spam please how to do that

Hello,

Fire up your email settings and enable DKIM using Email Settings ⇾ DomainKeys Identified Mail page.

1 Like

nice test website, can I have URL?

1 Like

NOTE: google will still sends thing to spam even if both work, it maybe content that’s sending it to spam. Google has a system like spamassassin that rates content.

But Dmarc and DKIM look to be off.

1 Like

even with that I still have the same problem

this service will breakdown your issues

I spoofed a email address using the service and it allow anyone to send from you domain, that need to be tighten else spammer can use your email address

2 Likes

please what should I do please I always have this shit even my clients always ask me for this please what should I do



Mr Ilia Please I have the same problem on all servers even with virtualmin pro even if I renew the kdim I would still have the same problem thank you dear friend


you may want to fix what is noted by the green arrows

your dns is also a mess

@jimr1 is that MX Toobox you have used for those DNS tests?

yes it is mxtoolbox why ?

just like to make sure I have all the tools on my list :smile:

Do you mean servers or virtual servers one same server. I know the record are correct so I set to reject, you may want quarantine.
You need to add each virtual server domain to the signing, you only have one there.

also check the dns option on the virtual servers

Do you host DNS locally and is it controlled by Virtualmin? If not, you’ll need to manually add the mentioned records in DNS Settings ⇾ DNS DKIM Record to your DNS.

1 Like

I did everything and I still have the same problem.


I did everything and I still have the same problem.

the soutution please

Since amanet.pro is hosted on Cloudflare, make sure Virtualmin Pro is set to manage your Cloudflare zone correctly. Check the Addresses and Networking ⇾ Cloud DNS Providers page to see if Cloudflare account is configured correctly, and ensure the Hosting for DNS records option is also correct in the DNS Settings ⇾ DNS Options page. With these settings DKIM records will be added automatically. Otherwise, you need to manually add the DKIM records to Cloudflare domain’s DNS zone. You can find the records to add (manually) on the DNS Settings ⇾ DNS DKIM Record page or the DNS Settings ⇾ Suggested Records page.

Furthermore, remember that Cloudflare only proxies HTTP/HTTPS traffic (ports 80 and 443, and a few other). Therefore you need to ensure your mail server’s ports (e.g., 25, 465, 587 for SMTP; 993, 995 for IMAP/POP3) are set to bypass Cloudflare’s proxy by setting them to “DNS Only” (grey cloud) in the Cloudflare DNS settings.

If you look further up the thread there are references to amanet.site just wondering if the OP has used .site as a mail server to negate the limitations of cloud flare and therefore perhaps everything is not configured correctly an the webmin/virtualmin instance

I know, I noticed. I think the OP isn’t paying attention.