*Solved* Post installation wizard issue

I have installed Webmin 1.550 on Ubuntu 10.4 LTS and then installed Virtualmin on top of that. I have not done much to set up Webmin (including DNS), and have proceeded to the Post Installation Wizard for Virtualmin. I get through the first few frames and encounter this when it checks for resolvability:

 Primary nameserver cannot be resolved from the rest of the Internet : epsilon.scubaboard.com has address Host epsilon.scubaboard.com not found: 3(NXDOMAIN) 

Pinging epsilon.scubaboard.com brings back is is one of several IPs I have bound to the server through /etc/network/interfaces.

As background, this is my 11th server in my dedicated rack at Atlantic.net. It is the first server I have ever configured and its my first time using Webmin/Virtualmin. I have grown to loathe Plesk and cPanel just doesn’t give me the warm fuzzies. I have two DNS servers, sblb1.scubaboard.com and sblb2.scubaboard.com that do nothing but provide dns for scubaboard.com. ScubaBoard is the largest forum for Scuba Divers and is my main source of income. Epsilon is to be used as a LAMP server and will ultimately replace sb400.scubaboard.com, a LAMP server using Plesk.


Well, my recommendation just to move forward would be to check the box there that tells it not to attempt resolving the nameservers you enter.

Then as you move forward with the setup of your server and the domains it’s hosting – if you’re still having problems, we can try and tackle that then.

It’s possible that your server is having trouble resolving other names as well – that’ll show up whenever you go to run System Settings -> Re-Check Config. It may ask you to verify that “” is added to your /etc/resolv.conf file.


You were right. I had to add for it to work.

After I fixed that I rechecked and it came up with an additional error: A problem was found with your Postfix virtual maps : No map sources were found in the Postfix configuration

What is a virtual map and how do I acquire a source?


Well, the problems you’re having aren’t normal… it sounds like something odd is going on.

Adding “” into the resolv.conf file is something that occurs when running the install.sh script. Similarly, setting up the Postfix config is also done during the installation.

We’ve occasionally run into VPS providers who reset some of their customers config files after a reboot… you may want to watch out for that sort of problem.

Here’s a quick fix to your problem though – if you edit /etc/postfix/main.cf, add this line to the end:

virtual_alias_maps = hash:/etc/postfix/virtual

Then restart Postfix with “/etc/init.d/postfix restart”.

After that, see if that error goes away.

However, you may want to try rebooting, and see which of those problems recur. We may then need to dig into why that’s happening.


Eric, I appreciate your patience in this. That error has been resolved. However, I just got this when I checked again:

[code]The status of your system is being checked to ensure that all enabled features are available, that the mail server is properly configured, and that quotas are active …
Your system has 15.70 GB of memory, which is at or above the Virtualmin recommended limit of 256 MB.
BIND DNS server is installed, and the system is configured to use it.

Your Postfix configuration is missing the system’s mail hostname epsilon from the mydestination line, which will cause mail to bounce.

… your system is not ready for use by Virtualmin. [/code]

FWIW, this is not a virtual server… it’s an actual physical one that I just installed last week in my dedicated rack at Atlantic.net.

I don’t remember running an install script. I installed webmin first using wget and dpkg -i and a couple of days later did the same for virtualmin. Should I go and run the script now? Should I install usermin first?


I did want to check, did you by chance use the install.sh script to perform your installation?

As for the above error – what output do you receive if you run the command “hostname” on your server?

Whatever name that outputs – that name needs to be listed on the “mydestination” line of your /etc/postfix/main.cf file. You can just add it to the end of the list of names in there now.

Once you add that, restart Postfix, then try running the Re-Check Config again.

If it shows any other issues, feel free to post them here and we’ll get them figured out :slight_smile:


I don’t remember running an install script. I installed webmin first using wget and dpkg -i and a couple of days later did the same for virtualmin. Should I go and run the script now?

Aha, that explains the issues you are seeing.

The install.sh script performs all sorts of customizations for you… a lot of which you can see here in the manual installation documentation:


If this server is new – if it’s not hosting any live sites, email addresses, or the like – I’d highly recommend using the install.sh script to perform your installation, that’ll make things a lot simpler :slight_smile:

The installer will install all the required apps (including Usermin), as well as configure everything to work out of the box for you.

You can download the installer using the Download link above.


Cool, its not hosting a thing yet.

I will do as you suggest.

/bin/sh: Can’t open install.sh

Well, can you describe what steps you’ve taken so far?

The error you’re giving sounds as if the install.sh script may not be in the current directory, or if it is, that it could be corrupt.


I installed Ubuntu 10.4 LTS and made it a LAMP, DNS and EMail server.
I bound several IPs to /etc/network/interfaces (
I have updated the system files several times.
I added a perl library.
wget webmin
dpkg -i webmin
Set up a few things (mostly trying to learn) like users etc.
wget virtualmin
dpkg -i virtualmin
and you know the rest.

Not a whole lot other than that.

I will be up to Orlando next week installing a KVM over IP switch, so if I have to reload and do things a bit differently, I can and will. I have always had others do my servers and some are great and others are less than optimal. Ultimately, I want this to replace a Plesk server, reload that server and make it another web server for ScubaBoard. But as it is, there is nothing on this server at the moment, so I can play and learn on it and reload it if need be.


Well, I suppose I was wondering what steps you took to download the install.sh script. I’m looking to verify that it is indeed in your current directory when you go to run it.


Mea culpa… I guess I am not good at reading directions. I never downloaded the install.sh script. I have done so and /etc/sn install.sh is currently running. Again, you have been most helpful.

That sounds great!

Feel free to give a shout if you run into any trouble while configuring things, but I think you’ll find it a lot simpler to get things up and running when using the install.sh script.

Have a good one!


Almost there… [code]
Checking Configuration
The status of your system is being checked to ensure that all enabled features are available, that the mail server is properly configured, and that quotas are active …
Your system has 15.70 GB of memory, which is at or above the Virtualmin recommended limit of 256 MB.
BIND DNS server is installed, and the system is configured to use it.

Mail server Postfix is installed and configured.

Apache is installed.

Webalizer is installed.

Apache is configured to host SSL websites.

MySQL is installed and running.

ProFTPd is installed.

Logrotate is installed.

SpamAssassin and Procmail are installed and configured for use.

ClamAV is installed and running.

Plugin DAV Login is installed OK.

Plugin AWstats reporting is installed OK.

Plugin Mailman is installed OK.

Plugin Protected web directories is installed OK.

Using network interface eth0 for virtual IPs.

IPv6 addresses are available, using interface eth0.

Default IP address for virtual servers is

Default IP address is set to, which matches the detected external address.

Both user and group quotas are enabled for home and email directories.

All commands needed to create and restore backups are installed.

The selected package management and update systems are installed OK.

… your system is ready for use by Virtualmin.
Updating all Webmin users with new settings…
… done

Updating Virtualmin library pre-load settings …
… done

Updating status collection job …
… done

Re-loading Webmin …
… failed! Incorrect Webmin PID 13823 at /usr/share/webmin/web-lib-funcs.pl line 1360.[/code]

Check out that last line… failed! Incorrect Webmin PID 13823 at /usr/share/webmin/web-lib-funcs.pl line 1360.

You may just need to reset the Webmin processes that are running.

If you run:

ps auxw | grep miniserv | grep webmin

Try killing whatever processes you see, then restart Webmin with:

/etc/init.d/webmin start

After that, does the re-check config work?


Hey Eric,

I had to take a break to go diving, but everything seems to be running correctly.

However, when I go to create a virtual server, I get this:

Failed to create virtual server : Mailman cannot be enabled unless the administration list mailman has been created.This can be done in the Mailman plugin module.

How to create an administration list mailman without a domain seems problematical. I haven’t been successful.

Well, you could always disable the mailman feature when creating a Virtual Server – that would prevent the message you’re seeing.

I’m not seeing a way to create a list without a domain either… I may need to ask Jamie about that. It doesn’t come up often, as systems seem to default to having a mailman list (at least, my test system here did).

One thing you could try is to create the list from the command line, using:


Using that, create a list named “mailman”, and see if that does the trick :slight_smile:


We are making progress! Thanks again, ever so much. That worked perfectly. The list had to be named “mailman@epsilon.scubaboard.com” but that was explained as I executed the script.

I have created http://www.ScoutFishing.com and it is kind of working. I am not getting any kind of indication that its going to the right directory though. I did change a few directories in Webmin before I installed Virtualmin (I asked about this in another thread). The files are sitting in /home/scoutfishing/public_html, where I have installed the files for Drupal 7.7. Unfortunately, when I try to run the install script for drupal http://www/scoutfishing.com/install.php, I get a 404 error. If I go to just http://www.scoutfishing.com I get

[code]Index of /

Name	Last modified	Size	Description

Apache/2.2.14 (Ubuntu) Server at www.scoutfishing.com Port 80[/code]

The Drupal files are definitely in /home/scoutfishing/public_html. Here is the output of ls -a in that directory.

root@epsilon:/home/scoutfishing/public_html# ls -a
.                  cron.php           INSTALL.sqlite.txt  scripts
..                 etc                INSTALL.txt         sites
authorize.php      fcgi-bin           LICENSE.txt         stats
awstats            .gitignore         logs                themes
.awstats-htpasswd  homes              MAINTAINERS.txt     update.php
awstats-icon       .htaccess          misc                UPGRADE.txt
awstatsicons       icon               modules             .usermin
.bash_logout       includes           .profile            web.config
.bashrc            index.php          profiles            xmlrpc.php
cgi-bin            INSTALL.mysql.txt  public_html
CHANGELOG.txt      INSTALL.pgsql.txt  README.txt
COPYRIGHT.txt      install.php        robots.txt

I am going into Webmin to see if I can find the directories I had previously modified. Still, your help would be invaluable.