Smtp error (454) authentication failed

Ubuntu
20.04
contabo VPS

domain is redirected from cloudflare- maybe missing any records (not sure…)

A mail ip address
A webmail ip address
MX domainname.com mail.domainname.com

I want to send and get emails
Installed roundcube + want to access via thunderbird

Created new user (virtualmin/edit users)

  • #1 When I login to roundcube I can only get emails and if I try to send the error pops out:

  • “smtp error (454) authentication failed”

  • #2 Thunderbird does not connect at all with the settings from “Email Client Settings”

The only way If I go to Webmin/ Read user mail/ then I can read or send an email or using “usermin”

Just opened terminal and checked ports on the current virtual server administrator name
netstat -tulpan
these ports needed for email seems to be open
IMAP
tcp 0 0 0.0.0.0:993 0.0.0.0:* LISTEN

pop3
tcp6 0 0 :::995 :::* LISTEN

smpt
tcp6 0 0 :::587 :::* LISTEN

port 25
tcp6 0 0 :::25 :::* LISTEN

How to fix this?

Quick question: Are you hosting on your own server from your own connection?

Be sure of the user name in thunderbird and roundcube. it probably defaults to “someone@domain.com

But the min’s software with postfix defaults to a user name of “someone.domain.com

Just tried to login with roundcube using username as “someone.domain.com
Nothing happened - can’t login

I use contabo VPS

Good day Team
I am using ubuntu VPS 20.04LTS (linode) , I am having the same issue
I can receive mails fine mailtoolbox.com show all DNS configs and server ok
also my saslauthd conf already has the -r set
I am able to log into roundcude via user@domain format but still get the authentication 454 error when sending my ports are all open like the original posters…
also I have verified with my provider that none of these ports are blocked for me.

can anyone help? I am busy with a huge client migration and cant get the mail sending going

Thank you

Anyone can help?

Not sure what my corresponding Postfix settings are but FWIW my Thunderbird username is

someone.domain

Why are y’all trying to guess usernames? You’re the system administrator, you can know with 100% certainty what the usernames are.

It is right there in the UI. Click Edit Users in the domain in question, the field labeled IMAP / POP3 / FTP Login is the username.

If your system uses user@domain.tld format usernames, there will also be another username (without the @), that you can see in /etc/passwd or in the System->Users and Groups module, which can also be used, but it is not generally necessary to care about that at the client level. It is an artifact of Postfix and how it deals with @ (and some other services that not everybody uses).

In Usermin, if you connect to the domain name, e.g. https://www.virtualmin.com:20000, it should be possible to use either the barename, e.g. joe, or the full username, e.g. joe@virtualmin.com. Some other mail tools are able to do the same, but most dedicated local mail clients are not aware of that info.

2 Likes

@Joe
Just checked usernames and there are 2 of them:
hello@domain(.)com
hello-domain(.)com
Both usernames does not work if I try to login via Thunderbird.
Login to Roundcube works, yet same SMPT error if I try to send an email.

Logs. The client has no idea why it failed. Look in the maillog.

@Joe


which one to look at?

view mail.log

1 Like


I’m based in UK and I can see some strange IP’s trying to connect from Ukraine and Lithuania. What the…
Or I missed something here

Irrelevant. Any public server will be attacked by spammers.

saslauthd either isn’t running or is misconfigured. Did you do a full install? Were there any errors? This should have been done for you during install…but, if the install didn’t complete, it won’t be configured correctly or enabled.

Try running:

# virtualmin config-system --include SASL
1 Like

Note that if the install didn’t complete, we can’t guess how many steps didn’t happen but the installer should have indicated it. There is a counter during install where it says “4/23” or whatever (number of steps varies depending on the installation type chosen but there is always a counter), and if you don’t get all “23/23” steps with green checks (maybe a yellow mark during quota config) something went wrong with the install and it isn’t complete and not expected to be functional.

1 Like

sasl
1 out of 1

fail2ban status
one more

OK, now watch the log again while trying to auth. Did anything change?

1 Like