Smtp error (454) authentication failed

nothing changes on the log if I try to login via thunderbird

You’ll need to do some more troubleshooting, then, to figure out why it isn’t working normally.

That’s making sure saslauthd is running, making sure its config matches what is supposed to be setup, making sure Postfix is correctly configured to communicate with saslauthd. You can look in the Virtualmin-Config plugins that set all that up in Virtualmin-Config/lib/Virtualmin/Config/Plugin at master · virtualmin/Virtualmin-Config · GitHub

That should give the the gist of what it’s supposed to look like. There are a few comments in the plugin, and you can just scan through it looking for mentions of sasl and SMTP auth.


looks like rocket science coz I’m new

Well, @mantas8 and I worked on this and the issue is now resolved.

I had to do the following to resolve the issue:

  1. create a subdomain, vps.domain.tld, for hostname of server Virtualmin was running on
  2. change the hostname from the default that Contabo sets to vps.domain.tld
  3. create subdomains for name servers
  4. Rerun Post-Install Wizard and apply name servers
  5. Request SSL certificate for vps.domain.tld and apply to webmin / usermin / postfix / dovecot et al.
  6. Install Roundcube
  7. Troubleshoot SASL (as Joe had recommended in the earlier message)
  8. Send / receive test messages from Roundcube and Thunderbird - everything worked perfectly right off the bat

Thanks for the business @mantas8!

Hey @saabir, you had a similar issue too. Hope this sequence of steps helps you fix it.


@calport thanks
One thing I can’t understand why it didn’t worked on my default assigned records
These I’ve created for this specific purpose to be “default”

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.