Roundcube 503 on fresh install centos8

**Operating system:CentOS
**OS version:CentOS Linux 8.2.2004

Hello all,

I just installed roundcube and I get a 503 whatever I do.

Service Unavailable

The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.

I tried going up and down in php versions. Bu it doesn`t work

When I try to change the php version I get this message
image

In apache the error that I get is this:

[Wed Dec 02 04:55:17.842860 2020] [proxy:error] [pid 67170:tid 140457736644352] (111)Connection refused: AH00957: FCGI: attempt to connect to 127.0.0.1:8000 (*) failed
[Wed Dec 02 04:55:17.842919 2020] [proxy_fcgi:error] [pid 67170:tid 140457736644352] [client xx.xx.xx.xx:15996] AH01079: failed to make connection to backend: localhost, referer: http://mysite.tld:10000

You should focus on this error, as it is the first error you say you encountered after you installed Roundcube.

Here is what you could do to resolve this error: Virtualmin -> Server Configuration -> Website Options - see PHP script execution mode and change mode to something else (any mode other than the one currently selected). Save; then change it back to the original mode.

Roundcube should work now.

@calport thank you so much

But this takes me to the next problem :smiley:

I cannot change that, no option to go to cgi

Virtualmin is not a mature product, if on a fresh install I have so many errors

  1. You need to set the mysql password twice
  2. The php version out of the box crashes
  3. I cannot install a simple script like roundcube or squirrel mail
  4. Constant error about not having an mx record even though I have 2
  5. NO ptr record out of the box

I was testing the gpl version to go to professional but at this point if with a fresh install I have all these problems how can I trust this product to pay money for it

Hi,

  1. You need to set the mysql password twice

Where exactly do you need to set your MySQL password twice?

We are sorry about that. It was a bug which was fixed and discussed numerous of times.

  1. I cannot install a simple script like roundcube or squirrel mail

Yes you should be able to install it out of the box. It doesn’t work due to the bug mentioned above.

  1. Constant error about not having an mx record even though I have 2

Not a bug but mis-configuration on server side.

  1. NO ptr record out of the box

PTR records are set by your service provider and not my Virtualmin (we cannot do it in anyway)

Hello

  1. On wizard, right after the fresh install when you get a password created for mysql. You get an error, then you have to go back and be sure to set the mysql password for root.

for the rest of them Im going to try the posts that you mentioned. Thank you for the help Ill get back with news.

When this happens does Virtualmin return an error that MySQL root password is unknown and must be reset? If so, it’s not a bug. By default, with clean installs, MySQL root password must not be set, so Virtualmin will help you to make it secure by setting up the password. However, if root password was set outside of Virtualmin before running the wizard, it cannot know the password, so it offers to reset it or enter a current password.

for the rest of them Im going to try the posts that you mentioned. Thank you for the help I ll get back with news.

Thanks!

Hello

Tried the posted solution


Added the line as suggested to no avail.

Modified /usr/libexec/webmin/virtual-server/php-lib.pl for centos8
added the line as instructed on Git still same issue.

Yes but on the second screen. After you set a password it return an mysql error and you have to go back and put it the same pswd.

BR

Did you restart Webmin with /etc/webmin/restart command?

Hello

Yes I restarted

Issue still present

Again, I appreciate your help.

You’re missing php-fpm package? Double-check that it’s installed and re-run config check under System Configuration.

Hello

Please use our official guide to install multiple PHP versions.

How did you install Virtualmin GPL?

hei I installed it via wget and sh install.sh

Since then I have tried multiple OSs on ubuntu I didnt have any of the issues

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.