Postfix reports incorrect version

OS type and version Ubuntu 20.04
Webmin version 2.021

I am trying to set up SNI on my server, but it reports 2 different versions of Postfix installed which is critical to that. Postfix => 3.4 supports SNI and when it displays in Webmin it has a module called “Certificate Mapping” that I need to use. I have 2 near identical servers and on one of them this is all good. On the other one however, it shows Postfix 3.4 as installed but 3.3 on the server configuration page, with no “Certificate Mapping” module.

Correct server:

Incorrect server:


How can I get Webmin to recognise the correct installed version and give me access to the “Certificate Mapping” module?

That seems way out of date. All mine are using Postfix v3.6.4 on Virtualmin 7.7 (Webmin 2.021) perhaps the problem has already been resolved?

Thanks for your reply but it doesn’t address my problem. I have 3.4 installed, but Webmin reports it as 3.3 and doesn’t show the Certificate Mapping module. Ubuntu 20.04 only ships with 3.4.

I have Ubuntu 20.04 - It has everything currently up to date and has Postfix 3.6.4 and not 3.3 or 3.4 So that was why I was suggesting that it might be that Postfix is out of date rather than Virtualmin (Webmin)

I now see that it may be more to to do with the “Certificate Mapping” not showing with the old version 3.3 - perhaps it wasn’t available back then? I personally haven’t had the need to use it so cannot help - good luck

looks like a bug somewhere I have up to date Ubuntu 22.04
webmin shows :

but the command line shows :



That’s interesting, the official Ubuntu site lists 3.4 shipping with 20.04 and 3.6 shipping with 22.04. Did you install Postfix from the official Ubuntu repository or compile it from source?

Yep, same issue as me but just with different versions. My difference is critical because 3.3 doesn’t have SNI (Certificate Mapping), 3.4 does.

so you have a version of 3.6.4 when you use the command line utils or something else ?

from the Ubuntu repository

It either came with the original Virtualmin LEMP install on that server OR (and probably more likely) it came as a subsequent package update which I take withe the pretty naïve approach of accepting when prompted.
I currently have 6 boxes running Virtualmin in different countries (two USA, one Canada, one Holland, one UK, and one Japan) and different hosting providers. All LEMP. All on Ubuntu three on 20.04. three on 22.04. Some were originally 16.04. All six now showing up to date with Postfix 3.6.4

So I have no idea where it has come from if " the official Ubuntu site lists 3.4 shipping with 20.04 and 3.6 shipping with 22.04" I have been thinking of upgrading the 20.04 machines to 22.04 but am reluctant given all the work that would involve.

I have 3.4 on the command line and Webmin package list, but 3.3 on the Webmin Postfix configuration screen, and the 3.3 version is the one prior to SNI which doesn’t have the Certificate Mapping module. I have another almost identical server with the same OS and Webmin version, but it displays 3.4 on the command line, 3.4 on the Webmin package list and 3.4 on the Webmin configuration screen. This one has the Certificate Mapping module. And when I run apt upgrade on Postfix it says current version is installed on both servers. Somehow, on server #1, Webmin is displaying the incorrect version of Postfix, and consequently I don’t see the Certificate Mapping module.

That is strange. I built both of mine from the ground up on 18.04 and installed Webmin/Virtualmin on top. I don’t know how long the issue has existed, I’ve just noticed it recently when I tried to add another mail domain on the same server IP address. The fact my other server displays it correctly makes me strongly suspect an issue with Webmin but I have no idea how to correct without uninstalling and reinstalling Postfix, which I’m extremely reluctant to do.

I should probably add that all these VPS boxes have multiple domains some > 10 (when sub-domains included) I’m not even aware of any need to use “Certificate Mapping” I have checked all boxes now and the Postfix Server page is showing the latest version 3.6.4 and the “Certificate Mapping” option.

I know my original suggestion was to upgrade from 3.3 and 3.4 to 3.6.4 but now I am as sceptical as you and would wait for input from someone in @staff who should be better placed to know if Virtualmin(Webmin) has a bug in this respect, and comment on which version is expected to be current

Again it sounds like a webmin bug if both apt and postconf return a later version of postfix than webmin is reporting , best report it as a bug

Screenshot 2023-06-16 155456
On all six in my case so ??

So every sever is the same sorry i didn’t realize that just because you have six reporting correctly and there are 3 from this thread are not reporting the postfix version correctly but you know best

Yes, that is the problem - all I was asserting was that it was not (seemingly) a problem for me. and hence the suggestion for an upgrade.

To what postfix is at the highest version so are you saying webmin is out of date ?

Try removing /etc/webmin/postfix/version and then visiting the Postfix module page.

That should force it to update the version, assuming all the config and command paths are correct.


Webmin should re-check the version cached in /etc/webmin/postfix/version if a new version of the postconf command is detected…