Postfix mails stuck in queue

Ubuntu Linux 18 (64-bit)
Hi I have completed my setup but when I am sending emails they are landing in a mail queue. I do not know how to fix this issue.


Also use the search facility of the forum to get a list of topics which deal with this oft discussed issue.

Yes I reviewed the post you suggested but port 25 is open in my vps machine.

Is port 25 blocked anywhere else, some hosts block this by default? Postfix logs are saying the connection to port 25 on the remote SMTP is timing out?

No port 25 is not blocked

Logs report the connection attempt to send the email has timed out on 25? Or postfix isn’t even trying to send the message?

yes right, postfix isn’t trying to send the message.

Can you paste the postfix log here after trying to flush the queue, refresh the log 5 minutes after you flush.


If you’re still experiencing this issue, please reach out and I can setup some time to get this sorted out for you.

Best Regards,
Peter Knowles | TPN Solutions

Professional, Affordable IT Support -

You enabled Require SASL SMTP authentication? in the postfix SMTP Authentication And Encryption setting already?

Yes, I have enabled Require Sasl Smtp authentication.

Check here: Setting the "Use SASL SMTP authentication?" option to 'Yes writes incorrect configuration option to [#58454] | Virtualmin to be sure you got the right one. Also, this isn’t by any chance the hosts default domain you’re trying to send the mail from?

This is your default domain? I had a similar issue where the SASL auth file wasn’t written in the correct location. You can check here:

Yes, this is my default domain.

smtp_sasl_auth_enable = yes

This doesn’t need to be enabled unless you’re using a relay. Try changing that to:

smtp_sasl_auth_enable = no

Then check the output.