All outgoing mail stuck in queue (solved)

Fresh Debian 10 install a couple days ago. First thing I wanted to do is get email set up. Everything went smoothly. Set up user. Set up a mail client. Can receive mail just fine. However all outgoing mail gets stuck in queue.

Some queue entries say delivery temporarily suspended. All of them say connection timed out. I’m new at administering email. Getting a server to deliver mail to the user is a big win for me. But I’m at a loss as to where to start with getting user’s outgoing mail delivered.

Hello @lazybullfrog and welcome to the Virtualmin community forum. will give you an overview of what you have got right in configuring your system as a mail server and will also offer remedial suggestions, in case anything is amiss.

Also see:

Okay. I used netcat to verify that my host provider was blocking port 25. (Sorry, I don’t trust random scripts on random websites to diagnose my servers. Thanks for saying so many words just to tell me my port was blocked though.) Got request approval to remove block. Flushed the queue. Every mail in queue got sent and returned as undeliverable due to google not resolving my ipv6 address back to my domain. Added a AAAA record for my domain. Rookie mistakes. Problem solved.

Also a good idea to setup dkim and a reverse dns entry for both ipv4 and ipv6 if you want mail going to to be delivered.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.