PHP 7.4 not showing as option under Virtualmin

Hi

I installed php74 from Remi Safe repo and it is not showing as an option in Virtualmin > Server Configuration > PHP Versions.

Is Virtualmin compatible with this yet ?

Centos 7.7.1908
Webmin 1.940

1 Like

Hi,

Yeah, but the problem, is that if you run it using PHP-FMP, only default version of PHP can be used.

What is the output you see on Virtualmin/Server Configuration/PHP Versions page?

Have a look at Virtualmin/Server Configuration/Website Options and PHP script execution mode. If you change it to FCGId, will you be able to see other PHP versions, right?

1 Like

Hi

You can use PHP-FPM with multiple versions of PHP from SCL or Remi Safe I do on lots of sites but this specific site is not using PHP-FPM anyhow but php7.4 doesn’t show as an option unlike all the other php versions.

I meant using it with different version for each directory - is not possible.

Yeah, you need to edit a lib file to make this happen or wait until next Virtualmin release:

Find at /usr/libexec/webmin/virtual-server/virtual-server-lib.pl

"7.0", 7.1, 7.2, 7.3);

and replace with:

"7.0", 7.1, 7.2, 7.3, 7.4);
3 Likes

Thanks Ilia.

This doesn’t give the option for configuring PHP7.4 under Services, but never mind I’ll wait for the next VM update.

You need to restart Webmin, as the file that you’ve edited usually cached:

/etc/webmin/restart

You might also want to Re-check configuration from UI or run virtualmin check-config from console.

Thanks IIia I’ll give it a go.