New version of webmin causes problem with my cron

Operating system: OS version: CentOS Linux 6.10
Kernel and CPU Linux 2.6.32-754.30.2.el6.x86_64 on x86_64

I have an old dedicated server, I’ve had it for years. I don’t want to upgrade it as it will cost money :slight_smile:

When the new version of webmin came along on the 26th, I clicked upgrade as I have for years. From that time on my cron no long works

When I check the reason it says:
Not a GLOB reference at /usr/libexec/webmin/fastrpc.cgi line 339, line 2.
Failed to run on this server : Unknown reason

fastrpc belongs to you :slight_smile: All I want to do is go back to the version before that worked AND NEVER UPGRADE WEBMIN again. Can you help me?

What cronjob do you have that could possibly be triggering a fastrpc call? I can’t think of anything we’d setup by default. fastrpc is used for communication between multiple Webmin servers. It wouldn’t even come into play unless you’d setup multiple Webmin servers, or you have something custom calling the RPC interface.

I don’t know. That is the error I’m getting on all cron run programs (there are about 2 dozen of them). All the programs run fine when run from a browser. I wrote a simple program that just says hello. Even that generated the same error.

But let’s not worry about that, is there a simple way to install the old version that worked without trouble or the version before that etc for years.

The facts are this, my crons never had a problem for years. I updated the webmin sometime on the 27th. I noticed 2 days later that the cron wasn’t working. I could tell it stopped on the 27th because of the time stamp of files it creates.

I’m not making up this error:
Not a GLOB reference at /usr/libexec/webmin/fastrpc.cgi line 339, line 2.
Failed to run on this server : Unknown reason
I don’t even know what it means :slight_smile:

Please help me return to the version of webmin that works :slight_smile: Why it doesn’t work isn’t important to me. I just need it to work.

Where are you seeing this error exactly?

If you click on any run now for any of the cron jobs you get this
Failed to run on (this server) : Unknown reason

As you know, when a cron job runs it sends an email to root. If you look at any of these emails, you see
Not a GLOB reference at /usr/libexec/webmin/fastrpc.cgi line 339, line 2.
Failed to run on this server : Unknown reason
on all of them jobs that attempted to run.

As I said before, my server is old, it has been running cron jobs for years. I haven’t changed anything in months. All I know is that

If fastrpc.cgi is webmin trying to communicate with another webmin, where would I see it trying to do that on my webmin. Maybe someone hacked me and put code to track me? I was hacked before, maybe they left something that I didn’t know and that is what is wrong? I had seen a listing for fastrpc.cgi running in my list of running processes before, at least I think I remember seeing it.

Same problem here. The error message is:
Error reading response length from fastrpc.cgi :
I am using Cluster Cron Jobs
Even the cron job only refering to the local host is giving the problem
Normally I am distributing maintenance jobs to other computers.

I am using Linux Mint 20.2 Uma MATE
The problem occurred by goring from webmin 1.981 to 1.982
Kernel Linux 5.4.0-91-generic on x86_64

OK, your case is understandable, and an actionable bug. (OP said they haven’t setup other Webmin instances, so they aren’t using the cluster modules, so it makes no sense why they’re seeing this error.)

@Jamie is this a known issue in 1.981/1.982 and, maybe, fixed in 1.983, or is it new?

I’m glad someone else has the same bug I have. But that isn’t important. (not to me) The question is still can I return to the old version that works and how can I do that? Waiting even a month for you to find and fix the problem might be good for your future versions, but I shouldn’t have to wait.

Please can you tell me is it possible to return to the old version? If the answer is no, let me know that also.

If you installed in the recommended way, all of our software is installed using yum/rpm, and you can use those tools like you would with any other package installed using yum and rpm.

Looks like a bug in the IPv6 support we added to fastrpc.cgi in 1.982. I’ll look into it …

As a quick work-around, edit /etc/webmin/miniserv.conf and remove the line ipv6=1 (assuming you’re not actually using IPv6).

Actually, I looked into this closer, and found the real bug. We are about to release version 1.983 that will include a fix for this issue…

1 Like

OK, now I am scared since /etc/webmin/miniserv.conf doesn’t have ipv6=1

Here is the unedited miniserv.conf (what am I missing. If I’m blind and missing the line please forgive me)
realm=Webmin Server

My apologies, that suggestion about removing ipv6=1 was wrong. The proper fix will be in Webmin 1.983

1 Like

I understand, but there is a reason I have these cron. As a practical matter, I can’t sit here and run them manually. Certainly not starting the same problem over and over over the course of days. When will this update be released?

The release will happen today…

I downloaded the new version. restarted my server, restarted webmin…didn’t fix the problem.

The error looks slightly different, but the result is the same

Here is the new error:
Undefined subroutine &main::in6addr_any called at /usr/libexec/webmin/fastrpc.cgi line 370, line 2.
Failed to run on this server : Unknown reason

Its the same here. I have installed version 1.983 on the clients and the server.

I am searching why certain combinations aren’t working. Its probably not a software error but a configuration error. The Cluster Cron Jobs seem to work, but the execution on server and client2 seems to give problems.

From server to client2 Error
From server to client3 OK
From server to client4 OK
From server to server Error
From client2 to client2 Error
From client3 to server Error

From server to server Error

Running /home/onderhoud/scripts/backup_daily on selected servers …
Failed to run on server…(this server) : Unknown reason

From server to client2 Error

Running /home/onderhoud/scripts/synchronize_home on selected servers …
Output from client2 …
Error reading response length from fastrpc.cgi :

From client2 to client2 Error

Running /scripts/create_tunnel on selected servers …
Failed to run on client2… (this server) : Unknown reason

From client3 to server Error

Running ls -al on selected servers …
Output from server …
Error reading response length from fastrpc.cgi :

I am still trying and searching.


In /etc/webmin/miniserv.conf is a line missing


I copied miniserv.conf from client3 to server and its working. With the same trick client2 is now working.


Could you try this small patch please?