manually upgrade virtualmin

As there is no armhf version of the script for Virtualmin and installing it on a RPi3 I used this instruction:

It looks outdated but it works.

Now I noticed I do not receive any updates to virtuamin. There is no distribution source for armhf debian jessie. So that explains.

Of course I like to stay tuned with new versions.

Can I manually upgrade virtualmin by just installing the latest version over current version without losing configurations and data?



Hmm, it’s been a little while since I’ve done a manual Virtualmin install, but if you go into Webmin -> Webmin Configuration -> Upgrade Webmin -> Upgrade Modules, does it offer to upgrade the Virtualmin module there for you?


Hi Eric,

Apparently no. Though shows the wbm.gz to be available for 5.07


hi all - guys can you tell the upgrading from to? the os you using and configs you are using…

debian (raspbian) linux 8
webmin 1.831
virtualmin 5.04 (as wbm install)

configs is not the point as config is to remain… I need an updated virtualmin.

can this upgrade be done on windows platform?also since i m looking for a new web hosting for my website so do you think vitualmin can be a good choice in my case?

on my end (also deb jessie) it all worked with apt update && apt upgrade -y- do you get any error msgs in terminal?

hi, yes it can… just download putty, log into your server as root and do apt update && apt upgrade -y commands and you should be fine once its finished.


As you can read in the start of this thread there is no distribution source for armhf platform (raspbian). That is why virtualmin has been installed as wbm module.

apt would only be nice if there was a source.

Do read the question first.


Hi, I am on debian jessie 64bit and commands works for me just as they should, however I installed virtualmin with script provided by downloads. I assumed if it works on standard debian installation, it would also worked on rp install, perhaps I was wrong but it was worth for try - I did read your question whole, but never mind.

let me explain.
A raspberry pi3 has an armhf architecture. Though 64 bit there is no (working) 64 bit OS thus the raspbian (linux 8) is 32 bit.
There is no “” available for armhf acrhitecture. So virtualmin is to be installed as wbm module after installing webmin first.
There is no distribution source for armhf architecture for virtualmin. Hence no “apt”

It seems as webmin module virtualmin is only available as downloadable package.
Not updatable through webmin module config.
So knowing the above, can it be upgraded and keep the current settings by installing a more recent version over an old version?

@pieterG thank you for your update - well it seems to me that I learn from you and not you from me - which I like! Well - to be honest with you I am against to use anything 32bit on servers… last time I did try that I was on debian 5 or 6 and it did gave me some issues - anomalies which I now understand why…

perhaps its limit of rps or something. I am very sorry for it. Regards the version over and old version question - my best bet would be to open the issue ticket to guys and as them directly - they do build it so perhaps there is very small chance to build something for low power like rps…

rps are good for some stuff but not for everything… my personal opinion is ssh reverse connection (sort of vpn) or rsync backups or git repos, but otherwise - I see them very well useless, but that is just my opinion. Also you have an option to ask on official prs irc channels about your issue - I think they will be much more smarter there then me or anyone else here…

Of course I would like to see 64 bit… in this case it would not make any difference as there also is no 64bit armhf distro on virtualmin.

Anyway for home and small business solutions a Raspberry Pi is a versatile little thing for under $40,-. At that price considering it a useless device is showing ignorance for what it can do. Any low end x86-64/amd64 device will cost you about 3 to 4 times as much.

As this is not an issue but a question, posting it in the issue tracker is not appropriate.
Irc channel may be an option.

If you need Raspberry Pi for home (lan) server for whatever reason then you dont even need a control panel but if you insist Webmin can do the job. If you mean home/small business as hosting from home or your local ISP then you are doing it wrong. Plus you can now rent a dedicated server with C2750 (8/8) and SSD for less than 20$/month (what is cheaper than 2 pizzas) in case you need a server for hosting. This CPU is enough to server one Wordpress website or even e-commerce (e.g. Woocommerce) with low/medium traffic, or in case of low traffic even more than one website.

If you don’t know any background but just need to rant…
if you do have an answer to the question do tell, else stay out of this thread…

I dont like your attitude toward @unborn especially as he is/was trying to help you. No one here knows everything but at least there are few people who are active on this forum and they do their best to help others. Statement from my previous post stay as a fact regardless if you like it or not. But you could tell us for what you intend to use that Raspberry Pi, so maybe someone could give you better advice than you got until now.

@diabolico, you get the reaction you triggered yourself… reading back nothing I wrote @unborn was wrong or in contempt.

The question simply is can virtualmin be updated by installing a more recent virtualmin wbm module over the old one preserving all settings and configuration.
I also explained why and all of a sudden I have to defend myself for using a raspberry pi3?

I get personal opinions on the use of a Rpi, 32 vs 64… even an advice to rent a server at 12x$20,- a month? To run Wordpress?
For a years worth of that advice I can buy a pi and an external 4TB disk or several pi’s and build me a server stack (for which webmin and virtualmin also can come in very handy) And no I will not run Wordpress… ever.
Your Pizza’s are way too expensive by the way…

A control panel is to be available for admins that need to setup accounts, hosts and such. Not devs that know how too commandline and vi/nano their way through a system.
You’d be amazed how well a pi can perform as a private cloud/web solution with webmin/virtualmin together with the appropriate web apps.

it is webmin on a Rpi3
which is armhf architecture
yes that is 64bit but there is no (proper) 64bit OS available yet
which in general would not make sense anyway as it has only 2GB memory
so running raspbian/debian linux 8 is not available for armhf architecture
therefore virtualmin installed as wbm
there also is no armhf source for virtualmin on only amd64 and i386 packages.

and still would like to know how to upgrade manually

I second Diabolico advice here to go with Webmin. Why did you install Virtualmin on a Raspberry Pi? I don’t think you plan to run all services like Apache, MySQL, Postfix and provide services for multiple users from that right? It’s a valid question when you ask for help for an unsupported device. So it’s normal that people will be curious at least.

I assume you did it because you want an administrator interface. In that case, Webmin is exactly what you want. And yes, you can also run websites and everything else. Just think Webmin as single tenant (you are the admin) and simple visual Linux interface. Virtualmin is more designed towards providing services to other users (staff, customers, etc.) in a multi-tenant environment. Said this, Virtualmin is NOT supported on that device or OS so I don’t think any advice you receive here is official, support or will even work, it may be just a test if anything else. And Virtualmin can and probably will get more intensive in the future with services, so it will require even more computing resources.

This is what I would do:

  1. Do a full backup. Or at least for your config files & data.

  2. Install the latest module just like you installed it initially.

  3. Check configs, if there are still there, great, else go to 4.

  4. Restore only config files.

There is absolutely no reason why this should not work. You are just overwriting the files with the latest ones, and you keep the config files separated. I do not think the installation will delete data (like your sites) in any way (but it could…).

Now I assume you were playing when you said to run a private/cloud solution from a Raspberry Pi. It’s like saying you are going to run a website from your phone, actually, an Android phone is just as powerful if not multiple times more powerful, yet you don’t see people running racks of Android systems as servers. Why? They are mobile chips towards single users, servers require multi-threading and running process in parallel + other instructions, think Xeon chips here. Of course, it will work. Just don’t tell anyone here your website because they will be able to crash it by just hitting the reload button a couple of times in their browsers :slight_smile:

Hi, well I forgot to mention that while you on debian (I know rps debian is not pure debian and cannot be safely said it works as normal debian) perhaps you could try to enable virtualmin updates in your sources list and see if it works. Did you try that option already? IRC on some rps channel would be good.

BTW: just side note, I use rps for remote support - replacement for team-viewer (yeah with some funny configuration its fast and very safe and totally doable) and some rsync features but other then that, sorry. 7 years old laptop with 4gigs of ram would cost around £70 to £100 but as server like features - rps cannot be even comparable. Its not my ignorance, its years (more then decade) in ICT and knowing your best options what you can squeeze out from THAT and THAT hardware. rps are good for some stuff no doubt about that, but have its own limits.

Rpi3’s. Yes they do have limits… but they do fit in a closet next to my meter and fuses… laptops tend to grow to big for that. Also old second hand laptops and computers are not my favorite. The ones I had all broke down… in the end you understand why the previous owner wanted to get rid of it.
And for me one of the things I am fond off is the ease of use and versatility… have your images ready and write them to a micro sd. Insert and plug it in… there you go…
You can create a farm of servers at the speed you can write images to a micro sd.

As said before, setting up the Virtualmin updates in the sources list isn’t working as there is no armhf package available.

Though I have an obsolete 10" netbook atom n570 running debian as I have 2 docker containers running on it that require amd64 architecture. (though the RAM on that tiny old one isn’t really sufficient for a 64bit environment. It does that job allright. (and even fast too). I may move that to a UP board. Unfortunately they sell around $140,- though I saw cheap Chinese Z83xx below $90,- too. That becomes more interesting… I have a 2in1 with a Z83xx and that performs pretty well (compared to old laptops :wink: ) But my aim is to stay below $50,- per physical server/machine.

BTW I don’t want to stress this n570 with more than the two dockers.

You’d be amazed… I am running some web based monitoring tools, nextcloud with spreed webrtc and collabora CODE together with a bunch of development sites. From a closet in our hallway. Accessible from anywhere. On various (sub) domains.