Manual update procedure (ARM64)

Operating system:
Ubuntu 20

Greetings all. After many attempts at searching for this specific topic, I had to resort to raising a question here on the forum to seek some proper answers.

In short, AWS have recently released their T4g range of instances which (much like many other cloud/VPS providers) are now utilising a custom ARM64 CPU architecture. Now, there are quite a few posts out there about Webmin/Virtualmin’s support which all elude to support “eventually” coming, but most of these posts date back to 2017 and nothing thereafter.

I have managed to successfully install Webmin on Ubuntu 20 utilising the ARM64 architecture by specifying the --minimal flag. (Without specifying the --minimal flag, install work fine but there’s an issue with Procmail that’s obscure). Anyways, when performing an ‘apt update’, the process returns a warning advising that the Webmin/Virtualmin repo does not support ARM64 and has been skipped. This, to me, indicates that there will be a problem with picking up any new webmin/virtualmin versions that are released via the official repo - which leads to my question (actually 2 questions):

  1. Is there a “manual” way to run a Webmin/Virtualmin update (when there’s one available) which can essentially be done by manually downloading and running an update package, vs. having to rely on the ‘apt update/upgrade’ process?

  2. When can we expect to see official ARM64 support? The architecture is becoming increasingly popular for VPS’s and a solid bang for buck so it would be brilliant to see official support for it released at some point.

I hope the above information is clear enough and many thanks in advance to anyone willing to assist.

You still have the procmail issue, whether minimal or normal. If you aren’t hosting mail, you don’t need to care.

You don’t need to do updates manually. Just configure the appropriate universal repo for your distro. The packages in the universal repos are not arch dependent.

Official ARM64 support is not being worked on at the moment. I can’t make any estimate for when it’ll happen. It isn’t a high priority, but it continues to be a thing that I’d like to get to. But, we have a lot going on and not a lot of resources to do it.

Brilliant - this helps. I’m not doing any mail at all on these servers so glad to hear it’s a non-issue.

Appreciate the prompt reply, and thanks for all the great work!

Sorry Joe, just a quick question regarding your repo comment. I originally installed Virtualmin by manually downloading the installer package and following the process via this link: https://www.virtualmin.com/download/

Server is Ubuntu 20 and my repos are configured to use main, universe and multiverse. When you say “just configure the appropriate universal repo for your distro…”, are you referring to the repos added by the Virtualmin installer? Here’s what I have configured for those repos via /etc/apt/sources.list.d/virtualmin.list:

deb hxxp://software.virtualmin.com/vm/6/gpl/apt virtualmin-focal main
deb hxxp://software.virtualmin.com/vm/6/gpl/apt virtualmin-universal main

(I purposely changed http to hxxp for the sake of this reply)

Assuming universal is in fact configured based on the above, correct?

Even with this config, I still get the following warnings when running ‘apt update’:

N: Skipping acquire of configured file ‘main/binary-arm64/Packages’ as repository ‘hxxp://software.virtualmin.com/vm/6/gpl/apt virtualmin-focal InRelease’ doesn’t support architecture ‘arm64’
N: Skipping acquire of configured file ‘main/binary-arm64/Packages’ as repository ‘hxxp://software.virtualmin.com/vm/6/gpl/apt virtualmin-universal InRelease’ doesn’t support architecture ‘arm64’

Maybe I’ve misinterpreted or am missing something?

I did not tell you to enable the focal repo. That has binary packages which are not built for ARM. Universal is the only repo you can use.

Then again, you’re seeing an error for universal, too…I’m not sure why. You may have to explicitly tell it to only get…um…any (maybe all?) packages from that repo. I know there’s a way to specify that, maybe with something like [arch=any] or [arch=all]. I can’t spend any time figuring that out right now, but I know there’s a way to make apt not act stupid on this problem by telling it explicitly what to get from the repo.

Great, here’s the answer:

deb [arch=all] hxxp://software.virtualmin.com/vm/6/gpl/apt virtualmin-universal main

This now works correctly! Thanks again for your help, very much appreciated.

1 Like

And, actually, I guess if you do that, you could use the focal repo, too. The lamp-stack and lemp-stack packages are useful if doing somewhat automated installs. Though I dunno if they’ll install without procmail-wrapper being available. I’m not sure if it’s in Requires or Recommends.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.