Lost Connection

Since the Webmin upgrade a while ago, we have been experiencing a lost connection after logging in to our Webmin URL via port 18888. Accessing the dashboard is OK, but then we went to File Explorer or other modules and found that “Lost Connection” popped up.

The only way to deal with this is to restart the Webmin service. Occasionally, we can access the File Explorer, and sometimes, we can’t!

Basic troubleshooting so far:
Update the package. Still no go!
Increase the connection in the Webmin configuration from 50 to 200. Still no go!

I appreciate your feedback.

SYSTEM INFORMATION B
OS type and version UBUNTU 20.04
Webmin version 2.111

UPDATE INFORMATION:
I have two servers, and both have the same issue.

Ran the command for: sudo tail -f /var/webmin/miniserv.error

image

Those 101.113.205.41 are my local machine accessing the browser via Webmin URL, which is a bit odd - too many connection as I am accessing the URL only on the single tab of the Chrome browser ?!?! I also tested it with another browser, Mozilla Firefox, and it’s the same issue.

Thanks
DC Partners

Use tracert or tracepath and see if can see a issue.
Maybe also go back to default port and see if that helps.

hi @stefan1959

I am assuming that you want me to run this on the local machine that is running the browser accessing this Webmin URL. Is that right?

Yeah from your pc and tracert the hostname

Can you screenshot the lost connection error, it might be useful. an what Webmin version are you using. can you update your first post.

top right of the dashboard, the clipboard will copy all of the information in markdown format.
image

Hi @shoulders

I’ve updated the version of the Webmin above - 2.111.

I also attached the information that you need:

SYSTEM INFORMATION
OS type and version Ubuntu Linux 20.04.6
Webmin version 2.111
Theme version 21.10
Package updates All installed packages are up to date

The screenshot of the error after accessing the File Manager:

I also updated some new information on the original thread.

If you are home behind a router 101.113.205.41 the connections might not just be your browser, do you have any other software running?

Maybe try accessing your server through TOR as there will only ever be that browsers traffic from a different IP. See if it still drops off.

Try from another physical location. A VPN might not work if your computer is doing weird connections to webmin.

This wouldn’t be a DoS attack? Either that it maybe some sort of loop happening on connection.

If you have a fixed IP maybe restarted webmin or reboot server to reset those connections
and limit the IP’s that can connect to the server (this on work if you have a fixed IP else you will get locked out.

Did you restart webmin? I seen one other message like this and that was the solution.

Hi @stefan1959

Yes, after we changed the config, we did restart the Webmin service, in fact, we have to restart Webmin anyway when the issue starts.

Thanks

Something is making a lot of connections to your Webmin instance. You should figure out what it is.

Didn’t realise you where in Brisvagas Stefan

No Cairnsvagas, even better :slight_smile:

Hi @shoulders and @stefan1959

In our environment, we used Chrome with many tabs and multiple accounts (many Chrome browser instances opened). But only two tabs have a URL to go to Webmin (one for each server).

We do have software running, such as the VPN client and EndPoint Security. However, the VPN is disabled during this connection.

However, we tested it with the TOR browser, which seems to work.

We also tested this on other LAN environments via Azure, and it works OK.

So, it seems related to the browser itself. I’m still investigating this.

But at the moment, we have a work-around solution.

Also, we don’t have a Static IP on our environment, so it the modem reset or leased expired, it will change the IP.

Thanks

what about firefox? Maybe its chrome.

hahaha … too funny

Hi @stefan1959

We tested this using Firefox, and it’s the same issue. We even close all active Chrome browsers prior accessing this and the same issue.

However, soon, we used the TOR browser, and everything was good. I believe TOR is using a different IP address while browsing, isn’t it? I’m not sure why our IP address caused the Webmin to have too many connections. Any ideas?

We could technically restart the modem and hoping to get a new IP address.

Yeah tor give another IP, that is strange. And other path to server I would think.

Hi @stefan1959 , what do you mean by “other path to server” ?

  • on your local network turn off (or unplug from network) all but one computer and see if it still happens, this way you can identify which PC is causing the issue.
  • Maybe you have an email app that keep trying to connect many times.
  • Check the firewall logs on Webmin

These will not fix the problem but will help you identify which one is causing it.