Kvm-gpl fails to install

Tried installing the gpl version to check it out but i get this:
no match for argument: kvm
no match for argument: kvm-qemu-img
no match for argument: qemu-kvm-tools
no match for argument: kvm-tools

then the installer quits

SYSTEM INFORMATION
OS type and version Fedora 37 (server)
Webmin version ?
Cloudmin version ?

@Lobstrosity,

I’m not sure you are using a supported “Host OS” version… Might want to check with @staff on this.

We do not test on Fedora, at all, and strongly discourage its use on servers (though it’s what I use on my desktop and laptop). It simply does not have a reasonable lifecycle for server use.

Nothing we ship is ever expected to work on Fedora. I see the Webmin.com page mentions Fedora, but it shouldn’t. Nobody is running Cloudmin on Fedora and you shouldn’t either.

We’ll hopefully be refactoring the Cloudmin installer soon, which will make it much nicer, but it’ll also be louder about Fedora not being supported.

oh hah, weird. what os is recommended? i actually only installed fedora because it was listed on the page and alma (what i currently use) wasnt!

thanks

Rocky or Alma or RHEL, if you like RPM-based distros. But, we’ve probably only tested up to 8. Cloudmin is long overdue for some attention…

Sweet maybe when you get er up and running I’ll have to pull a sub for that as well and check it out can’t wait I have an odd need for running VPS for masternodes for digitalnote XDN crypto currency should be interesting if I can have a go at it and setup a bunch of masternodes.

Tried on Alma now that I’ve had a spare minute to and same problem as my OP. Also, didn’t notice this before, the installer script recommends fedora as well

It shouldn’t. We’ll fix that. I’m working on a new Cloudmin installer this weekend (though it’ll probably be weeks before it’s actually ready).