Joomla 4.x and virtualmin

Ciao, sorry in advance for my bad english…

I have a Joomla 3.x website with virtualmin and so far I have never had any problems. I decided to upgrade Joomla to version 4.x and at first after the migration everything seemed fine but I started having problems when I go to check for extensions or updates. The site loads for a very long time and then crashes with this generic error.

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at [no address given] to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.
I updated the php from 7.4.3 to 8.0.25 as suggested by Joomla but the result doesn’t change.

I tried to reinstall a version of Joomla 4.x totally from scratch to verify that the problem was with Joomla or after upgrading from version 3.x but nothing the problem remains even with a clean installation.

At this point it is a problem of virtualmin or some parameter not correctly configured.

What do you suggest I go check?

Thanks in advance :slight_smile:

OS type and version Ubuntu Linux 20.04.5
Webmin version 2.001
Virtualmin version 7.3-1
Related packages SUGGESTED

We install Joomla from the Joomla download server. It is not custom to Virtualmin, and there is nothing unique about the way Virtualmin runs PHP apps.

If you’re using mod_fcgid, you might try switching to PHP-FPM (or vice versa, but PHP-FPM is better for most users). But, otherwise you need to troubleshoot performance in the same was you would in any web server…nothing to do with Virtualmin.

The usual stuff: Check top to see what’s using CPU, check error log for clues, enable slow query logging in MySQL/MariaDB to see if there’s some particular plugin or query that’s consuming a lot of resources, make sure you have sufficient memory and CPU for the work you need to do.

Thanks for the reply.

I changed as suggested by mod_fcgid to phppfm but the problem remains.

CPU and RAM usage from dashboard is minimal, I have 16% cpu and 48% ram.

I’ll try to open the logs and see if there are any errors.

Any luck solving this problem. I just upgraded to joomla 4.26 On upgrading it got to 90.2% completed and then after a long time interval stopped with a 500 server error. Did this several times with different sites including a clean install. Tried different versions of php 7.4, 8.0 and 8.2 fpm version. The sites seem to work but i have been having issues with rechapcha. I am sure the problems are related.

Why would you think the problems are related? They don’t sound very similar, to me, except that they’re Joomla issues.

And, my answer is the same as above, but especially, “check error log for clues”. We can help if we have actual errors (the web browser does not know the actual errors, a 500 error in the browser is meaningless, it just means “something didn’t work”). You’ve got to look at the logs.

That was a typo i actually meant to say not related. I agree with you.

Then a new topic is the way to go.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.