ISP stopped allowing relay of mail looking for suggestions

OS type and version Debian Buster
Webmin version 2.001
Virtualmin version 7.3-1 Pro
Related packages Postfix

My email is no longer sending mail via my email relay through my ISP contacted them and they have stopped allowing relaying via their mail relay.

I cannot do this any longer so I am looking for a free way to send and get mail to keep my expenses down.

I’ve read that if you have a GMAIL account you can relay through however I have attempted this and am getting stuck somewhere with setting that up with my personal gmail account.

If anyone has done this successfully please share with me what was done to get it functional and working as of this past week my email is dead as I cannot figure out how to properly configure this to use GMAIL’s SMTP as the way to relay email.

You need to relay?

Good question as direct send option did not seem to work email never sent when I was using virtualmin so … I did some research found the mail server my ISP was using for their mail and setup to relay through there and it worked.

Maybe time to look for another ISP? Could you use a service like they offer 1000 email free per month. But if your ISP is blocking still not sure you can connect.
They have instruction on config for postfix here, start at step 4.
Setting up Postfix Smarthost with SMTP2GO

Do a test with the telnet client (you may need to install it) to see if port 25 is blocked.

eg “telnet some.mailserver 25” and see if you get any response.

Use a mailserver outside of your and youyr ISPs network for “some.mailserver”, should probably work.

If you aren’t blocked, then revisit using VM directly.

SASL authentication failed; cannot authenticate to server[xxx]: no mechanism available

That’s an unusual response to a telnet attempt.
Can you please try with eg ?

Well I know port 25 is open because its my networking equipment as far as if it is open to my ISP that is another question I will have to explore from my windblows machine good suggestion.

Non-authoritative answer: MX preference = 5, mail exchanger =

That’s a dns lookup answer.

I tried to help.

Well then…

Microsoft Telnet> o [25]
Connecting To…Could not open connection to the host, on port [25]: Connect failed
Microsoft Telnet> o [25]
Connecting To…Could not open connection to the host, on port [25]: Connect failed
Microsoft Telnet> o [25]
Connecting To…Could not open connection to the host, on port [25]: Connect failed
Microsoft Telnet> frick me ports are open on the network

Evidence begs to differ.
You need to check firewall on that PC, firewall at the router, then find out if ISP is blocking.
My upstream has an option in my account login to drop their firewall for certain ports.

It would be weird if your ISP both blocked your port and also refused you to send via their server.

When you said “relay” through them, do you mean you had their server configured as a smart host?

Usually ISPs only block clients if there is a lot of spam etc involved.

No I personally called over a year ago they said port 25 is stopped to prevent spam etc… So from there I was looking into things and decided well I’ll find their email server its likely something bog standard and it was so I used that with no password and they left it open to relay mail so I relayed for the last year using that method as they allowed non standard email. All was good until last week when they closed up that hole. So now I have to resort to mailgun I believe as I called again and they said yeah you were not supposed to be able to relay mail that has been closed I thought sheesh this is lame. And he proceeded to set me up with an account for the ISP. After looking at the settings their is no way to configure any advanced settings it is a basic roundcube account on their server with very limited options. I will have to use mailgun or something along that line at this point.

I was going to sign up and use google as the email provider but I’d much rather handle things on my own and not pay yet another monthly fee. I just hate monthly fees not to mention it does not interface well when trying to add their MX records it is essentially impossible because virtualmin does not allow you to add them properly. It automatically inserts mywebsite.tld at the beginning of everything so its impossible to have the proper mx records and also have mail and webmail on there which is required for outgoing mail if I want to add it to the server.

Lesson learned you can’t get around port 25 without a relay…

Hrmmm… I wonder if I could setup hosting on and create my own free relay for mail instead of using say mailgun or whatever.

The problem is that you probably need port 25 open to be able to use any relay outside of your personal network.

Normally the ISP would give you an account, you set your mail server to use that account which then allows them to be used as a smarthost.

You would then be using eg port 465 SSL or 587 TLS, but not 25.

Tried Send in blue seems like an SASL issue at this point dunno how to fix at the moment but got to sleep! Only 4 hours left to sleep lol

apt install libsasl2-modules I may try this tomorrow hopefully I can fix my setup without having to reinstall and reconfigure everything. What a pita things were going great until my ISP no longer allowed sends that way.

I guess the ISP did not know anything in regaurds to setting me up or as if they could allow my email to send and so forth I did ask questions but the guy didn’t know he stated I don’t know about the more advanced settings and configuration I thought well shit holy cow you are the lead tech support dude but ok I guess whatever works.

port 25 is blocked by most isps. you need to set MX server on port 587 or 465, or use a relay with those ports… most email providers do that, gmail too.
and did you try with your ISP email and pass?
noone (should) leaves open relays these days…

sasl issue usually means wrong authentication.

Isnt that just a browser?

this not bad for testing open ports

port 25 is needed for a mail server period. SASL define what you mean by “wrong authentication” The password username and port are correct and the text records are there both for my server and for the mail relay. Everything says “verified” via the sendinblue tests so all appears to be correct so it would help if you can define “wrong authentication.”

stefan1958 it may be but you can get lifetime hosting for 100bux or something along that line through stacksocial dunno if its the same company but I’d venture to say it is.
Now on to the port scan I opened up the port 25 on my router for another PC on the network when I scan port 25 it still says closed so I’m guessing what the tech told me is correct from the ISP they close port 25 which is why I couldn’t send direct in the first place. Now my SASL issues thats another thing.

Anyways I would like to thank the both of you for contributing and trying to help me its helpful sometimes just to type and discuss things sometimes you find your own answers just do to talk other times folks point something useful out that you’ve overlooked. Thank you both for taking a sliver of this short life we live to spend a few minutes to type a message that means a good deal to me.

yes, you can use 25 for MX locally, and relay mail to a relay server on 587 or 465… most ISPs don’t allow port 25 these days. period. but people can still send email by running local MX or relay email to another MX.

wrong authentication usually means wrong username/email and/or pass. but could be other things too…
dont know what’s sendinblue tests, did you try telnet/sendmail from server with your email auth? does it work?

What you need to do has already been mentioned: You need to get an account at a provider like smtp2go, SpamExperts, or Mailchannels. Then, configure Postfix to route all mail to them rather than directly to its destination. This is called “smart hosting” your email. Think of it as a mail proxy.

And yes, ISP’s block port 25 because of spammers, this is a known thing and I’m frankly shocked that in 2022 you’re just running into this.

1 Like