Incremental backup not being incermental

OS type and version Ubuntu Linux 20.04.4
Webmin version 1.991
Virtualmin version 7.0-4
Related packages Virtualmin > Backup & Restore > Scheduled BAckups

Since a few days ago, probably after the new update to webmin 1.991, my daily incremental backups are not incremental anymore. I have a weekly full backup + a daily incremental. It has been working fine for months. Suddenly my daily backup sizes went up from 200M+ to 4.3GB. I tested the archives and they are full backups, not incremental.

I have rechecked the settings, even removed Incremental checkbox and rechecked and saved. It is still the same.

1 Like

Are you doing the backup via the UI, the CLI, or on schedule?

On schedule.

Does the same thing happen if you run an incremental backup from the UI?

I tried a manual backup from Backup Virtual Servers (not schedule backups) section, chose incremental, and it is ok. It is incremental.

I tried also running the Scheduled Backup manually, it is not incremental, as it should be.

If you SSH in as root and run virtualmin list-scheduled-backups --multiline , does it show that backup as incremental?

Response: Incremental: Yes

If you go to Backup and Restore → Backup Logs and click on the scheduled backup that was supposed to be incremental, what does the Backup type field show?

Also, did the last full backup succeed completely for all domains?

In the log, for

The last full backup (weekly) done in 01/05 which is the right day shows: Final status Succeeded
The daily backup report says: Backup type Incremental

But for the past 4 days they are all 4+ GB (not incremental).

@Jamie I have the same issue. All my “incremental” backups are 3GB even when literally nothing is changing that is that significant. Also updated the other day and this started happening.

Is most of the backup perhaps data that cannot be incrementally backed up, like MySQL databases?

Hi Jamie, for me it is not mysql data. I have about 150mb mysql data, which in previous months my daily backups’s size ranged from 150-200mb and the weekly full backup was 4gb. Now since a few days ago, I guess the last webmin update, everyday it is 4gb and the archive contains full backup.
Again, this happens through the scheduled backup module. If I take a manual incremental backup it is ok.

I wasn’t able to re-produce this problem, sorry.

Are all your domains backed up to a single large file? Or is there one file per domain?

Hi Jamie,

having same problem for long time now, didn’t ask about it as I thought this is “normal”.

All my scheduled incremental backups have same size like full backups after reboot of the server/VM/container (whatever). I tend to only reboot servers on saturdays now, so next scheduled backup on sunday is full backup, anyways.

If I forget that and reboot a server during week … full size incremental backups from this time on, sometimes only recognized, when the backup volume fills too much.

It is interesting that may be this happens only for scheduled backups, but not if doing manual incremental.
But: just did a scheduled backup manually i.e. by clicking in the right column on “backup”, then started “running in background” → result was: full size.

Next try: doing the backup really manually → result: full size, too.

If needed, I can provide some pictures of the backup settings - if that helps?

The “backup type” in the logs is always shown as “Incremental”.
Edit: one file per domain.

Best regards,

So if you reboot, then do another full backup, are future incremental backups smaller?


I tried this: rebooted the server, ran the weekly full backup manually (from scheduled backup module) which was completed OK, and then ran a daily incremental backup (from scheduled backup module), but again it turned out as a full backup and not incremental.

Is this server a VM, and if so do you know which virtualization technology it is using (ie. KVM, Xen, LXC or something else?)

It is a VM with Contabo, and they say:
We use hypervisor software KVM – Kernel-based Virtual Machine as a standard hypervisor.
THank you for looking into this Jamie.