In a BIND Again

OS type and version Ubuntu Linux 22.04.2
Webmin version 2.021
Usermin version 1.861
Virtualmin version 7.7
Theme version 20.21
Package updates All installed packages are up to date

A problem with a site (just a new VS domain) added yesterday.
LE was added OK domain has propagated (DNS Checker).
But Today I cannot load the default page :scream: - nothing!
Saw that the BIND server was not running ??
and unresponsive to start (may have been like this for a while) - just noticed :person_shrugging:t2:
Tried to investigate Webmin -> Servers -> BIND DNS Server -> Check BIND Config
and get this

There are 2 other VS on this box both seem to be operating ok (but have not thoroughly checked them)
Any suggestions

found this

1 Like

To fix the issue, simply open up the /etc/named.conf file and delete the line that has ‘dnssec-enable’

Wasn’t there but found in /etc/named.conf.options = done - BIND restarted OK - thank you @stefan1959

curious what the update was?
Don’t know why it was there if no longer required @staff - I don’t go into these files (first time).

1 Like

Did you perhaps enable DNSSEC validation in the BIND DNS Server module? That’s the only place dnssec-enable is set…

Not to my knowledge. I have only recently found that such a thing as BIND was in Virtualmin due to that other error that was reported to me by Virtualmin in a previous post (and that was on a different box)

As indicated in the op this is on a box that has been ticking over happily with 2 domains and all I have done is added a new VS ( Now day 3 and it is still not visible (Yes I know only one subject per topic - so I’ll add this later) but I thought the issue of BIND was the cause.

The BIND issue has been resolved as above I was just curious what had caused it.

1 Like

Was the BIND package upgraded recently? I believe that dnssec-enable option was removed recently…

@Stegan your box is on ubuntu 22.04 so your bind version is 9.18.12. To verify run the command named -v
Have a look at the Release Notes for BIND9 v9.18.12
@Jamie BIND 9.16.0-1ubuntu1 came out for ubuntu 20.04 (focal) in Feb 2020.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.