How to install Virtualmin on AlmaLinux?

Please Help.
How to install Virtualmin on AlmaLinux ?
Manually Or Automatic Script.
Please create “Automated Install script” if possible.

Never install manually. It isn’t worth it.

The beta version of the Virtualmin 7 installer is expected to work pretty well on AlmaLinux and Rocky (but not Debian/Ubuntu, yet, so don’t bother trying on those): https://raw.githubusercontent.com/virtualmin/virtualmin-install/master/virtualmin-install.sh

1 Like

Please share link or script of “The beta version of the Virtualmin 7 installer”.

Just a little heads up for you @Joe

Today, I installed VM 7 on a Rocky 8 distro for testing purposes. The virtualmin-install.sh install script ran fine but I get an error later when going through the post-Installation wizard. Arrived to the “Enable virus scanning with ClamAV?” question, if I select the “Yes, uses up to 2G of RAM” option, I keep getting the following error:

Systemd service clamd@scan cannot be created unless a command is given

The only way I can get over it is to get back and select another option.

SYSTEM INFORMATION
OS type and version Rocky Linux 8.5
Webmin version 1.991
Usermin version 1.840
Virtualmin version 7.0
Theme version 19.91.2
Package updates All installed packages are up to date

The link is in the post you are responding to!

This must be solved by running freshclam command.

So I did:

$ freshclam
ClamAV update process started at Sat May  7 10:38:51 2022
WARNING: Your ClamAV installation is OUTDATED!
WARNING: Local version: 0.103.5 Recommended version: 0.103.6
DON'T PANIC! Read https://docs.clamav.net/manual/Installing.html
daily database available for update (local version: 26533, remote version: 26534)
Current database is 1 version behind.
Downloading database patch # 26534...
Time:    1.2s, ETA:    0.0s [========================>]   16.52KiB/16.52KiB
Testing database: '/var/lib/clamav/tmp.75c0b32f1a/clamav-9188d0ccb95c187296300ec3dc9fb9f2.tmp-daily.cld' ...
Database test passed.
daily.cld updated (version: 26534, sigs: 1983823, f-level: 90, builder: raynman)
main.cvd database is up-to-date (version: 62, sigs: 6647427, f-level: 90, builder: sigmgr)
bytecode.cvd database is up-to-date (version: 333, sigs: 92, f-level: 63, builder: awillia2)

But I still get the same error if I re-run the installation wizard at the same point (Enable virus scanning with ClamAV? → Yes, uses up to 2G of RAM).

That seems related to Rocky. Although, I could make it work by manually calling systemctl enable clamd@scan and then systemctl start clamd@scan (which took forever and only worked from the second or third time).

@Joe, what bothers me is that why neither Alma or Rocky get clamd@scan enabled and running? What does ClamAV.pm and its tests() sub expect to do?

This might not be relevant, but when I first started playing with VM, I made a small script that ran:
dnf install -y clamav-data.noarch
before downloading and running install.sh
The after the install the script runs:
systemctl enable --now clamd@scan

and then to get around the MariaDB password hassle:
mysql_secure_installation

This is all before I do the Post-Installation Wizard which then runs smoothly.

1 Like

Hell if I know. ClamAV breaks all the damned time, because the upstream packagers can’t make up their mind about how services ought to be named and which package is responsible for creating them (if at all). It’s changed literally a dozen times over the past several years.

2 Likes

Anyway, I think we fixed the issue with recent patches.

1 Like

Care to share the script? I’ve run into this on a new fresh install of Alma.

RC7
https://raw.githubusercontent.com/virtualmin/virtualmin-install/76010c7a6f7c121849eae59d9f248df8ecf9f1fb/virtualmin-install.sh

I found this bug on Almalinux 8 with a fresh install in the setup process.

Warning! An error occurred starting MariaDB :

sh: /etc/rc.d/init.d/mysqld: No such file or directory

it’s a proxmox container.

This keeps coming up and we still cannot reproduce it. My AlmaLinux 8.6 install went fine and does not have this problem. It (almost certainly) means the OS has been detected wrong by Webmin, but we can’t figure out why/how.

What’s the output of this command on the system showing this problem?

grep os /etc/webmin/config

And, these two:

cat /etc/redhat-release
cat /etc/almalinux-release

hi

have you tested in a container ?

I have this issue with a container and this template:

Captura de pantalla -2022-05-31 11-32-08

sorry I need to reinstall, I’ve deleted the server. Later I’ll send more info.

We have reproduced it and already fixed it upstream. Webmin 1.995 will have that sorted out.

The solution for now (before running the wizard) would be is to manually replace modules config in /etc/webmin/{apache|bind|mysql|proftpd}/config respectively, found with this command:

find /usr/libexec/webmin -name *AlmaLinux* |grep -E "apache|bind|mysql|proftpd"

@Ilia
Thank you for finding this elusive issue. But I don’t have your experience and need more help. When I execute the ‘find’ command that you provided, I get the following response:

/usr/libexec/webmin/bind8/config-AlmaLinux-Linux-6.0-ALL
/usr/libexec/webmin/mysql/config-AlmaLinux-Linux-7.0-ALL
/usr/libexec/webmin/proftpd/config-AlmaLinux-Linux-7.0-ALL
/usr/libexec/webmin/apache/config-AlmaLinux-Linux-7.0-ALL

What do I do next to fix the problem? Will there be an ‘RC9’ script soon that ‘just works’?

No, as the fix will come with Webmin 1.995 package update.

What do I do next to fix the problem?

Copy those files (overwriting existing) to correspondent /etc/webmin directory, i.e.:

cp /usr/libexec/webmin/mysql/config-AlmaLinux-Linux-7.0-ALL /etc/webmin/mysql/config