has mailman moved?

I’ve restored a virtualmin backup of a domain to a gpl virtualmin on ubuntu 14.04. I see that the mailman archive files are there and when I tried to apt-get install mailman I was told it was already installed. I normally expect to find it through webmin | servers | virtualmin mailman mailing lists but that last entry isn’t under servers.

Has it moved? do I need to enable it?



It should be enabled by default. Do you see an option for it in System Settings -> Features and Plugins? If so, is that enabled?

Also, do you by chance see the module in the Un-Used modules section in Webmin?


I made a new domain as root and made sure mailman lists were enabled. After creation of the domain I logged in as the domain owner and checked under Webmin -> Servers and there is no entry for Virtualmin Mailman Mailing Lists. Should I be looking somewhere else?

With buntu 14.04 I have to install it with webmin modules ( upload ) and manually create a list to get the system to work correctly, otherwise it keeps telling me my system is not ready?

Debian 7 works perfect.

Not sure what is going on with it as you cannot get it on sourceforge anymore, I have an old module here that I use. Afterwards it where you say it is. I have mentioned this a lot on IRC. Everytime I setup a server with 14.04 I get this problem.

Sometimes I think there is a conspiracy :slight_smile: Someone trying to point us to certain distros :wink:

Must admit, Deb7 and VM is very sweet to setup, all I have to do after install and initial setup is add to the DNS for BIND, no faffing around with etc/network/interfaces etc with buntu you have to edit interfaces if using DHCP

With 14.04 you add as instructed and it does nothing, not even save the info??

There is no conspiracy, but there is a slight imbalance in my level of expertise across the distros we support. I use Fedora on my desktop every day, and CentOS on all of our servers and VMs…so, I know it like the back of my hand. Ubuntu I only use for testing and development of Ubuntu support. Debian is similar, but I have more ancient wisdom from having poked at Debian more over the years (and Debian lacks some “features” of Ubuntu designed for desktop users that just get in the way of server users; CentOS 7 now has a similar feature in the form of firewalld/firewall-cmd which is just toxic for server usage, Ubuntu isn’t the only distro doing foolish things to make the OS nicer for desktop users at the expense of the server).

I try to make it nice on all supported systems. If I can reproduce these problems I can usually resolve them, but I don’t have tons of time for debugging most days. I dunno about the thing; is the system running some kind of network daemon that would be resetting it? NetworkManager on CentOS/Fedora systems has to be cajoled into not screwing things up.

Well Joe in the last few days i was thinking the similar thing and how to make a topic on forum. In my opinion Virtualmin list of supported systems is too long. Especially Ubuntu 14.04 LTS what is all but LTS because of some ideas they implemented. Maybe cut that list and just go for Centos and Debian. Ubuntu is based on Debian and i would leave to the user to try to sort the problems.
Note sure what will happen with Centos 7 and his (in)famous changes and how will this reflect in the future, but right now i find it as big mess (personal opinion) and i dont like it at all. I can understand that more systems will make bigger market for Virtualmin but the question is whether it is worth the time, problems and development. Dont hate me but i think Ubuntu should stay on desktop PC or laptop not server.

While I share your preference for Debian over Ubuntu, as a user, from the perspective of what we support Ubuntu just has to be supported. It’s the second most popular OS for Virtualmin after CentOS (CentOS has a little over half of installs, Ubuntu has maybe 30%), and the amount of support queries we’d get if we didn’t support the installer on Ubuntu would be huge, or we’d lose those folks as users and customers.

Ubuntu isn’t that bad. Sure, I question some of their development choices, but nobody is perfect, and on some fronts Ubuntu is actually better than Debian for servers (not on technical merits, but on other stuff, like lifecycle…Ubuntu LTS has a 5 year lifecycle, while Debian only guarantees 3). And, if we were to start talking about all of the other distros and operating systems out there…these three are shining examples of sanity and wisdom. I just wrote a blog post targeted at general web hosting administrators making suggestions for what OS to choose, and these are the three I recommend; we don’t support them just because they’re popular, but because they’re also quite good.

Anyway, we can fix problems when we get good bug reports for any supported OS (and we try to help here in the forums for questions that come even about systems that aren’t well-supported in the installer). Let us know what goes wrong, and we may be able to fix it.

As we all know Ubuntu has a nice EOL, 12.04 is a nice one but some of the servers I use will not install it due to modern hardware unless you faff around with things and I don’t like to take servers off stable for any reason.

Guess we cannot have it all ways. Very happy with Deb 7 at the moment.

Thanks for all your work.

After backing everything up try installing the mailman module again…

You may be being told lies.

The VM team should offer paid per instance to fix things, but I don’t thnk this is your fault.

What is my path forward on this? I need to make restored domains with mailman lists work and need to be able to make a new domain that can have mailman lists.


PS another wrinkle is that if I login as root I can see the mailman servers in the usual place, but I still can’t use them. I tried using the edit virtual server page to first disable mailman lists and save then re-enable and save (as domain owner) - no change

Sorry, I didn’t realize there was an outstanding issue being discussed. I thought we were just ranting about Ubuntu. :wink:

So, I’m not entirely clear what’s wrong. I’m reading you as saying that when logged in as root, you see Mailman Mailing Lists in Virtualmin, but “can’t use them”. What do you mean by “can’t use them”? Can’t edit them in VIrtualmin, or can’t send and receive email from them?

“I tried using the edit virtual server page to first disable mailman lists and save then re-enable and save (as domain owner) - no change”

So, you can see them in Virtualmin as the domain owner and can enable and disable them?

I don’t know what problem we’re trying to help you solve, but I’m sure it’s something simple.

I set up a new U14.04 box and installed Virtualmin GPL. After loggng in as root and creating a domain I restored from a backup that I now know was made with VM Pro. I can see during the restore (which runs fine) that the mailing lists (a half dozen or so) are being restored.

So then I log out and back in as domain owner. The Virtualmin Mailman Mailing Lists are not in the Webmin -> Servers list. Even though I know the list name I can’t in fact send a mail to the list nor can I access domain/pipermail or archives,

If I then logout and back in as root, I see the Mailman entry in the Servers list just as I expect.

As a test, I created a new domain and checked that the server details showed mailman lists were enabled. Even so, the mailman entry is not in the servers list.


I checked that on my Ubuntu 14.04 system, and I do see the “Virtualmin Mailman Mailing Lists” option under Webmin -> Servers, even for Virtual Server owneers.

Out of curiosity, if you create a new test Virtual Server (with the Mailman feature enabled), and then log in as that user, do you see Mailman option in that case?

I’m wondering if there’s some sort of permissions issue for the users that were imported.


I went to Virtualmin -> Services -> Mailing Lists and added a new list. List creation a@a.com seemed to work ok. Adding a first member did this:

Failed to add list member : Add members to a list from the command line. Usage: add_members [options] listname Options: --regular-members-file=file -r file A file containing addresses of the members to be added, one address per line. This list of people become non-digest members. If file is `-', read addresses from stdin. Note that -n/--non-digest-members-file are deprecated synonyms for this option. --digest-members-file=file -d file Similar to above, but these people become digest members. --welcome-msg= -w Set whether or not to send the list members a welcome message, overriding whatever the list's `send_welcome_msg' setting is. --admin-notify= -a Set whether or not to send the list administrators a notification on the success/failure of these subscriptions, overriding whatever the list's `admin_notify_mchanges' setting is. --nomail -n Set the newly added members mail delivery to disabled by admin. --help -h Print this help message and exit. listname The name of the Mailman list you are adding members to. It must already exist. You must supply at least one of -r and -d options. At most one of the files can be `-'. 



Thanks for the error output – I’m doing some testing with that to see if I can reproduce that issue.


Okay, I was able to reproduce a problem adding list members using Webmin -> Servers -> Mailman -> Members.

I’ll work with Jamie regarding that, so that can be fixed up.

However, there are other ways to add list members that shouldn’t cause a problem.

You can go into Webmin -> Servers -> Mailman -> Manage, and there, you’d be interacting with Mailman itself, where you can add members.

Also, people desiring to be on the list can also use the various email aliases created in /etc/aliases for list management, such as joining, posting, and leaving.


After some testing, we determined that there was an issue with Virtualmin’s support for newer Mailman versions.

The exact syntax to use for adding new members is different in those newer versions, so when doing that using the Virtualmin interface, it was throwing the error that you saw.

That will be fixed in the next Mailman version, though you can also get around it by adding users via the other two means mentioned above.


this bit from your post

You can go into Webmin -> Servers -> Mailman

fails because mailman isn’t a listed server. I’ve looked at the domain features enabled page and mailman lists is ticked. Don’t know where else to look.


Ah, it should indeed show up there.

Is it by chance in the Un-Used Modules Section at the bottom of the left menu in Webmin?

That’s one place it may be showing up if there’s some sort of Mailman/configuration issue.


There are two cases - admin user and domain owner.

As admin there is under webmin -> servers an entry for Virtualmin Mailman Mailing Lists. So as admin I can see all domains and after selecting the relevant domain from the pull-down list I go to Virtualmin -> Administration Options -> Edit Owner Options and in Allowed Features for Servers I see that the mailman box is ticked.

So logging out then in as domain owner for that domain I go to Webmin -> Servers and there it isn’t. I don’t know why or where to look.

Something I noticed during setup was that the mailman-owners (I think) list wasn’t set up and I had to make the first domain in order to get it created. But that list is still unpopulated, even with a dozen domains.

The entry (visible to admin) says that the list named mailman has “no domain” and there are no members, and apparently no way to add them - when I try I get no response. Don’t know if this is relevant