Filesystem backup running forever

SYSTEM INFORMATION
Debian Linux 11 REQUIRED
Webmin 1.981 REQUIRED
I don’t know where I would find the Virtualmin version REQUIRED

I installed Debian and Webmin on an old Buffalo Terastation 5800 that I bought from a university surplus store.

I got everything up and running, but I want to back everything up to my Synology DS413 NAS. I thought I had Filesystem Backup configured correctly (because it kept telling me when I didn’t), and right now it looks like a backup is running.

However, that same backup has been running for 8 days now. I see a bunch of stuff in the logs under/var/webmin/miniserv.error, but I’m not even sure if these are an indication of a problem or if it’s actually running correctly.

The two most recent lines are:
Subroutine is_dictionary_word redefined at /usr/share/webmin/acl/md5-lib.pl line 261.
Use of uninitialized value $access{“role”} in split at /usr/share/webmin/webmin/webmin-lib.pl line 1224.

Since this is the first backup from this system to the other, it’s somewhere around 1 TB, so it’s pretty big. But is it 8 days big?

@mediagiant,

Virtualmin Version is located on the Dashboard of Virtualmin. It lists, “Virtualmin”, “Webmin”, “Usermin” and even “Authentic Theme” version of that page.

Is your NAS connected via USB2/3 or LAN? Do a smaller sized backup as a test like a 1MB file/directory, so you can confirm config is correct. Yes 1TB is large, especially if USB2 and it may just be stuck hence above to see if setup actually works.

It’s connected via LAN.

Unfortunately, any smaller backup I attempt would be in line behind the larger one, which is STILL running (?) over two weeks later. So, I can’t really test that without eliminating the backup in progress.

Any other ideas? Anything I should be checking in the logs? Should I just terminate this backup because I know it’s not really doing anything?

I’m not using Virtualmin. I’m only using Webmin.

There is no point to have a backup running for 8 days, yes I would cancel and test with a small file as a proof of concept.

I think the setup with buffalo running Debian/Virtualmin is just too slow. The cpu is atom. Meaning your config/ Virtualmin setup may be correct but as the hardware isn’t really great, it will be mega slow. Make sure Virtualmin backup compression is not enabled and NAS is directly connected. Try to backup smaller files as proof of concept.

If you have a spare pc/mini pc or another device, I would use that as the gateway with Virtualmin then attach buffalo and NAS to that device. Appreciate it may not be possible or budget for it though. But the original setup will be extremely slow otherwise.

Maybe you could run usbtop command to see if the usb is actually being written to.

Use sudo iotop to check disk read speed on the server being backed up.
Or some network monitoring tool to check the bandwidth. With that info you can calculate how long it should take (approx). Or you could find that the job is totally stuck and doing nothing.

It’s not USB, it’s over LAN…from one NAS to another.

I scrapped my original backup and attempted a much smaller one. Same result. It just seems to run forever without doing anything.

I’m not sure why this is happening, so any insight would be appreciated.

It’s clearly stuck and doing nothing. Even when I canceled the backup job and tried to run something much smaller over the LAN, even that got stuck for a week without any action.

This is my Webmin configuration. 192.168.1.4 is the local address of my Synology server. I have entered my username for the Synology server and the password for it on this screen.

This should be a relatively small backup job.

Am I doing something wrong here?

It feels a little strange not masking some of this information, but I feel like it’s necessary to show everything in case I went astray in one of these fields.

In the long run, I want to move that Synology server offsite, but if I can’t even back up to it locally, I don’t know how in the world I would back up to it over the internet.

Are you filling out the Backup Options tab correctly? Are you sure the SSH is working? What are the error logs saying?

If you make a folder and put a text file in it and back it up it should be pretty much instantaneous. If that’s not working at all then I would suspect your SSH isn’t working for some reason or you didn’t fill out the Options tab so it doesn’t know what to do.

There’s nothing obviously wrong to me, but I’m a noob, so I might be missing something that would be obvious to you. When you ask if I’m filling out the backup options correctly, I’m not sure what “correctly” is in this case.

Here are the logs. I honestly have no idea what I’m looking for here.

What is the file or device Daniel? I believe this should point to a path on your host that you are ssh’ing into.

That is the name of the folder on the Synology NAS where I want the backup to save to.

So, with the knowledge that the folder Daniel is the destination folder on my Synology NAS, what does that tell you?

Another option I have considered (and might even prefer) is rsync, but I haven’t had any success getting that to work either. So, any suggestions you can provide on that would be appreciated.

In the long run, my goal is to move the Synology NAS offsite and run regular backups to it, but I can’t even get it to sync when it’s three feet away on LAN.

Is there something I need to set up on the other end to make this work? I have configured the Synology NAS for rsync, but there might be something I’m missing there to make the backup run.

On that machine where you’re running Webmin, can you SSH to this server and try to login to your NAS using command:

ssh -v danieladougan@192.168.1.4

If that works keep checking further – try to switch to run your backup in a foreground using System ⇾ Filesystem Backup ⇾ Configuration: Configurable options page to see what’s happening upon the backup.

Thanks. I went to Tools > Command Shell and entered the command you supplied.

ssh -v danieladougan@192.168.1.4

I got this in response:

danieladougan@192.168.1.4: Permission denied (publickey,password).

It never gave me an opportunity to enter a password though. Am I doing this in the wrong place?

@mediagiant,

This means that SSH is configured to “not allow” password authentication, hence it’s looking only for a valid public/private key pair.

You would place the “private key” in a file typically called “id_rsa” (which is the default name when you generate one using “ssh-keygen”) within the folder “/home/username/.ssh”.

The “public key” would then be pasted in a file called “authorized_keys” on the remote server inside the folder “/home/username/.ssh”.

If all of this seems confusing, I’d be happy for a small fee assist you in getting things setup and working in it’s entirty.

Drop me a line if you’re interested.