Filesystem backup running forever

You should SSH to the server (using a terminal program on your desktop PC). The command shell line on Webmin UI doesn’t have user input, and thus you won’t be able to enter a password.

I think I finally figured it out. I was pointing to the folder Daniel when I should have been pointing to volume1 on the Synology NAS. The Daniel folder is inside of the volume1 folder, and that’s where I wanted things to be. It took a lot of playing with SSH last night to figure out that problem because it’s not apparent through the Synology UI.

The backup worked!

Thanks for your help, everyone. I really appreciate it! It was such a stupid problem.

2 Likes

I might have spoken too soon. The backup is once again running forever without saving any files to the Synology NAS, and I have no idea why.

Can anyone offer any further suggestions for troubleshooting? I’ve tried a number of steps, but no such luck. If the problem is on my Synology NAS, I could check that too. But I really need to get this backup to work.

One thing I keep seeing in the logs is:

Use of uninitialized value $access{“role”} in split at /usr/share/webmin/webmin/webmin-lib.pl line 1224.

I think this could be a clue, but I’m not sure what I would do about that.

Above, after some tests. Backup was confirmed working after sorting out relative paths/ directories. Was that a full test backup or a smaller dir/file backup to test? Under backup settings, did you disable compression. You haven’t changed paths again?

Here’s my most recent attempt. Note the directories listed. This was a relatively small directory to test before doing the full backup.

Can you do a background backup of 100mb and 500mb if possible? The log should then say how long it took each. My original post that 1TB could be one job too many for the hardware, perhaps realistic but good to troubleshoot through.

The folder I am currently attempting to backup as a test is 300 MB, and not one of the files in it has appeared on the Synology server.

Under backup and restore, destination options - have you tried to change the default backup compression to zip? It doesn’t look like it can find the destination path?

Forgive me, but I don’t see this menu option. Could you please clarify where I would find it?

Previously, when I experimented with different settings for the backup, if I chose a directory that didn’t exist or whatever, I would immediately get an error that there was nowhere to backup to. But that’s not what’s happening now. It’s just “running” without doing anything.

Backup and Restore under Virtualmin —> Scheduled backups —> choose one of the backups —> under destination and format.

I sincerely appreciate your help.

No wonder I couldn’t see it though. I’m not using Virtualmin. I only have Webmin.

Just to verify where I’m putting things, here’s a screenshot. Note that 192.168.1.4 is my Synology server, which is nicknamed microfourbirds. As you can see from the terminal, /volume1/Backup is a valid destination.

Any other ideas?

Interestingly, I tried replacing 192.168.1.4 with microfourbirds, but then I get an error that there’s no valid host to backup to.

OK so under file system backup. When you click on the job scroll down and look at backup options. In there you will have the compression option as attached on screenshot. There are some options there that you should say no to. I’m on mobile at the moment and can’t really see the full screen to view.

Your path with IP looks OK. I assume you can backup locally fine?. From webmin interface to same server (small file). That terminal window to the Synology, is it from the webmin server or your desktop, looks like your desktop. Did you test to ssh from the webmin server at all?

Do you see any errors like ssh_exchange_identification: Connection closed by remote host - which may be certificate issue rejecting the connection. In the Synology portal, there must be something with the keys or permission with the directories perhaps that are not set correctly. Meaning connection is there and path ok but with wrong directory permissions, webmin can’t actually write to the device. There must be something logged somewhere that can give us more of a lead to troubleshoot better.

Sorry I can’t be much of help here.

Well, that’s not quite what I see. There’s no option for “Yes, with gzip.”

As far as testing SSH directly from the Webmin server, here’s what happened. There was no place for me to enter a password, so it wouldn’t let me get to it. I do have the password entered on the Filesystem Backup.

I searched the error logs for ssh_exchange_identification, and I came up empty.

I just tried to run a local backup, but the red line just goes back and forth across the screen for awhile without anything happening.

You could try to install the Webmin SSH Login module? Will need a browser that can support Java. Module can be removed later as needed, it’s for the testing. Synology control panel can drop the password and use keys only, but we are trying to confirm that there is a connection and port 22 is not blocked anywhere.

Could you untick the compress level 1 option. Then test your 300mb test backup.

As an update, I gave up on Filesystem Backup and used rsync. I was able to get a successful backup, but I want this to keep happening on a schedule. I created a Cron job, but I know I’ll need to set up the keys to make all of this work without a password.

Any advice on that? I’ve tried a few commands like this from my Webmin server:

ssh-keygen

ssh-copy-id -i /home/danieladougan/.ssh/id_rsa.pub 192.168.1.4

But this error plagued me:

Could not chdir to home directory /var/services/homes/danieladougan: No such file or directory
sh: line 0: cd: /var/services/homes/danieladougan: No such file or directory

Any ideas?

This new question about rsync deserves a new topic pls.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.