Failed to create virtual server : Failed to work out externally visible IP address [rehash of previous issues]]

I realise that this may get overlooked as its been asked a few times here:

When I set up a new site, and get the message in the title. The second & third post from above does fix the issue to a degree, As Ilia states:

It’s not a big of a deal. Help Virtualmin to work out your IP address by settings this up manually in System Settings/Virtualmin Configuration.

but unlike them:

when I put in my IP address, and recheck the issue, it resorts back to eth0. So my system works so long is it remains unchecked. Otherwise, it reverts from ‘detect automatically’ from eth0 and I get the message: Failed to create virtual server : Failed to work out externally visible IP address

Its fine so long as I get it work (and don’t recheck config), it just seems like there is a better way. What I am missing?

This happened out of the blue as well (I’ve set up ~30 working sites previously with no issue). All ears if anyone thinks they can help.

1 Like

Hi,

Thanks for heads up.

I will assign this to @Jamie for a review.

Perhaps add google nameservers to your network dns settings in virtualmin… 8.8.4.4 and 8.8.8.8 (from memory i think these were the entries)

If it works for you, then i think you have to go into the file where this is stored and make the file immutable so virtualmin cant over write it on restart .

Hey Guys - thanks for the super quick response! Will try this when I get back to my computer this evening.

Also, it might also be worth checking your template for new virtual servers as well. Its been a while since ive had this error so im a bit rusty on the fix for it.

adamjedgar - I am sure been using the default template for everything, but I have customised account plan I’ve created for last 5 sites I have added. I’ll check all this in a few hours. thanks again.

Hi Adam, sorry for the delayed response, I didn’t have time to check this until now. Where do change/add the network dns settings in Virtualmin?

Also, I am happy to run stuff in the command, and or take screenshots of the interface if that is help. I am currently looking in Virtualmin -> system settings -> virtualmin configuration -> network settings, but I don’t think I see an area to to add the google network dns?

This isn’t urgent, since I can add sites without configuration confirmation (so for no probs, which is good because I have a couple more to add today). However, just looking for the best way to go about this.

thanks again!

Maybe related: I ran into the same error message yesterday. I’ve been doing some tests with backup restore and was really puzzled why this error suddenly popped up when things worked fine earlier.

It seems Virtualmin does validation for external IP using software.virtualmin.com. Yesterday, the service returned error 500 on several occassions, which caused the validation to fail. Right now things seem to be better again, with valid responses.

The same issue impacted also DNS resolvability check.

check out all of the following…
https://www.virtualmin.com/node/25374
https://virtualmin.com/node/67670
https://virtualmin.com/node/65753
https://www.virtualmin.com/node/24040

Also, if you are running your system such that its supposed to also be acting as a nameserver, have your correctly configured your glue records at your registrar so that your system is internationally recognised as a nameserver? If not, then you need to consider that there are two methods of using a webhosting system…

  1. it runs as a nameserver for all of its virtual hosts (dns registrars for your clients have an ns record pointing at your nameserver (which in this case is also your hosting system). Your servers own Bind dns is directly involved in linking the outside world with the various domains on your hosting system. OR,

  2. your webhosting system is not a nameserver and therefore all virtual host dns registrars must have an “A record” pointing at your hosting server ip address. virtulamin then use the virtual hosts file to resolve each domain request to the appropriate public_html directory on your web server.

I personally do not use option 1 above because
a. i only have a dozen websites on my system
b. i personally manage all the client domains and most of their dns as well…so i can change the A-records at my client registrars at any time should i need to choose a different ipaddress.
c. i dont like the idea of my hosting server also being a nameserver. Always worries me about the implications of an attack on the dns…its also a direct attack on the exact same system that is hosting websites too.
d. dont have the budget to run the standard 5 systems hosting configuration (webhosting server, mx1 email, mx2 backup email, ns1+ ns2 nameservers)

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.