Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages

SYSTEM INFORMATION
OS type and version Ubuntu Linux 20.04.5
Virtualmin version 7.2-1

Howdy

due to the following message:

Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 apache2-suexec-custom : Depends: apache2-bin but it is not going to be installed
                         Depends: libc6 (>= 2.34) but 2.31-0ubuntu9.9 is to be installed
 at : Depends: libpam-runtime (>= 1.0.1-11) but it is not going to be installed
      Depends: libc6 (>= 2.34) but 2.31-0ubuntu9.9 is to be installed
      Depends: libpam0g (>= 0.99.7.1) but it is not going to be installed
      Depends: libselinux1 (>= 3.1~) but it is not going to be installed
 awscli : Depends: python3 but it is not going to be installed
          Depends: python3-pyasn1 but it is not going to be installed
          Depends: python3-colorama but it is not going to be installed
          Depends: python3-docutils but it is not going to be installed
          Depends: python3-yaml but it is not going to be installed
          Depends: python3:any
 bsdmainutils : Depends: bsdextrautils (>= 2.35.2-7) but it is not installable
                Depends: ncal but it is not going to be installed
 certbot : Depends: debconf (>= 0.5) but it is not going to be installed or
                    debconf-2.0
           Depends: python3:any
 cpp-9 : Depends: libc6 (>= 2.34) but 2.31-0ubuntu9.9 is to be installed
         Depends: libgmp10 (>= 2:6.2.1+dfsg) but it is not going to be installed
         Depends: libisl23 (>= 0.15) but it is not installable
         Depends: libmpc3 (>= 1.1.0) but it is not going to be installed
         Depends: libmpfr6 (>= 3.1.3) but it is not going to be installed
         Depends: zlib1g (>= 1:1.1.4) but it is not going to be installed
 cryptsetup-run : Depends: cryptsetup (>= 2:2.1.0-6) but it is not going to be installed
 fail2ban : Depends: python3:any
            Recommends: nftables but it is not installable or
                        iptables but it is not going to be installed
            Recommends: whois but it is not going to be installed
            Recommends: python3-pyinotify but it is not going to be installed
            Recommends: python3-systemd but it is not going to be installed
 firewalld : Depends: dbus but it is not going to be installed
             Depends: gir1.2-glib-2.0 but it is not going to be installed
             Depends: gir1.2-nm-1.0 but it is not going to be installed
             Depends: policykit-1 but it is not going to be installed
             Depends: python3-dbus but it is not going to be installed
             Depends: python3-gi but it is not going to be installed
             Depends: python3:any
             Recommends: ipset but it is not going to be installed
             Recommends: iptables but it is not going to be installed
             Recommends: python3-cap-ng but it is not going to be installed
 fuse : Depends: libc6 (>= 2.34) but 2.31-0ubuntu9.9 is to be installed
        Depends: adduser but it is not going to be installed
        Depends: mount (>= 2.19.1) but it is not going to be installed
        Depends: sed (>= 4) but it is not going to be installed
 galera-3 : Depends: libc6 (>= 2.34) but 2.31-0ubuntu9.9 is to be installed
            Depends: libssl3 (>= 3.0.0~~alpha1) but it is not installable
            Depends: libstdc++6 (>= 11) but it is not going to be installed
 gcc-9 : Depends: libcc1-0 (>= 9.4.0-5ubuntu1) but it is not going to be installed
         Depends: binutils (>= 2.37.90.20220130) but it is not going to be installed
         Depends: libc6 (>= 2.34) but 2.31-0ubuntu9.9 is to be installed
         Depends: libgmp10 (>= 2:6.2.1+dfsg) but it is not going to be installed
         Depends: libisl23 (>= 0.15) but it is not installable
         Depends: libmpc3 (>= 1.1.0) but it is not going to be installed
         Depends: libmpfr6 (>= 3.1.3) but it is not going to be installed
         Depends: libstdc++6 (>= 5) but it is not going to be installed
         Depends: zlib1g (>= 1:1.1.4) but it is not going to be installed
         Recommends: libc6-dev (>= 2.13-0ubuntu6) but it is not going to be installed
 gnupg2 : Depends: gnupg (>= 2.2.27-3ubuntu2) but it is not going to be installed
 groff : Depends: groff-base (= 1.22.4-8build1) but it is not going to be installed
         Depends: libc6 (>= 2.35) but 2.31-0ubuntu9.9 is to be installed
         Depends: libstdc++6 (>= 4.1.1) but it is not going to be installed
         Depends: libx11-6 but it is not going to be installed
         Depends: libxaw7 (>= 2:1.0.14) but it is not going to be installed
         Depends: libxmu6 (>= 2:1.1.3) but it is not going to be installed
         Depends: libxt6 but it is not going to be installed
         Recommends: ghostscript but it is not going to be installed
         Recommends: libpaper1 but it is not going to be installed
         Recommends: perl but it is not going to be installed
         Recommends: psutils but it is not going to be installed
 imagemagick-6.q16 : Depends: libc6 (>= 2.34) but 2.31-0ubuntu9.9 is to be installed
                     Recommends: ghostscript but it is not going to be installed
 jailkit : Depends: libc6 (>= 2.34) but 2.31-0ubuntu9.9 is to be installed
           Depends: python3:any
 libalgorithm-c3-perl : Depends: perl:any
 libasan5 : Depends: libc6 (>= 2.34) but 2.31-0ubuntu9.9 is to be installed
 libasn1-8-heimdal : Depends: libcom-err2 (>= 1.43.9) but it is not going to be installed
 libauthen-pam-perl : Depends: perl but it is not going to be installed
                      Depends: perlapi-5.34.0 but it is not installable
                      Depends: libc6 (>= 2.34) but 2.31-0ubuntu9.9 is to be installed
                      Depends: libpam0g (>= 0.99.7.1) but it is not going to be installed
 libclass-c3-perl : Depends: perl:any
 libclass-c3-xs-perl : Depends: perl but it is not going to be installed
                       Depends: perlapi-5.34.0 but it is not installable
                       Depends: libc6 (>= 2.34) but 2.31-0ubuntu9.9 is to be installed
 libcrypt-random-seed-perl : Depends: perl:any
 libcrypt-ssleay-perl : Depends: perl but it is not going to be installed
                        Depends: perl-openssl-abi-3 but it is not installable
                        Depends: perlapi-5.34.0 but it is not installable
                        Depends: libc6 (>= 2.34) but 2.31-0ubuntu9.9 is to be installed
                        Depends: libssl3 (>= 3.0.0~~alpha1) but it is not installable
                        Depends: libbytes-random-secure-perl but it is not going to be installed
                        Recommends: perl (>= 5.19.8) but it is not going to be installed or
                                    libio-socket-ip-perl (>= 0.26)
 libdbd-mysql-perl : Depends: perl but it is not going to be installed
                     Depends: perl-dbdabi-94
                     Depends: perlapi-5.34.0 but it is not installable
                     Depends: libc6 (>= 2.34) but 2.31-0ubuntu9.9 is to be installed
                     Depends: libmysqlclient21 (>= 8.0.11) but it is not going to be installed
                     Depends: libdbi-perl but it is not going to be installed
 libdevel-caller-perl : Depends: perl but it is not going to be installed
                        Depends: perlapi-5.34.0 but it is not installable
                        Depends: libc6 (>= 2.34) but 2.31-0ubuntu9.9 is to be installed
 libdevel-globaldestruction-perl : Depends: perl:any
                                   Depends: libsub-exporter-progressive-perl but it is not going to be installed
                                   Depends: perl (>= 5.14.0) but it is not going to be installed
 libdevel-lexalias-perl : Depends: perl but it is not going to be installed
                          Depends: perlapi-5.34.0 but it is not installable
                          Depends: libc6 (>= 2.34) but 2.31-0ubuntu9.9 is to be installed
 libdist-checkconflicts-perl : Depends: perl:any
                               Depends: libmodule-runtime-perl (>= 0.009) but it is not going to be installed
 libfuse2 : Depends: libc6 (>= 2.34) but 2.31-0ubuntu9.9 is to be installed
 libgcc-9-dev : Depends: libgomp1 (>= 9.4.0-5ubuntu1) but it is not going to be installed
                Depends: libitm1 (>= 9.4.0-5ubuntu1) but it is not going to be installed
                Depends: libatomic1 (>= 9.4.0-5ubuntu1) but it is not going to be installed
                Depends: liblsan0 (>= 9.4.0-5ubuntu1) but it is not going to be installed
                Depends: libtsan0 (>= 9.4.0-5ubuntu1) but it is not going to be installed
                Depends: libubsan1 (>= 9.4.0-5ubuntu1) but it is not going to be installed
                Depends: libquadmath0 (>= 9.4.0-5ubuntu1) but it is not going to be installed
                Recommends: libc6-dev (>= 2.13-0ubuntu6) but it is not going to be installed
 libgcc-s1 : Depends: gcc-10-base (= 10.3.0-1ubuntu1~20.04) but 10.3.0-15ubuntu1 is to be installed
 libgeoip1 : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.9 is to be installed
 libgssapi3-heimdal : Depends: libc6 (>= 2.34) but 2.31-0ubuntu9.9 is to be installed
                      Depends: libcom-err2 (>= 1.43.9) but it is not going to be installed
 libhcrypto4-heimdal : Depends: libc6 (>= 2.34) but 2.31-0ubuntu9.9 is to be installed
 libheimbase1-heimdal : Depends: libc6 (>= 2.34) but 2.31-0ubuntu9.9 is to be installed
 libhx509-5-heimdal : Depends: libc6 (>= 2.34) but 2.31-0ubuntu9.9 is to be installed
                      Depends: libcom-err2 (>= 1.43.9) but it is not going to be installed
 libipc-shareable-perl : Depends: perl:any
                         Depends: libjson-perl but it is not going to be installed
                         Depends: libstring-crc32-perl but it is not going to be installed
 libkrb5-26-heimdal : Depends: libc6 (>= 2.34) but 2.31-0ubuntu9.9 is to be installed
                      Depends: libcom-err2 (>= 1.43.9) but it is not going to be installed
                      Depends: libsqlite3-0 (>= 3.5.9) but it is not going to be installed
 liblog-dispatch-perl : Depends: perl:any
                        Depends: libmodule-runtime-perl but it is not going to be installed
                        Depends: libnamespace-autoclean-perl but it is not going to be installed
                        Depends: libparams-validationcompiler-perl but it is not going to be installed
                        Depends: libtry-tiny-perl but it is not going to be installed
                        Recommends: libmail-sendmail-perl but it is not going to be installed
                        Recommends: libmailtools-perl but it is not going to be installed
                        Recommends: libmime-lite-perl but it is not going to be installed
 liblog-log4perl-perl : Depends: perl:any
 liblua5.2-0 : Depends: libc6 (>= 2.34) but 2.31-0ubuntu9.9 is to be installed
               Depends: libstdc++6 (>= 4.1.1) but it is not going to be installed
 libmagickcore-6.q16-6 : PreDepends: dpkg (>= 1.17.6) but it is not going to be installed
                         Depends: libbz2-1.0 but it is not going to be installed
                         Depends: libc6 (>= 2.35) but 2.31-0ubuntu9.9 is to be installed
                         Depends: libfftw3-double3 (>= 3.3.5) but it is not going to be installed
                         Depends: libfontconfig1 (>= 2.12.6) but it is not going to be installed
                         Depends: libfreetype6 (>= 2.2.1) but it is not going to be installed
                         Depends: libgomp1 (>= 6) but it is not going to be installed
                         Depends: libheif1 (>= 1.4.0) but it is not going to be installed
                         Depends: libjbig0 (>= 2.0) but it is not going to be installed
                         Depends: libjpeg8 (>= 8c) but it is not going to be installed
                         Depends: liblcms2-2 (>= 2.6) but it is not going to be installed
                         Depends: liblqr-1-0 (>= 0.4.0) but it is not going to be installed
                         Depends: libltdl7 (>= 2.4.6) but it is not going to be installed
                         Depends: libopenjp2-7 (>= 2.0.0) but it is not going to be installed
                         Depends: libpng16-16 (>= 1.6.2-1) but it is not going to be installed
                         Depends: libtiff5 (>= 4.0.3) but it is not going to be installed
                         Depends: libwebp7 but it is not installable
                         Depends: libwebpdemux2 but it is not going to be installed
                         Depends: libwebpmux3 but it is not going to be installed
                         Depends: libx11-6 but it is not going to be installed
                         Depends: libxext6 but it is not going to be installed
                         Depends: libxml2 (>= 2.7.4) but it is not going to be installed
                         Depends: zlib1g (>= 1:1.1.4) but it is not going to be installed
                         Recommends: ghostscript but it is not going to be installed
 libmagickcore-6.q16-6-extra : Depends: libc6 (>= 2.35) but 2.31-0ubuntu9.9 is to be installed
                               Depends: libcairo2 (>= 1.6.0) but it is not going to be installed
                               Depends: libdjvulibre21 (>= 3.5.28) but it is not going to be installed
                               Depends: libglib2.0-0 (>= 2.12.0) but it is not going to be installed
                               Depends: libopenexr25 (>= 2.5.7) but it is not going to be installed
                               Depends: libpango-1.0-0 (>= 1.22.0) but it is not going to be installed
                               Depends: libpangocairo-1.0-0 (>= 1.14.0) but it is not going to be installed
                               Depends: libwmflite-0.2-7 (>= 0.2.12) but it is not installable
                               Depends: libxml2 (>= 2.7.4) but it is not going to be installed
                               Recommends: libjxr-tools but it is not going to be installed
 libmagickwand-6.q16-6 : PreDepends: dpkg (>= 1.17.6) but it is not going to be installed
                         Depends: libgomp1 (>= 4.9) but it is not going to be installed
                         Depends: libx11-6 but it is not going to be installed
 libmath-random-isaac-perl : Depends: perl:any
 libmath-random-isaac-xs-perl : Depends: perl but it is not going to be installed
                                Depends: perlapi-5.34.0 but it is not installable
                                Depends: libc6 (>= 2.34) but 2.31-0ubuntu9.9 is to be installed
 libmilter1.0.1 : Depends: libc6 (>= 2.34) but 2.31-0ubuntu9.9 is to be installed
 libmro-compat-perl : Depends: perl:any
 libnetpbm10 : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.9 is to be installed
 libopendkim11 : Depends: libbsd0 (>= 0.0) but it is not going to be installed
                 Depends: libc6 (>= 2.34) but 2.31-0ubuntu9.9 is to be installed
                 Depends: libdb5.3 but it is not going to be installed
                 Depends: libssl3 (>= 3.0.0~~alpha1) but it is not installable
 libpadwalker-perl : Depends: perl but it is not going to be installed
                     Depends: perlapi-5.34.0 but it is not installable
 libparse-syslog-perl : Depends: perl:any
 libroken18-heimdal : Depends: libc6 (>= 2.34) but 2.31-0ubuntu9.9 is to be installed
 libspecio-perl : Depends: perl:any
                  Depends: libdevel-stacktrace-perl but it is not going to be installed
                  Depends: libeval-closure-perl but it is not going to be installed
                  Depends: libmodule-runtime-perl but it is not going to be installed
                  Depends: librole-tiny-perl but it is not going to be installed
                  Depends: libsub-quote-perl but it is not going to be installed
                  Recommends: libref-util-perl but it is not going to be installed
 libssh2-1 : Depends: libssl3 (>= 3.0.0~~alpha1) but it is not installable
             Depends: zlib1g (>= 1:1.1.4) but it is not going to be installed
 libwind0-heimdal : Depends: libcom-err2 (>= 1.43.9) but it is not going to be installed
 libwmf0.2-7 : Depends: libwmf-0.2-7 (>= 0.2.12-5ubuntu1) but it is not installable
               Depends: libwmflite-0.2-7 (>= 0.2.12-5ubuntu1) but it is not installable
 libxstring-perl : Depends: perl but it is not going to be installed
                   Depends: perlapi-5.34.0 but it is not installable
                   Depends: libc6 (>= 2.34) but 2.31-0ubuntu9.9 is to be installed
 lm-sensors : Depends: sed (>= 4.0.5-1) but it is not going to be installed
              Depends: libc6 (>= 2.34) but 2.31-0ubuntu9.9 is to be installed
              Depends: libsensors5 (>= 1:3.5.0) but it is not going to be installed
              Depends: perl:any
 ltrace : Depends: libc6 (>= 2.34) but 2.31-0ubuntu9.9 is to be installed
          Depends: libelf1 (>= 0.131) but it is not going to be installed
          Depends: libselinux1 (>= 3.1~) but it is not going to be installed
 mariadb-client : Depends: mariadb-client-10.6 (>= 1:10.6.7-2ubuntu1) but it is not going to be installed
 mariadb-server : Depends: mariadb-server-10.6 (>= 1:10.6.7-2ubuntu1) but it is not going to be installed
 milter-greylist : Depends: libc6 (>= 2.34) but 2.31-0ubuntu9.9 is to be installed
                   Depends: libcurl4 (>= 7.16.2) but it is not going to be installed
                   Depends: libspf2-2 but it is not going to be installed
                   Depends: init-system-helpers (>= 1.51) but it is not going to be installed
                   Depends: adduser (>= 3.11) but it is not going to be installed
                   Recommends: sendmail but it is not going to be installed or
                               postfix but it is not going to be installed
 netpbm : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.9 is to be installed
          Depends: libjpeg8 (>= 8c) but it is not going to be installed
          Depends: libpng16-16 (>= 1.6.2-1) but it is not going to be installed
          Depends: libtiff5 (>= 4.0.3) but it is not going to be installed
          Depends: zlib1g (>= 1:1.1.4) but it is not going to be installed
          Recommends: ghostscript but it is not going to be installed
 p7zip : Depends: libstdc++6 (>= 5) but it is not going to be installed
 php-fpm : Depends: php8.1-fpm but it is not going to be installed
 php-imagick : PreDepends: php-common (>= 2:69~) but it is not going to be installed
               Depends: php8.1-imagick but it is not going to be installed
               Recommends: ghostscript but it is not going to be installed
 php-mbstring : Depends: php-common but it is not going to be installed
                Depends: php8.1-mbstring but it is not installable
 php-ssh2 : PreDepends: php-common (>= 2:69~) but it is not going to be installed
            Depends: php8.1-ssh2 but it is not going to be installed
 popularity-contest : PreDepends: debconf (>= 1.5.34) but it is not going to be installed or
                                  cdebconf (>= 0.106) but it is not installable
                      Depends: debconf (>= 0.5) but it is not going to be installed or
                               debconf-2.0
                      Depends: dpkg (>= 1.10) but it is not going to be installed
                      Recommends: gpg but it is not going to be installed
                      Recommends: cron or
                                  cron-daemon
 postgrey : Depends: adduser but it is not going to be installed
            Depends: debconf but it is not going to be installed
            Depends: libberkeleydb-perl but it is not going to be installed
            Depends: libnetaddr-ip-perl but it is not going to be installed
            Depends: libnet-dns-perl but it is not going to be installed
            Depends: libnet-server-perl (>= 0.87) but it is not going to be installed
            Depends: perl but it is not going to be installed
            Depends: ucf (>= 0.28) but it is not going to be installed
            Depends: debconf (>= 0.5) but it is not going to be installed or
                     debconf-2.0
            Recommends: libnet-rblclient-perl but it is not going to be installed
            Recommends: postfix but it is not going to be installed or
                        exim4 but it is not installable
 proftpd-basic : Depends: proftpd-core but it is not going to be installed
                 Depends: proftpd-mod-wrap but it is not going to be installed
                 Depends: proftpd-mod-crypto but it is not going to be installed
 python3-acme : Depends: ca-certificates but it is not going to be installed
                Depends: python3-openssl (>= 17.3.0) but it is not going to be installed
                Depends: python3-cryptography (>= 2.1.4) but it is not going to be installed
                Depends: python3-pkg-resources but it is not going to be installed
                Depends: python3-requests but it is not going to be installed
                Depends: python3-requests-toolbelt but it is not going to be installed
                Depends: python3-rfc3339 but it is not going to be installed
                Depends: python3-tz but it is not going to be installed
                Depends: python3:any
 python3-botocore : Depends: python3-dateutil but it is not going to be installed
                    Depends: python3-jmespath but it is not going to be installed
                    Depends: python3-urllib3 but it is not going to be installed
                    Depends: python3:any
                    Depends: python3-requests but it is not going to be installed
 python3-certbot : Depends: python3-requests but it is not going to be installed
                   Depends: python3-configobj but it is not going to be installed
                   Depends: python3-cryptography (>= 2.1.4) but it is not going to be installed
                   Depends: python3-distro but it is not going to be installed
                   Depends: python3-pkg-resources but it is not going to be installed
                   Depends: python3-rfc3339 but it is not going to be installed
                   Depends: python3-tz but it is not going to be installed
                   Depends: python3-zope.component but it is not going to be installed
                   Depends: python3-zope.interface but it is not going to be installed
                   Depends: python3:any
 python3-configargparse : Depends: python3:any
 python3-entrypoints : Depends: python3:any
 python3-firewall : Depends: gir1.2-glib-2.0 but it is not going to be installed
                    Depends: python3-gi but it is not going to be installed
                    Depends: python3-dbus but it is not going to be installed
                    Depends: python3:any
 python3-josepy : Depends: python3-cryptography (>= 0.8) but it is not going to be installed
                  Depends: python3-openssl (>= 0.13) but it is not going to be installed
                  Depends: python3-pkg-resources but it is not going to be installed
                  Depends: python3:any
 python3-mock : Depends: python3-pbr (>= 1.3) but it is not going to be installed
                Depends: python3:any
 python3-nftables : Depends: libnftables1 (= 1.0.2-1ubuntu2) but it is not going to be installed
                    Depends: python3-jsonschema but it is not going to be installed
                    Depends: python3:any
 python3-parsedatetime : Depends: python3:any
                         Recommends: python3-icu but it is not going to be installed
 python3-rsa : Depends: python3 but it is not going to be installed
               Depends: python3-pyasn1 (>= 0.1.3) but it is not going to be installed
               Depends: python3:any
 python3-s3transfer : Depends: python3:any
 python3-selinux : Depends: python3 (< 3.11) but it is not going to be installed
                   Depends: python3 (>= 3.10~) but it is not going to be installed
                   Depends: python3:any
                   Depends: libselinux1 (>= 3.1~) but it is not going to be installed
 python3-zope.event : Depends: python3-pkg-resources but it is not going to be installed
                      Depends: python3:any
 python3-zope.hookable : Depends: python3 (< 3.11) but it is not going to be installed
                         Depends: python3 (>= 3.10~) but it is not going to be installed
                         Depends: python3-pkg-resources but it is not going to be installed
                         Depends: python3:any
 qemu-guest-agent : PreDepends: init-system-helpers (>= 1.54~) but it is not going to be installed
                    Depends: libc6 (>= 2.34) but 2.31-0ubuntu9.9 is to be installed
                    Depends: libglib2.0-0 (>= 2.63.3) but it is not going to be installed
                    Depends: libudev1 (>= 183) but it is not going to be installed
                    Depends: liburing2 (>= 2.0) but it is not installable
 ri : Depends: ruby3.0 but it is not installable
      Depends: ruby3.0-doc but it is not installable
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

the upgrades installation has failed.

How may I remove/fix those dependencies in order to get the upgrades?

Thank you in advance.

My best regards.

What’d you do to your system? That’s a scary pile of dependency issues. I have no idea where to start to resolve it. Heck, why are so many things uninstallable? Did you disable some or all of the OS repositories?

Hi Joe

dunno, may you please advise how to reboot and re-install Virtualmin from the console?

Thank you in advance.

Hi Joe

may I proceed in that case (s. below attachment)?

Thank you in advance.

image

I don’t understand what you’re asking? That message means your kernel has been updated since you last rebooted the system. It has nothing to do with Virtualmin/Webmin; you updated your packages (that’s good), and now in order to use the latest kernel you’d need to reboot. Webmin is just telling you about the state of updates on your system.