Empty package repositories page on fresh VPS Install

Hi everyone,

I’ve just installed Virtualmin on my VPS, but I’m facing an issue with the package repositories. When I navigate to memeserver.com:10000/package-updates/ and click on “Package Repositories,” the page appears empty with no repositories listed.

However, when I check the repositories from the shell, they are present.

root@host:~# apt-cache policy
Package files:
 100 /var/lib/dpkg/status
     release a=now
 500 https://software.virtualmin.com/vm/7/gpl/apt virtualmin/main all Packages
     release o=. virtualmin,a=virtualmin,n=virtualmin,l=. virtualmin,c=main,b=all
     origin software.virtualmin.com
 500 https://software.virtualmin.com/vm/7/gpl/apt virtualmin/main amd64 Packages
     release o=. virtualmin,a=virtualmin,n=virtualmin,l=. virtualmin,c=main,b=amd64
     origin software.virtualmin.com
 500 https://mirror.hetzner.com/ubuntu/security noble-security/multiverse amd64 Packages
     release v=24.04,o=Ubuntu,a=noble-security,n=noble,l=Ubuntu,c=multiverse,b=amd64
     origin mirror.hetzner.com
 500 https://mirror.hetzner.com/ubuntu/security noble-security/restricted amd64 Packages
     release v=24.04,o=Ubuntu,a=noble-security,n=noble,l=Ubuntu,c=restricted,b=amd64
     origin mirror.hetzner.com
 500 https://mirror.hetzner.com/ubuntu/security noble-security/universe amd64 Packages
     release v=24.04,o=Ubuntu,a=noble-security,n=noble,l=Ubuntu,c=universe,b=amd64
     origin mirror.hetzner.com
 500 https://mirror.hetzner.com/ubuntu/security noble-security/main amd64 Packages
     release v=24.04,o=Ubuntu,a=noble-security,n=noble,l=Ubuntu,c=main,b=amd64
     origin mirror.hetzner.com
 100 https://mirror.hetzner.com/ubuntu/packages noble-backports/universe amd64 Packages
     release v=24.04,o=Ubuntu,a=noble-backports,n=noble,l=Ubuntu,c=universe,b=amd64
     origin mirror.hetzner.com
 500 https://mirror.hetzner.com/ubuntu/packages noble-updates/multiverse amd64 Packages
     release v=24.04,o=Ubuntu,a=noble-updates,n=noble,l=Ubuntu,c=multiverse,b=amd64
     origin mirror.hetzner.com
 500 https://mirror.hetzner.com/ubuntu/packages noble-updates/restricted amd64 Packages
     release v=24.04,o=Ubuntu,a=noble-updates,n=noble,l=Ubuntu,c=restricted,b=amd64
     origin mirror.hetzner.com
 500 https://mirror.hetzner.com/ubuntu/packages noble-updates/universe amd64 Packages
     release v=24.04,o=Ubuntu,a=noble-updates,n=noble,l=Ubuntu,c=universe,b=amd64
     origin mirror.hetzner.com
 500 https://mirror.hetzner.com/ubuntu/packages noble-updates/main amd64 Packages
     release v=24.04,o=Ubuntu,a=noble-updates,n=noble,l=Ubuntu,c=main,b=amd64
     origin mirror.hetzner.com
 500 https://mirror.hetzner.com/ubuntu/packages noble/multiverse amd64 Packages
     release v=24.04,o=Ubuntu,a=noble,n=noble,l=Ubuntu,c=multiverse,b=amd64
     origin mirror.hetzner.com
 500 https://mirror.hetzner.com/ubuntu/packages noble/restricted amd64 Packages
     release v=24.04,o=Ubuntu,a=noble,n=noble,l=Ubuntu,c=restricted,b=amd64
     origin mirror.hetzner.com
 500 https://mirror.hetzner.com/ubuntu/packages noble/universe amd64 Packages
     release v=24.04,o=Ubuntu,a=noble,n=noble,l=Ubuntu,c=universe,b=amd64
     origin mirror.hetzner.com
 500 https://mirror.hetzner.com/ubuntu/packages noble/main amd64 Packages
     release v=24.04,o=Ubuntu,a=noble,n=noble,l=Ubuntu,c=main,b=amd64
     origin mirror.hetzner.com
Pinned packages:
     libapache2-mod-php -> 2:8.3+93ubuntu2 with priority -1
     libapache2-mod-php8.3 -> 8.3.6-0ubuntu0.24.04.1 with priority -1
     libapache2-mod-php8.3 -> 8.3.6-0maysync1 with priority -1

Has anyone encountered this issue before? How can I resolve it?

Thanks in advance for your help!

I have not, but to be fair Ubuntu 24.04 is a bit to new for me to use, so your error maybe related to a change in configuration I guess all the source files are in /etc/apt/sources.list.d and not somewhere else ? does apt update throw any errors ?

Apt update works as expected.

in /etc/apt/sources.list there is nothing, and in /etc/apt/sources.list.d/ I can see;

root@host:~# ls /etc/apt/sources.list.d/
ubuntu.sources  virtualmin.list

I think you are right, I just uninstalled Ubuntu 24.04 from my desktop (too many issues) and reinstalled 22.04. I’m not sure, but maybe I could do the same with the VPS. However, so far the VPS hasn’t given me any problems, except for this issue with Virtualmin not seeing the repositories.

I really like the RockyLinux distro, think about installing, test and see if you agree with me.

1 Like

May be Ubuntu 24.04 is not really supported:

virtualmin setup-repos
Setting up Virtualmin software repositories ..
..error : [INFO] Log will be written to: /usr/share/webmin/virtual-server/virtualmin-install.log [INFO] Started Virtualmin 7 GPL software repositories setup ▣ Phase 1 of 1: Setup Ubuntu 24.04 is not supported by this installer.

I thing I’m going to reinstall the VPS with a less recent distro.

Sounds like a issue with your vps supplier

Although, Ubuntu 24.04 is not supported by this installerI will try and test.

Just deploying on vultr, will let you know…

Seeing no issue with install script

I see repos but no virtualmin repos

Not sure if this is normal for this OS, on rocky I see virtualmin repos.

Ubuntu yes it is

So you need cli to see the virtualmin repos?

Yep dunno why must be something to do with apt i guess

I tried again, but no luck:

virtualmin setup-repos
Setting up Virtualmin software repositories ..
..error : [INFO] Log will be written to: /usr/share/webmin/virtual-server/virtualmin-install.log [INFO] Started Virtualmin 7 GPL software repositories setup ▣ Phase 1 of 1: Setup Ubuntu 24.04 is not supported by this installer.lear

Here is the log:

Checking for HTTP client .. found /usr/bin/wget -nv
2024-07-12 11:52:16 URL:https://software.virtualmin.com/lib/slib.sh [24228/24228] -> "slib.sh" [1]
[2024-07-12 11:52:16 CEST] [INFO] Log will be written to: /usr/share/webmin/virtual-server/virtualmin-install.log
[2024-07-12 11:52:16 CEST] [DEBUG] LOG_ERRORS_FATAL=1
[2024-07-12 11:52:16 CEST] [DEBUG] LOG_LEVEL_STDOUT=INFO
[2024-07-12 11:52:16 CEST] [DEBUG] LOG_LEVEL_LOG=DEBUG
Checking for Perl .... found Perl at /usr/bin/perl
Checking for HTTP client .. found /usr/bin/wget -nv
Checking for GPG .. found GPG command
[2024-07-12 11:52:16 CEST] [INFO] Started Virtualmin 7 GPL software repositories setup
[2024-07-12 11:52:16 CEST] [DEBUG] Install mode: setup
[2024-07-12 11:52:16 CEST] [DEBUG] Product: Virtualmin GPL
[2024-07-12 11:52:16 CEST] [DEBUG] virtualmin-install.sh version: 7.3.4
[2024-07-12 11:52:16 CEST] [DEBUG] Installing serial number and license key into /etc/virtualmin-license
[2024-07-12 11:52:16 CEST] [DEBUG] Operating system name:    Ubuntu
[2024-07-12 11:52:16 CEST] [DEBUG] Operating system version: 24.04
[2024-07-12 11:52:16 CEST] [DEBUG] Operating system type:    ubuntu
[2024-07-12 11:52:16 CEST] [DEBUG] Operating system major:   24
[2024-07-12 11:52:16 CEST] [DEBUG] Configuring package manager for Ubuntu 24.04 ..

and use use this command to run script?
sudo sh -c "$(curl -fsSL https://software.virtualmin.com/gpl/scripts/virtualmin-install.sh)" -- --bundle LAMP

But this way I will reinstall Virtualmin from scratch? Will i loose something on the VPS?

I tested and it works fine, that why I asked what script your using.

I tried with no luck, the page "Package Repositories,” still appears empty.

root@host:~# sudo sh -c "$(curl -fsSL https://software.virtualmin.com/gpl/scripts/virtualmin-install.sh)" -- --setup
[INFO] Log will be written to: /root/virtualmin-install.log
[INFO] Started Virtualmin 7 GPL software repositories setup
▣ Phase 1 of 1: Setup
Downloading Virtualmin 7 key                                                 ✔ 
Installing Virtualmin 7 key                                                  ✔ 
Downloading repository metadata                                              ✔ 
Enabling universe repositories, if not already available                     ✔ 
Disabling cdrom: repositories                                                ✔ 
Cleaning up software repo metadata                                           ✔ 
[SUCCESS] Repository configuration successful. You can now install Virtualmin
[SUCCESS] components using your OS package manager.

But your not getting that error.
Sound like you used the wrong script originally if the script was erroring,

you are clicking on package repo tab as the first tab will be empty.

Wait, where’d you get the installer, @AlessioIT? 24.04 is supported.

AlessioIT was getting the error not me, my tests worked fine.

1 Like

I’ve used

sudo sh -c "$(curl -fsSL https://software.virtualmin.com/gpl/scripts/virtualmin-install.sh)" -- --bundle LAMP

The error reported " ▣ Phase 1 of 1: Setup Ubuntu 24.04 is not supported by this installer." is from:

virtualmin setup-repos

root@host:~# virtualmin setup-repos
Setting up Virtualmin software repositories ..
..error : [INFO] Log will be written to: /usr/share/webmin/virtual-server/virtualmin-install.log [INFO] Started Virtualmin 7 GPL software repositories setup ▣ Phase 1 of 1: Setup Ubuntu 24.04 is not supported by this installer.


Maybe the problem is with Hetzner? They provide a version of Ubuntu with their repositories.

I just ran a test on a newly created VPS on Hetzner with Ubuntu 24.04.

The installation script did not give any errors (except for the hostname), but the “packages repositories” page, the third tab, is empty.

I’m starting to think it might be a problem with the Hetzner provider.

Did you run check configuration?