Email sending problem

OS type and version Ubuntu Linux 22.04.4
Webmin version 2.105
Virtualmin version 7.10.0
Related packages SUGGESTED

I was not able to send any emails, don’t know that happens, everything is fine few day before but now i try sending emails it not sending. This only happens when I’m sending mails to gmail.Please help me out

Can anyone help me here?

Looks like you don’t have outgoing port 25 (i.e. Google blocked you, or your ISP/hosting provider did).

I have outgoing port 25 have a look on screenshort

And hosting provider also don’t do anything

You have connected to port 587 when telnetting to Gmail in your screenshot. You do understand that port 587 is not port 25, right?

Sorry i previous check and copy pasted, now check using port 25 please have a look


Again, you don’t have outgoing port 25. Nothing has changed about my answer because the facts remain the same.

how should i check then? can you guide me please, if i don’t have outgoing port 25 early i send emails using same IP

You can’t send emails without port 25.

You’ll need to use a relay service, such as Amazon SES, Mailgun, Mailjet, Sendgrid, whatever. There are dozens of them. They mostly have a free or cheap tier.

I connect using one of my domain does it works connecting to port 25? I’m not familer with this commands, If still the same issue we can close this forum


Should you also not redact the IP address in the screenshot, as you have the domain names?

Thankyou, done!

I assume you aren’t having problems sending mail to your own domains on the server. So, this isn’t a useful test of anything.

Okay then, Here no more discussion but I’m still thinking how i send mails previously without have port 25 lol.

Server to server needs port 25

Client to server can a couple of different ports to send email. Since STARTTLS most just use port 25.

If you were sending mails before, you had port 25. As I said in my first reply, either Google or your host has blocked you from sending. They do that if they see abuse from your IP.

You can determine if it was your host or Google specifically by testing other mail servers on the internet using the same method you used to find out Google is blocking you (telnet hostname 25 and see if it times out or issues a greeting).

I tried connecting hostname using port 25 and get this results


Does google block every outgoing mails? As i’m trying to send different email address it’s not gmail but still it’s not sending and added as queued.

All results points hosting provider block my outgoing?

Is that a hostname on the internet (i.e. not one on the same server)? If so, then it may only be Google that is blocking you. Why they’re blocking you is unknown to me, but presumably it’s because of spam/abuse from your IP.

The hostname is same on the internet and server

Then you’re not testing anything useful.

Try to connect to our server from your server:

telnet 25