Dovecot IMAP / POP3 Server shows down, but sends/receives mail?

Admins feel free to mark as as duplicate as I looked and saw there are are few dovecot postings here, but they didn’t seem to match this one. When I checked this morning Virtualmin panel Dovecot IMAP / POP3 Server shows down, clicking ‘restart’ does nothing. I can send/receive mail ok. On Webmin, clicking restart Dovecot says

Failed to start Dovecot :
Fatal: Dovecot is already running? Socket already exists: /var/run/dovecot/login/login

There is old post (Can't Start Dovecot IMAP/POP3 Server?) that describes this issue, but I am not sure if this is something that is being worked on at the moment, so I am hesitant to try anything until the experts chime in :slight_smile:

Any advice how to proceed? Happy to run stuff on the command line, just let me know what to try.


Please include your OS/version, and see this thread if your system is an upgraded Debian or Ubuntu system that has both a Dovecot initscript and a systemd unit: Dovecot Failed state

Hi Joe, thanks for replying. I installed some updates this morning which required a reboot, that seemed to fix the problem. But before I did, I tested mail again, and it worked. In case they are needed here’s what I ran:

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.04.4 LTS
Release: 18.04
Codename: bionic

$ systemctl status dovecot
dovecot.service - Dovecot IMAP/POP3 email server
Loaded: loaded (/lib/systemd/system/dovecot.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Sat 2020-05-16 01:38:28 UTC; 2 days ago
Docs: man:dovecot(1)
Process: 19093 ExecStop=/usr/bin/doveadm stop (code=exited, status=75)
Process: 994 ExecStart=/usr/sbin/dovecot -F (code=exited, status=0/SUCCESS)
Main PID: 994 (code=exited, status=0/SUCCESS)

I also am seeing this same issue…see my thread about dovecot issues here

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.